XAMPP rennt, vhost geht auch ABER... [GELÖST]

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP rennt, vhost geht auch ABER... [GELÖST]

Postby xampp4vero » 29. July 2006 16:03

Hier die Lösung:http://community.apachefriends.org/f/viewtopic.php?p=81474#81474

Hallo liebe Community,

ich hab es geschafft. XAMPP 1.5.3a läuft einwandfrei. Kann alles über das Control Panel starten und administrieren. SUPER! :D

Danach hab ich hier die sehr nützlichen leider aber auch unzähligen Beiträge zum Thema vhost gelesen und mich gleich daran gemacht einen vhost einzurichten. Und siehe da. Auch das läuft.

Einen vhost in W:\WEBSRV\xampp\apache\conf\extra\httpd-vhosts.conf ergänzt.
Code: Select all
NameVirtualHost *:80

<VirtualHost project.local:80>
    DocumentRoot W:/WEBSRV/xampp/htdocs/project.local
    ServerName project.local
</VirtualHost>


Natürlich auch die Raute # in W:\WEBSRV\xampp\apache\conf\httpd.conf entfernt.
Code: Select all
Include conf/extra/httpd-vhosts.conf


Und dann noch den DNS-Eintrag in C:\WINDOWS\system32\drivers\etc\host
Code: Select all
127.0.0.1       localhost
127.0.0.1       project.local


Folgende ULR im Browser: http://project.local/ und schon zaubert mir meine index.php das erste "Hallo Welt!" auf den Schirm. :D :D :D

ABER
Wenn ich jetzt im Control Panel auf Admin... klicke, springt der Browser auf http://localhost/ und zeigt mir wieder mein "Hallo Welt!". Ich will doch aber die XAMPP Willkommensseite sehen?!

Im error.log steht eine Warnung:
Code: Select all
[Sat Jul 29 16:56:04 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sat Jul 29 16:56:04 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sat Jul 29 16:56:06 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sat Jul 29 16:56:06 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sat Jul 29 16:56:08 2006] [notice] Apache/2.2.2 (Win32) DAV/2 mod_ssl/2.2.2 OpenSSL/0.9.8b mod_autoindex_color PHP/5.1.4 mod_perl/2.0.2 Perl/v5.8.7 configured -- resuming normal operations
[Sat Jul 29 16:56:08 2006] [notice] Server built: May  9 2006 14:08:48
[Sat Jul 29 16:56:08 2006] [notice] Parent: Created child process 3676
[Sat Jul 29 16:56:09 2006] [warn] NameVirtualHost *:80 has no VirtualHosts
[Sat Jul 29 16:56:10 2006] [warn] NameVirtualHost *:80 has no VirtualHosts
[Sat Jul 29 16:56:12 2006] [notice] Child 3676: Child process is running
[Sat Jul 29 16:56:12 2006] [notice] Child 3676: Acquired the start mutex.
[Sat Jul 29 16:56:12 2006] [notice] Child 3676: Starting 250 worker threads.
[Sat Jul 29 16:56:12 2006] [notice] Child 3676: Starting thread to listen on port 443.
[Sat Jul 29 16:56:12 2006] [notice] Child 3676: Starting thread to listen on port 80.


Wenn ich den vhost wieder entferne, den Apache aus dem Control Panel starte, und dann auf Admin... klicke, komme ich wieder zur XAMPP Willkommensseite. URL im Browser ist http://localhost/xampp/! Zwar sind die Warnungen weg, aber trotzdem habe ich noch diese Meldungen in der error.log.
Code: Select all
[Sat Jul 29 17:02:00 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sat Jul 29 17:02:00 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sat Jul 29 17:02:02 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sat Jul 29 17:02:02 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sat Jul 29 17:02:04 2006] [notice] Apache/2.2.2 (Win32) DAV/2 mod_ssl/2.2.2 OpenSSL/0.9.8b mod_autoindex_color PHP/5.1.4 mod_perl/2.0.2 Perl/v5.8.7 configured -- resuming normal operations
[Sat Jul 29 17:02:04 2006] [notice] Server built: May  9 2006 14:08:48
[Sat Jul 29 17:02:04 2006] [notice] Parent: Created child process 2636
[Sat Jul 29 17:02:09 2006] [notice] Child 2636: Child process is running
[Sat Jul 29 17:02:09 2006] [notice] Child 2636: Acquired the start mutex.
[Sat Jul 29 17:02:09 2006] [notice] Child 2636: Starting 250 worker threads.
[Sat Jul 29 17:02:09 2006] [notice] Child 2636: Starting thread to listen on port 443.
[Sat Jul 29 17:02:09 2006] [notice] Child 2636: Starting thread to listen on port 80.


Ich vermute mal, dass das zwei verschiedene Ursachen hat. Kann mir jemand sagen, wie ich trotz vhost noch die XAMPP Willkommensseiten erreichen kann? Bitte Bitte Bitte...

Vielen Dank 8) vero

Hier die Lösung:http://community.apachefriends.org/f/viewtopic.php?p=81474#81474
Last edited by xampp4vero on 29. July 2006 16:55, edited 1 time in total.
xampp4vero
 
Posts: 5
Joined: 29. July 2006 15:30

Postby Wiedmann » 29. July 2006 16:07

Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby xampp4vero » 29. July 2006 16:14

Suuuuuuuuuuper. Jetzt verstehe ich auch den Beitrag unter XAMPP FAQ http://faq.kwm-web.info/ Also einfach noch den ersten vhost auf das Standard-htdocs-Verzeichnis legen. Werde ich gleich probieren und dann hier komplett posten. Quasi als weitere vhost-Hilfe! Vielen Dank :D :D :D
xampp4vero
 
Posts: 5
Joined: 29. July 2006 15:30

Postby xampp4vero » 29. July 2006 16:35

:cry: Heul!
Nööö, geht nich'.

"Admin..." aus dem Control-Panel kommt immer noch auf http://localhost/ und zeigt mir meine "Hallo Welt!" aus W:/WEBSRV/xampp/htdocs/project.local/index.php an.

Die Warnungen von Virtual Host sind aber weg. :D
xampp4vero
 
Posts: 5
Joined: 29. July 2006 15:30

Postby xampp4vero » 29. July 2006 16:53

Ich nehme alles zurück und behaupte das Gegenteil! Ähhh?! Fast alles. In der URL steht http://localhost/. Sonst ist er weitergesprungen auf http://localhost/xampp/. :D

Mein Fehler:
Ich hatte in der ersten Zeile anstelle des "*" noch project.local geschrieben und in ServerName den Port :80 vergessen zu ergänzen. Auch ein blindes Huhn findet einmal ein Korn.

Hier also noch mal zusammengefasst:

Darauf achten, dass die Include-Zeile in der W:\WEBSRV\xampp\apache\conf\httpd.conf auskommentiert ist (Raute # entfernen):

Code: Select all
Include conf/extra/httpd-vhosts.conf


Dann den Standard VirtualHost auf das XAMPP-Verzeichnis setzen und weitere vhosts in W:\WEBSRV\xampp\apache\conf\extra\httpd-vhosts.conf ergänzen.

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    ServerName localhost:80
    DocumentRoot "W:/WEBSRV/xampp/htdocs"
    <Directory "W:/WEBSRV/xampp/htdocs">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>

<VirtualHost *:80>
    ServerName project.local:80
    DocumentRoot "W:/WEBSRV/xampp/htdocs/project.local"
    <Directory "W:/WEBSRV/xampp/htdocs/project.local">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>


Und dann noch den DNS-Eintrag in C:\WINDOWS\system32\drivers\etc\host.

Code: Select all
127.0.0.1       localhost
127.0.0.1       project.local


Die Fehlermeldungen
Code: Select all
[Sat Jul 29 17:43:21 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sat Jul 29 17:43:21 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sat Jul 29 17:43:22 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sat Jul 29 17:43:22 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sat Jul 29 17:43:24 2006] [notice] Apache/2.2.2 (Win32) DAV/2 mod_ssl/2.2.2 OpenSSL/0.9.8b mod_autoindex_color PHP/5.1.4 mod_perl/2.0.2 Perl/v5.8.7 configured -- resuming normal operations
[Sat Jul 29 17:43:24 2006] [notice] Server built: May  9 2006 14:08:48
[Sat Jul 29 17:43:24 2006] [notice] Parent: Created child process 2988
[Sat Jul 29 17:43:27 2006] [notice] Child 2988: Child process is running
[Sat Jul 29 17:43:27 2006] [notice] Child 2988: Acquired the start mutex.
[Sat Jul 29 17:43:27 2006] [notice] Child 2988: Starting 250 worker threads.
[Sat Jul 29 17:43:27 2006] [notice] Child 2988: Starting thread to listen on port 443.
[Sat Jul 29 17:43:27 2006] [notice] Child 2988: Starting thread to listen on port 80.
bekomme ich aber nicht weg.

Vielen Dank :D :D :D
xampp4vero
 
Posts: 5
Joined: 29. July 2006 15:30

Postby Wiedmann » 29. July 2006 17:05

Die Fehlermeldungen
Code: Select all
[Sat Jul 29 17:43:21 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sat Jul 29 17:43:21 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sat Jul 29 17:43:22 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sat Jul 29 17:43:22 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null

bekomme ich aber nicht weg.

Die kommen vom Control Panel. Kannst also nichts dagegen machen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests