vhost einrichten, aber wie?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

vhost einrichten, aber wie?

Postby garnetz » 26. July 2006 13:12

Hallo, nachdem das mit meinem zweiten Server nicht so richtig geklappt hat, möchte ich mir einen zweiten virtuellen Host einrichten. Das habe ich in meine httpd.conf geschrieben:

#NameVirtualHost *

<VirtualHost *:80>
ServerName localhost
DocumentRoot C:/apachefriends/xampp/htdocs
</VirtualHost>

<VirtualHost *:80>
ServerName localhero
DocumentRoot C:/apachefriends/xampp/htdocs2
</VirtualHost>

so sieht meine Datei HOSTS aus:

# localhost: Needs to stay like this to work
127.0.0.1 localhost
127.0.0.1 localhero

Rufe ich nun http://localhero auf, so bekomme ich den Inhalt von localhost angezeigt.

Wo liegt da der Fehler? :?
Kann jemand helfen?
Vielen Dank
garnetz
garnetz
 
Posts: 25
Joined: 14. July 2006 09:15

Postby kleinweby » 26. July 2006 13:23

moin,

entferne mal die Raute(#) vor NameVirtualHost * .
Dann sollte es gehen.

kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Postby Wiedmann » 26. July 2006 14:14

a) das von "Kleinweby".
und b) musst du natürlich noch den Zugriff auf das Verzeichnis (DocumentRoot) vom VHost erlauben.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Document Root vhosts

Postby technet » 28. July 2006 09:00

Hallo Wiedmann,

Habe das selbe Problem,
Wie gewährt man den Zugriff auf das Verzeichnis (DocumentRoot) vom
VHost??


danke im voraus

grüsse technet
technet
 
Posts: 17
Joined: 20. January 2006 11:16
Location: Zuerich

Postby Wiedmann » 28. July 2006 14:07

Zugriff gewährt man mit "Allow from ...".
Und wenn das für ein Verzeichnis gelten soll, dann macht man das innerhalb von einem "<Directory>"-Block wo man das Verzeichnis angibt.

Beispiele daui findest du ja in der "http.conf". Insbesondere da, wo das für's DocumentRoot vom Hauptserver gemacht wird.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby garnetz » 29. July 2006 13:09

Vielen Dank erstmal für eure Hilfe.
Leider bin ich ein absoluter Nicht-Könner in diesem Bereich.
Zugriff gewährt man mit "Allow from ...".
Und wenn das für ein Verzeichnis gelten soll, dann macht man das innerhalb von einem "<Directory>"-Block wo man das Verzeichnis angibt.

Beispiele daui findest du ja in der "http.conf". Insbesondere da, wo das für's DocumentRoot vom Hauptserver gemacht wird.

Wo und was genau muss ich schreiben?
Könnte mir das vielleicht noch einer ganz kurz sagen :oops: ?

Danke an alle Könner
garnetz
garnetz
 
Posts: 25
Joined: 14. July 2006 09:15

Postby garnetz » 31. July 2006 14:31

So, nachdem ich nun viel hier gelesen habe sieht meine httpd.conf folgendermaßen aus:
NameVirtualHost *

<VirtualHost *:80>

ServerName localhost
DocumentRoot C:/apachefriends/xampp/htdocs

<Directory "C:/apachefriends/xampp/htdocs">
Order Allow,Deny
Allow from all
#Options All
#AllowOverride All
</Directory>

</VirtualHost>



<VirtualHost *:80>

ServerName localhero
DocumentRoot C:/apachefriends/xampp/htdocs2
<Directory "C:/apachefriends/xampp/htdocs2">
Order Allow,Deny
Allow from all
#Options All
#AllowOverride All
</Directory>

</VirtualHost>

Und nun bekomme ich beim Start des apache diese Meldung:

[Mon Jul 31 15:01:44 2006] [error] VirtualHost *:80 -- mixing * ports and non-*
ports with a NameVirtualHost address is not supported, proceeding with undefined
results
[Mon Jul 31 15:01:44 2006] [error] VirtualHost *:80 -- mixing * ports and non-*
ports with a NameVirtualHost address is not supported, proceeding with undefined
results
[Mon Jul 31 15:01:44 2006] [error] VirtualHost _default_:443 -- mixing * ports a
nd non-* ports with a NameVirtualHost address is not supported, proceeding with
undefined results

Vielleicht kann jemand damit etwas anfangen :? ?

Danke
garnetz
garnetz
 
Posts: 25
Joined: 14. July 2006 09:15

Postby Wiedmann » 31. July 2006 14:45

Code: Select all
NameVirtualHost *

<VirtualHost *:80>

Was stimmt hier nicht überein?

Schau dir das Beispiel wo du deinen Code herhast nochmal genau an...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby garnetz » 31. July 2006 14:52

DANKE!!! :D :D :D

Ihr seid die Größten in meinen Augen!

garnetz
garnetz
 
Posts: 25
Joined: 14. July 2006 09:15


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests