vitual host und cgi-bin

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

vitual host und cgi-bin

Postby lugau45 » 11. July 2006 23:29

hallo zusammen,

ich habe xampp am laufen mit einigen virtual hosts und geht auch alles super. nun habe ich ein problem mit cgi-bin. wie kann man bei den einzelnen vitualen hosts den cgi-bin ordner in das verzeichniss integrieren?

(ich schreibe immer klein!)
irgendwas ist ja immer...
Skype me...
User avatar
lugau45
 
Posts: 106
Joined: 25. July 2004 10:31

Postby Wiedmann » 11. July 2006 23:34

wie kann man bei den einzelnen vitualen hosts den cgi-bin ordner in das verzeichniss integrieren?

Welchen cgi-bin Ordner?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby lugau45 » 11. July 2006 23:37

C:\Programme\xampp\cgi-bin

dort kann man doch seine datein ablegen oder nicht? wenn ich vhost habe komme ich ja immer gleich in das im vhost definierte verzeichniss kann ich da auch ein cgi-bin ordner mach? wenn ja was muss ich in der httpd-vhosts.conf eintragen? und noch nebenbei wie kann ich dateien (anderer rechner ohne vhost) im cgi-bin ordner starten?

habe schon das mit in den vhost eingetragen:
Code: Select all
    <Location /cgi-bin>
        Options +ExecCGI
        Action application/x-httpd-php /php4/php.exe
        Order allow,deny
        Allow from all
    </Location>
</VirtualHost>

aber geht auch nicht.
irgendwas ist ja immer...
Skype me...
User avatar
lugau45
 
Posts: 106
Joined: 25. July 2004 10:31

Postby Wiedmann » 11. July 2006 23:51

Das:
Wiedmann wrote:Welchen cgi-bin Ordner?

C:\Programme\xampp\cgi-bin

und das:
wenn ich vhost habe komme ich ja immer gleich in das im vhost definierte verzeichniss kann ich da auch ein cgi-bin ordner mach?

wiederspricht sich aber.

Möchtest du:
a) in jedem VHost für die URI "/cgi-bin/" das eine Verzeichnis "C:\Programme\xampp\cgi-bin" benutzen?
--> dann musst du nichts machen

b) in jedem VHost ein separates Verzeichnis für die URI "/cgi-bin/" benutzen?
--> dann musst du für jeden (weiteren) VHost das cgi-bin separat konfiguriern. Genauso wie es für den Hauptserver (1. VHost) in der "httpd.conf" gemacht wird, nur jeweils halt den Verzeichnisnamen anpassen.

und noch nebenbei wie kann ich dateien (anderer rechner ohne vhost) im cgi-bin ordner starten?

:?:
Versteh ich nicht ganz. Scripte/Dateien werden immer gleich gestartet:
Protokoll + Server + Location + Scriptname
--> z.B.: "http://localhost/cgi-bin/script.pl"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby lugau45 » 12. July 2006 08:33

hallo,

wenn ich dich richtig verstehe kann ich aus der httpd-vhosts.conf (siehe oben)
Code: Select all
<Location /cgi-bin>
        Options +ExecCGI
        Action application/x-httpd-php /php4/php.exe
        Order allow,deny
        Allow from all
    </Location>
</VirtualHost>

rausnehmen. muss ich also in der httpd.conf etwas ändern. ja ich möchte für jedes verzeichniss ein cgi-bin ordner. könntest du noch bitte schreiben wo ich das in der httpd.conf eintragen muss?
irgendwas ist ja immer...
Skype me...
User avatar
lugau45
 
Posts: 106
Joined: 25. July 2004 10:31

Postby Stefan » 12. July 2006 13:09

Mahlzeit,

mach mal einen reset auf die VHosts und suche in der httpd.conf die Einträge die das mit dem cgikram regeln. Post mal hier was Du gefunden hast und was Du daraus lesen kannst.

ciao, Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby deepsurfer » 12. July 2006 13:17

Code: Select all
<VirtualHost *:80>
    ServerName dummydomain.biz
    ServerAlias www.dummydomain.biz
    ServerAdmin webmaster@localhost
    DocumentRoot c:/apachefriends/xampp/htdocs/webpfad
    ErrorLog c:/apachefriends/xampp/htdocs/webpfad/logs/error.log
    CustomLog c:/apachefriends/xampp/htdocs/webpfad/logs/access.log common

    ScriptAlias /cgi-bin/ "c:/apachefriends/xampp/htdocs/webpfad/cgi-bin/"

<Directory "c:/apachefriends/xampp/htdocs/webpfad">
AllowOverride All
        Options Indexes FollowSymLinks ExecCGI
        Order allow,deny
        Allow from all
</Directory>
</VirtualHost>
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby lugau45 » 12. July 2006 21:11

Stefan wrote:Mahlzeit,

mach mal einen reset auf die VHosts und suche in der httpd.conf die Einträge die das mit dem cgikram regeln. Post mal hier was Du gefunden hast und was Du daraus lesen kannst.

ciao, Stefan


httpd.conf:

also zeile 350 bis 363
Code: Select all
   #ScriptAlias /cgi-bin/ "C:/Programme/xampp/cgi-bin/"

</IfModule>

#
# "C:/Programme/xampp/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "C:/Programme/xampp/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>

zeile 444-447
Code: Select all
# To use CGI scripts outside of ScriptAliased directories:
    # (You will also need to add "ExecCGI" to the "Options" directive.)
    #
    AddHandler cgi-script .cgi


vhost:


Code: Select all
<VirtualHost *:80>
    ServerName verzeichniss.waldhufe.dyndns.org
    ServerAlias http://verzeichniss.waldhufe.dyndns.org
    ServerAdmin server@domain.de
    DocumentRoot E:/webserver/verzeichniss
   
    ScriptAlias /cgi-bin/ "E:/webserver/verzeichniss/cgi-bin/"

<Directory "E:/webserver/verzeichniss">
AllowOverride All
        Options Indexes FollowSymLinks ExecCGI
        Order allow,deny
        Allow from all
</Directory>
</VirtualHost>
irgendwas ist ja immer...
Skype me...
User avatar
lugau45
 
Posts: 106
Joined: 25. July 2004 10:31

Postby Stefan » 13. July 2006 12:25

Servus, klappt oder?

Noch ein Tipp.
Wenn E auch die Partition ist, auf der der Server liegt, kannst Du
statt "E:/webserver/verzeichniss" auch "/webserver/verzeichniss" benutzen.

viel Spaß noch damit, ciao
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby lugau45 » 13. July 2006 16:16

nee geht nicht mit dem cgi-bin ordner das ist es ja.
irgendwas ist ja immer...
Skype me...
User avatar
lugau45
 
Posts: 106
Joined: 25. July 2004 10:31

Postby deepsurfer » 17. July 2006 09:48

lugau45 wrote:nee geht nicht mit dem cgi-bin ordner das ist es ja.

Wie ?? geht nicht ..... <grübel> ....
Schau mal in die Apache-logfiles ob da der Aufruf des CGI vermerkt wird und wie er das berücksichtigt.

Denn Ausgehend von einer XAMPP-Grundinstallation brauch ich nur im VHOST den ScriptAlias einfügen mit dem Pfad verweis und schon laufen die Perl-Scripte in dem definierten Verzeichnis des VHOST.

<grübel>

Wenn du *.pl Perlscripte hast müsstest du in httpd.conf Zeile 447 etwas hinzufügen.
AddHandler cgi-script .cgi .pl

Du hattest nicht beschrieben ob Deine Scripte im \xampp\cgi-bin funktionieren, sollte es dort auch nicht gehen so schaue bitte auf die SHEBANG Zeile der Scripte (die allererste Zeile eines Ausführbaren Perlscript muss den korrekten Pfad zum Perl-Parser aufweisen.)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby lugau45 » 17. July 2006 10:19

geht jetzt alles war ein fehler von den scripten ich musste doch noch im script die per.exe angeben.

danke für die hilfen.
irgendwas ist ja immer...
Skype me...
User avatar
lugau45
 
Posts: 106
Joined: 25. July 2004 10:31


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests