Problem mit Aliases

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit Aliases

Postby Bubo » 11. July 2006 13:21

Moin moin,
ich hatte bisher xampp in der Version xampp-win32-1.5.0 installiert und schätze daran, dass ich keine Kenntnisse bzgl. Apache etc. haben muss. Der Alias wurde in der httpd.conf eingegeben und alles lief unter localhost.

Nun habe ich heute die Version xampp-win32-1.5.3a installiert und musste feststellen, dass die httpd.conf völlig anders aussieht und ich es nicht mehr zum laufen bekomme .

Bisher habe ich in der Datei hier meinen Alias eingegeben:
Code: Select all
# Aliases: Add here as many aliases as you need (with no limit). The format is
# Alias fakename realname
#
#...........#
Alias /icons/ "C:/Program Files/xampp/apache/icons/"
alias /meinepage E:/meinepage


Wo mache ich diese Einstellung nun in der neuen Version?

Vielen Dank und
LG
Sandra
Bubo
 
Posts: 8
Joined: 11. July 2006 13:11
Location: Basel

Postby Wiedmann » 11. July 2006 13:24

Wo mache ich diese Einstellung nun in der neuen Version?

Eine Alias legt man z.B. in der "httpd.conf" an. Da hat sich nichts zwischen dem alten und neuen Apache geändert.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Bubo » 11. July 2006 13:28

Wiedmann wrote:Eine Alias legt man z.B. in der "httpd.conf" an. Da hat sich nichts zwischen dem alten und neuen Apache geändert.


Aber wo :roll:

Die "alte" httpd.conf war 37kb gross, die "neue" nur noch 20kb und ich finde den oben angeführten Abschnitt nicht mehr.
Wenn ich den alias irgendwo reinschreibe, bekomme ich einen "Access denied" Fehler :(

Danke,
Sandra
Bubo
 
Posts: 8
Joined: 11. July 2006 13:11
Location: Basel

Postby Wiedmann » 11. July 2006 13:36

Aber wo

Im Prinzip wo immer du willst.

Wenn ich den alias irgendwo reinschreibe, bekomme ich einen "Access denied" Fehler

Da das Ziel (Directory) deines Aliases ausserhalb vom DocumentRoot liegt, musst du natürlich erlauben, dass jemand auf dieses Directory zugreifen darf.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Bubo » 11. July 2006 13:43

Sorry, aber so etwas habe ich in der alten Version nicht machen müssen :oops: Anpassen der httpd.conf mit dem alias, fertig.

Aber egal, ich kenne mich nicht aus und werde wieder die alte Version xampp-win32-1.5.0 installieren; da geht es ja :)

Trotzdem vielen Dank für Deine Mühe und
LG
Sandra
Bubo
 
Posts: 8
Joined: 11. July 2006 13:11
Location: Basel

Postby Wiedmann » 11. July 2006 14:54

Sorry, aber so etwas habe ich in der alten Version nicht machen müssen

Yup. Die alte Version war dahingehend wirklich fehlerhaft vorkonfiguriert.

Beispiel wie das geht gibt es aber einige in den Config-Dateien vom Apache:
Wiedmann wrote:Da das Ziel (Directory) deines Aliases ausserhalb vom DocumentRoot liegt

Code: Select all
Alias /meinepage "E:/meinepage/"

Wiedmann wrote:musst du natürlich erlauben, dass jemand auf dieses Directory zugreifen darf.

Code: Select all
<Directory "E:/meinepage/">
    Order allow,deny
    Allow from all
    AllowOverride All
    Options Indexes FollowSymLinks Includes ExecCGI
</Directory>

(Wichtig sind hier die ersten 2 Angaben für das Directory)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Bubo » 11. July 2006 16:05

Danke für Deine Geduld, jetzt klappt's!
Musste noch die .htaccess anpassen, aber das war dann mal kein Problem :D

Ich schätze xampp gerade deshalb, weil man so gut wie keine Apache-Kenntnisse benötigt - ich will ja nur einen localhost, um meine Homepage erstmal zu testen, bevor sie online geht und keinen eigenen Server betreiben :shock:

Vielen lieben Dank und
Gruss aus Basel,
Sandra
Bubo
 
Posts: 8
Joined: 11. July 2006 13:11
Location: Basel


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests