Berechtigungsproblem

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Berechtigungsproblem

Postby revillo » 03. July 2006 23:08

Ich habe einen kleinen Home Server auf welchem w2k und ein Xampp Apache Server laufen.

Mit der Installation vom Joomla hatte ich keinerlei Prolbeme. Der Check bei der Installation (Rechte der Verzeichnisse, Safemode usw.) klappte problemlos und entsprach den 'Recommended' Settings.

Ich wollte dann eine neues Usermenu erstellen und erhielt die Meldung

Warning: require_once(X:/.../xampp/htdocs/administrator/components/com_menus/
content_archive_section/content_archive_section.menu.php) [function.require-once]: failed to open stream: Permission denied in X:\...\xampp\htdocs\administrator\components\com_menus\admin.menus.php on line 292

Fatal error: require_once() [function.require]: Failed opening required 'X:/.../xampp/htdocs/administrator/components/com_menus/content_archive_section/
content_archive_section.menu.php' (include_path='.;X:\...\xampp\php\pear\') in X:\...\xampp\htdocs\administrator\components\com_menus\admin.menus.php on line 292

Ich habe dann den MamboXplorer heruntergeladen und wollte mit diesem die Rechte der Dateien und Verzeichnisse abändern. Ich habe mittels googlen erfahren, dass damit die Dateirechte geändert werden können.

Mit AceFTP hab ichs ebenfalls versucht, da sind aber die CHMOD-Kästchen alle grau hinterlegt und nicht editierbar..

Ich hab dann mittels googeln und Foren herausgefunden, dass es etwas mit dem Benutzer nobody von Apache zu tun hat... kann mir jemand mehr darüber sagen?? kann ich die Zugriffsberechtigung ändern??

Greetz
Revillo
revillo
 
Posts: 3
Joined: 03. July 2006 22:35

Postby deepsurfer » 04. July 2006 18:46

Mit AceFTP hab ichs ebenfalls versucht, da sind aber die CHMOD-Kästchen alle grau hinterlegt und nicht editierbar..

Richtig, denn das "CHMOD" kennt Windows nicht und von daher kann es auch nicht angewandt werden.

Ich hab dann mittels googeln und Foren herausgefunden, dass es etwas mit dem Benutzer nobody von Apache zu tun hat... kann mir jemand mehr darüber sagen?? kann ich die Zugriffsberechtigung ändern??

Was auch nur zum teil stimmt, da "nobody" beim Windows System nicht existiert und die Rechte Zuweisung beim Win-Apache anders läuft.

Schau dazu am besten im Joomla Forum nach ob es noch mehr leute gibt die diesen Fehler haben.
Die bisherigen Joomla Installs die ich auf einem Windows System (teilweise auch mit XAMPP) gemacht habe führten nicht zu diesen Meldungen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Linux rules....

Postby revillo » 04. July 2006 19:59

Danke für deine Erläuterungen...leider hab ich bereits mehrere Joomla-Foren, auch englische, durchsucht...aber die konnten mir auch nur sagen, dass etwas mit den Rechten nicht stimmt..

Ich hab jetz rasch n' linux mit Xampp aufgesetzt.. jetzt läuft's tadellos...

Mir wärs halt einfacher, das ganze auf dem Windows server laufen zu lassen, da ich auf diesem einige Benötigte Platten per FTP freigegeben hab..

Wenn ich meinen Router umkonfiguriere (FTP-Port auf den Linux PC leite) kann ich nicht über FTP auf den Webserver zugreiffen...

Naja....Geduld ist zeitlos...vielleicht stollpere ich mal über ne Lösung

thx
revillo
revillo
 
Posts: 3
Joined: 03. July 2006 22:35

Postby martinpre » 05. July 2006 10:59

vielleicht safemode?
das war damals nämlich immer mein problem mit joomla.
martinpre
 
Posts: 405
Joined: 22. May 2006 16:14
Location: Nähe Tulln / Österreich

.

Postby revillo » 05. July 2006 19:59

ne, dass leider nicht.. hab ich auf off..

muss irgendwas mit den schreibrechten zu tun haben...aber danke..
revillo
 
Posts: 3
Joined: 03. July 2006 22:35


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests