Mail will einfach nicht funktionieren....

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Mail will einfach nicht funktionieren....

Postby Gast » 30. July 2003 13:02

Hallo,

ich habe mir das aktuelle XAMPP gezogen und installiert und bin total begeistert wie toll die Jungs das hinbekommen haben....(das beste, keine Registryeinträge usw.!!!!), leider gibt es aber offenbar ein Problem mit Mail und ich finde einfach keine Lösung, hoffe ihr könnt mir weiterhelfen.

Es läuft bei mir alles, also Apache, MySQL, PHP und PHPAdmin.
Mercury habe ich nicht am laufen, da ich direkt von meinem POP3-Account bei 1und1 mir meine eMails holen will.

Habe dann phproject installiert und auch das läuft, allerdings wollte ich mir dort einen eMail-Account einrichten (POP3) um meine eMails bei meinem Account bei 1und1 abzuholen, jedoch gab es in den Mailsettings keinen Button um einen Account einzurichten, obwohl in der Anleitung steht das da einer sein müsste. Hab leider nix gefunden bei phproject (Forum, FAQ usw.) zu diesem Problem. Habe dann auch noch TUTOS installiert und hier bekomme ich nun folgende Fehlermeldung:
"Disabled mailboxes (IMAP not supported by this PHP)
Please change php/mailbox/mconfig.pinc : $tutos[usemailboxes] = 0;"
Das ganze macht mich nun doch sehr stutzig und lässt mich vermuten das es gar kein Problem von phproject oder tutos ist, sondern rührt vermutlich schon von der xampp (windows) Installation her.

Ich finde nirgend wo etwas wo ich einstellen kann ob pop3 oder imap verwendet werden kann/muss/soll. Da die Fehlermeldung etwas von PHP schreibt, dachte ich, ich finde irgendwo in php.ini usw. etwas, aber auch nix.

Nun komme ich nicht mehr weiter und hoffe ihr könnt mir irgendwie weiterhelfen.

Muss ich vielleicht bei Apache etwas einstellen?

Ich will einfach nur POP3 (kein IMAP!) verwenden und mit den vorhandenen Mailmodulen bei xampp(win)/phproject/tutos (wichtig ist mir, das es z.B. mit TUTOS funktioniert, da cih wohl dieses Programm in Zukunft verwenden werde) meinen Account einrichten, sodass meine Mails bei meinem Internetprovider abgeholt werden.
Mercury will ich nicht verwenden (ich werde wohl irgendwann mal Winroute verwenden, hab es auch schon eingerichtet, aber derzeit den Winroute-Mailserver noch deaktiviert, will erstmal den "einfachen" direkten Zugriff auf meinen Internet-EMail-Account schaffen).

Gruß Eddy
Gast
 

Ähnliches Problem

Postby dracan » 07. August 2003 20:56

Also das wird wohl an der fehlenden imap Unterstützung liegen oder an 1und1!

Versuche ein phpscript zu proggen um mails direkt in eine mysql-db zu schreiben. Teste das auch mit nem 1und1 acount;-)

also ich habe in der php.ini schon die extension=php_imap.dll - aktiviert!

Code: Select all
$mailbox = imap_open("{".$host."}INBOX","$user","$passwort");

Warning: Couldn't open stream {pop3.1und1.com} in d:\wampp13cs\htdocs\mail_selbst_progi\mail.php on line 10

usw. usw.
dracan
 

Postby dracan » 07. August 2003 22:04

Hi hatte nen Fehler- das teil heisst pop.1und1.com

laäuft alles prima - also einfach in die php.ini und das Kommentar vor

extension=php_imap.dll


wegmachen
dracan
 


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests