Perl-Skript wird nicht ausgeführt,sondern im Editor geöffnet

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Perl-Skript wird nicht ausgeführt,sondern im Editor geöffnet

Postby forap » 29. June 2006 13:07

Moin,
habe mir nach jahrelanger Abstinenz den neuen Apache-Server unter Win XP installiert.
Erst mal Entschuldigung, falls an falsche Steller gepostet. das Ergebnis der Installation war das Verzeichnis XAMPP und darunter Apache, also Thema Apache oder XAMPP ?
Jetzt habe ich folgendes Problem:
Ich habe meine cgi-bin angelegt unter
D:\XAMPP\htdocs\mycgi-bin\
Wenn ich ein Perl-Programm in diesem Ordner aufrufe mit
http://localhost/mycgi-bin/prog1.pl
so wird es mit dem Text-Editor geöffnet.
Hat es die Endung cgi wird es ausgeführt.
Ich bin mir aber ganz sicher, dass in meiner früheren Version auch die *.pl Programme ausgeführt wurden.
Wahrscheinlich ist es nur eine Parameter-Angabe, allerdings weiß ich nicht (mehr), wo ?
Es sollen pl- und cgi-Dateien gleich behandelt werden!
Danke !
forap
 
Posts: 29
Joined: 29. June 2006 12:32

Postby forap » 29. June 2006 13:19

Korrektur!
Das Programm wird im Internet Explorer geöffnet, aber es wird der Quelltext angezeigt !
forap
 
Posts: 29
Joined: 29. June 2006 12:32

Postby deepsurfer » 29. June 2006 13:32

Jo, wurde in der BETAphase übersehen.

Ausgehend von XAMPP Version 1.5.3(a) in der httpd.conf Zeile 421
AddHandler cgi-script .cgi
erweitern
AddHandler cgi-script .cgi .pl

Abspeichern, xampp-apache neu starten, testen und melden

Desweiteren beschreibst du das Verzeichnis mycgi-bin
also hattest du in der httpd.conf schon was geändert bzw. hinzugefügt, oder benutzt du VHOST !?!?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby forap » 29. June 2006 15:01

<<AddHandler cgi-script .cgi .pl
<<Abspeichern, xampp-apache neu starten, testen und melden

Habe ich gemacht.

<<Desweiteren beschreibst du das Verzeichnis <<mycgi-bin
<<also hattest du in der httpd.conf schon was geändert bzw. hinzugefügt, <<oder benutzt du VHOST !?!?

Nein, habe zuvor nichts geändert. Mir ist aber aufgefallen, dass ich in der früheren Version die httpd.conf nicht geändert hatte und trotzdem liefen die Scripts !?
VHOST sagt mir nichts, daher nehme ich an, dass ich es nicht verwende.

Ich habe jetzt noch in der httpd.conf ohne Erfolg herumgeändert - wohl weil ich die Syntax nicht verstehe. Es kommt beim Start des Servers die Meldung:

"ScriptAlias takes two arguments, a fakename and a realname".

Hier die beiden vorgenommenen Änderungen:

# ScriptAlias /cgi-bin/ "/xampp/cgi-bin/" <============ geändert =======================
ScriptAlias /cgi-bin/ "/xampp/htdocs/mycgi-bin/"
</IfModule>

#
# "/xampp/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "/xampp/cgi-bin"> <================= geändert =========================
<Directory "/xampp/htdocs/mycgi-bin">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>
forap
 
Posts: 29
Joined: 29. June 2006 12:32

Postby deepsurfer » 29. June 2006 15:38

Wie sieht die allererste Zeile deines *.pl Script aus ?
Den so genannten "shebang" der den pfad zum perl interpreter beinhaltet.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby forap » 29. June 2006 16:05

Der Pfad ist
#!d:\xampp\perl\bin\perl.exe -w


Er ist korrekt (getestet mit Start/Ausführen)
Gruß
Forap
forap
 
Posts: 29
Joined: 29. June 2006 12:32

Postby forap » 29. June 2006 17:08

Habe Apache neu installiert und zwar auf Laufwerk C:
Jetzt funktioniert es !
Danke
forap
 
Posts: 29
Joined: 29. June 2006 12:32


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests