Problem bei mehreren Virtualhosts

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem bei mehreren Virtualhosts

Postby phpfuchs » 27. June 2006 22:48

Ich benutze die derzeit neueste Version von xampp.

Ich will mehrere verschiedene VirtualHosts anlegen aber es funktioniert nicht richtig.

Ich habe im httpd.conf folgende Zeilen hinzugefügt:

Code: Select all
<Directory "D:/www/test">
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

<VirtualHost test>
  ServerName test
  ServerAlias test
  DocumentRoot "D:/www/test"
</VirtualHost>

<Directory "C:/Programme/xampp/htdocs/xampp">
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

<VirtualHost xampp>
  ServerName xampp
  ServerAlias xampp
  DocumentRoot "C:/Programme/xampp/htdocs/xampp"
</VirtualHost>


Die Eintrage in der hosts-Datei ist richtig:
Code: Select all
127.0.0.1       test
127.0.0.1       xampp


Wenn ich den Apache neu starte, und im Browser http://xampp eingebe, sollte ich eigentlich dee XAMPP-Oberfläche sehen, bekomme jedoch die Seiten vom Testserver.

Vertausche ich die VirtualHosts-Einträge, starte Apache neu und gebe im Browser, bekomme ich bei http://test und bei http://xampp die XAMPP-Oberfläche.

Was mache ich falsch, warum haben beide VirtualHosts immer dasselbe DocumentRoot?
phpfuchs
 
Posts: 5
Joined: 27. June 2006 22:29

Postby deepsurfer » 29. June 2006 09:53

Ich habe im httpd.conf folgende Zeilen hinzugefügt:

Zwar möglich, aber wenn die hälfte fehlt kann es nicht funktionieren.
Ansonsten den Modularen aufbau von Apache benutzen, somit ergibt sich die VHOST geschichte im Pfad \xampp\apache\conf\extras in Datei
httpd-vhosts.conf

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
  ServerName test
  ServerAlias test
  DocumentRoot D:/www/test

<Directory "D:/www/test">
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
  ServerName xampp
  ServerAlias xampp
  DocumentRoot C:/Programme/xampp/htdocs/xampp

<Directory "C:/Programme/xampp/htdocs/xampp">
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>
</VirtualHost>


An den HOSTS einträgen ist nicht zu bemängeln ;)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests