alte XAMPP Versionen + PHP/PEAR-Binding 1.53a

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

alte XAMPP Versionen + PHP/PEAR-Binding 1.53a

Postby ScriptTeddy » 23. June 2006 20:19

Hallo,

Es ist mein erster Beitrag in diesem Forum und starte mit 2 Fragen:

1. Wo bekommt man aeltere XAMPP Versionen her :?: Ich suche eine mit mgl. ausgereifter MySQL4.1-Version und ausgereifter Apache2.0, z.B. 1.4.16. Entweder hatte ich beim Suchen Tomaten :oops: auf den Augen oder es scheint wirklich nur fuer Insider zugaenglich zu sein.

2. Ich hatte gestern das erste mal XAMPP (v1.53a) ausprobiert und hatte Probleme bei der PEAR-Integration. Wollte es dann mit 1. lösen, da nicht gefunden, bin ich wieder zu Einzelinstallation übergegangen. Wuerde mich aber freuen, wenn ich es mit Eurer Hilfe aufarbeiten könnte:
- phpinfo per CLI ja, per Web nein (lehres schnell zurückkommendes Fenster)
- das Binding zum PEAR funktionierte bei mir nicht, sowohl V4 als auch V5 + sowohl CLI als Web-Call: Fehlermeldung "call to undefined function" aus wo anders lauffaehigen Applikation und Testscripten, Bsp mysql_connect(), mysql_pconnect()
- erst ohne, dann mit entsprechend gesetzten Systemvariablen PATH, PHPRC, MIBDIRS + Reboots, an Extensions nur noch snmp+sockets hinzugenommen, mysql war eh schon aktiviert.

Installationsdoku habe ich gelesen und ich denke auch keinen Schritt ausgelassen zu haben, nur was fehlte der PHP-Umgebung, damit es die PEAR-Funktionen kennt und warum ist das go-pear nur im PHP4-Pfad zu finden?


Noch ein Hinweis: einige PHP-dll's im XAMPP1.53a sind noch auf die Visual-C RunTime Lib (MSVCR71.dll) angewiesen. PHP4 gibt noch einige DLL-Warnings mehr aus. Ist bestimmt nicht gewollt :roll: Rechner war ein frisch aufgesetztes XP.


vg, Steffen
ScriptTeddy
 
Posts: 2
Joined: 23. June 2006 16:39

Postby Wiedmann » 23. June 2006 20:33

1. Wo bekommt man aeltere XAMPP Versionen her

Steht auf der Projectseite. (Ansonsten überleg mal, von wo du XAMPP eigentlich genau runtergeladen hast...)

Ich suche eine mit mgl. ausgereifter MySQL4.1-Version und ausgereifter Apache2.0, z.B. 1.4.16.

Was wo drin ist, findest du z.B. in der XAMPP FAQ.

2. Ich hatte gestern das erste mal XAMPP (v1.53a) ausprobiert und hatte Probleme bei der PEAR-Integration.

:?:
PEAR ist doch beim XAMPP schon dabei?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

mit XAMPP 1.5.2 kann geholfen werden

Postby knutwilli » 23. June 2006 20:36

mit XAMPP 1.5.2 kann geholfen werden.

Ich habe mit 1.5.2. begonnen und die originalen downloads im download-Verzeichnis aufgehoben.
Bei Bedarf bitte email an knut@schlanert.de
alles gelingt - irgendwann
knutwilli
 
Posts: 21
Joined: 02. June 2006 04:45
Location: Berlin

Re: mit XAMPP 1.5.2 kann geholfen werden

Postby deepsurfer » 24. June 2006 12:27

knutwilli wrote:mit XAMPP 1.5.2 kann geholfen werden.

Ich habe mit 1.5.2. begonnen und die originalen downloads im download-Verzeichnis aufgehoben.
Bei Bedarf bitte email an knut@schlanert.de


Komisch bei SourceForge ist doch alles vorhanden, ok ausser die uralten WAMPP sachen..
http://faq.kwm-web.info/doku.php?id=xam ... und_inhalt
dort steht nach der Auswahl auch der Download LINK...
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby ScriptTeddy » 26. June 2006 10:57

Hallo,

Danke fuer die Tips:
http://sourceforge.net ist die Loesung, auch die 1.5.2er Version ist drin.
War das mit der 1.5.2er Version so gemeint, PHP-Problem 1.53a bekannt - geh auf Xampp1.52?

Ja - Xampp Versionsmaps findet man recht gut im Google, war jetzt auch nicht das eigentliche Problem - dachte mir vielleicht bestaetigt jemand nur noch mal ja 1.4.16 ist genau die Version fuer A2.0 + M4.1 oder nimm die :wink: Nur verlinken die ergoogleten Fremdseiten mit XAMPP-Versionsbeschreibungen fuer den Download ins Lehre oder zur apachefriends-Seite mit der aktuelle Version aber niemals zu sourceforge.net (haette man auch selbst drauf kommen muessen.)

Zitat: Steht auf der Projectseite. (Ansonsten überleg mal, von wo du XAMPP eigentlich genau runtergeladen hast...):
finde da weiterhin nur die aktuelle Version. Vielleicht koennte man http://sourceforge.net fuer die aelteren Versionen darauf erwaehnen.

########

Zitat: PEAR ist doch beim XAMPP schon dabei?

In der 1.53a ist das PEAR rein Files-technisch drin, aber die Bindings ins PHP funktionierten bei mir nicht, sowohl CLI als auch im Web Fehlanzeige. Auch das phpinfo() bringt nur einen lehren Bildschirm zurück. Was ist neben der offiziellen Installationsdoku noch zu PHP in XAMPP zu beachten (Umgebungesvariablen, Registry-Eintraege ...)???

Steffen
ScriptTeddy
 
Posts: 2
Joined: 23. June 2006 16:39


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 22 guests