Zugriffbeschränken

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Zugriffbeschränken

Postby DJ-Galaxy » 12. June 2006 17:48

Hi
Ich habe ein Problem Ihr kennt doch sicher alle webadmin.php oder_
Ich lasse Leute daten auf meinem Server hosten und da hat einer mit diesem script alle meine daten gel;scht und jetyt meine frage
Wie kann ich den yugriff auch bei so was nur auf den ordner des user beschrènken_

Danke scho m,al f^r Euro hilfe
(sry French Tastatur)
DJ-Galaxy
 
Posts: 63
Joined: 10. April 2006 09:17

Postby deepsurfer » 12. June 2006 18:06

ich gehe mal von aus das du mit VHOST dateien arbeitest.

Innerhalb dieser VHOST definition kannst du dem PHPparser ein Directory zuweisen wo er nur drin arbeiten darf. standardmässig kann der Parser bis ganz auf die höchste ebene.

open_basedir =

http://community.apachefriends.org/f/viewtopi ... 7772#47772

Somit schränkst du den VHOST = Kunden in ein bestimmtes Verzeichnis ein sodass der parser nicht weiter hoch hinaus kann.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby DJ-Galaxy » 12. June 2006 18:29

hmm könnteste du mir das vieleicht erklären wo ich das alles finde und wie ich das mache, weil so ganz hab ich das nicht verstanden ,danke schon mal.
DJ-Galaxy
 
Posts: 63
Joined: 10. April 2006 09:17

Postby deepsurfer » 12. June 2006 19:14

Du benutzt ja VHOST, un derjenige welche der das webadmin.php benutzt musst du innerhalb seines VHOST auch einschränken.
Das geschieht mittels

NameVirtualHost *:80

<VirtualHost *:80>
ServerName freund.dyndns.org
ServerAlias freund.dyndns.org
ServerAdmin du@mailadresse.de
DocumentRoot C:/xampp/htdocs/unterverzeichnis/freund
<Directory C:/xampp/htdocs/unterverzeichnis/freund/>
php_admin_value open_basedir C:/xampp/htdocs/unterverzeichnis/freund/
Options +Indexes
</Directory>
</VirtualHost>

Der rote eintrag sorgt dafür das er mit seinem webadmin auch nur innerhalb dieses VHOST Directory arbeiten darf.
Zudem sollte in der php.ini die sicherheit eingeschaltet sein
mode_save= On

Ohne diesen Eintrag könnte ein User/Kunde durch eine einfach .htaccess Anweisung deine Einschränkung umgehen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby birwac66 » 12. June 2006 19:46

ne geht bei mir ned geht das auch ohne subdomain_
Kannst des vieleicht mal deine fertige datei kopieren und hier einf^gen (mit einem beispiel geht bei mri echt ned xampp wurde neugestartet)
Geh mal auf meine webseite
www.webwacki.de
birwac66
 
Posts: 2
Joined: 31. May 2006 15:36
Location: DE

Postby deepsurfer » 12. June 2006 19:58

Kannst des vieleicht mal deine fertige datei kopieren und hier einf^gen


Kann ich nicht, da ich den XAMPP nicht für einen Produktiv Einsatz benutze, somit ist das hinfällig.

Ich kann dir nur aus den vorgegebenen Inhalten dir etwas schreiben (was ich ja hier schon gemacht hatte)
Der damalige Test mit 6 Vhosts war auf einer Linuxtestmaschine nur für diesen Zweck konfiguriert.

Da du Anscheinend ohne VHOST arbeitest, sind solche Einstellungen zum einen in der PHP.INI zu definieren, ansonsten in der globalen Drectory vergabe innerhalb der httpd.conf.

Ansonsten auch den Thread komplett lesen, damit der Zusammenhang vielleicht besser vorhanden ist.
http://community.apachefriends.org/f/viewtopi ... 7752#47752
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests