php-Admin meckert und streikt nach TuneUp-Reinigung

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

php-Admin meckert und streikt nach TuneUp-Reinigung

Postby knutwilli » 12. June 2006 15:35

Habe mit Tune Up wie gewohnt mal wieder den Computer von Datenmüll befreit. Dazu noch AdAware und Spybot.

nach dieser Reinigungs-Aktion meckerte phpAdmin und meldete die fehlende Datei lang.tmp.
Diese Datei war mit dem Undelete-Programm im Tune Up schnell rückholbar.

Jetzt ist diese erste Fehlermeldung weg und eine neue andere kommt:

Warning: include(lang/) [function.include]: failed to open stream: Permission denied in G:\Web-Server\htdocs\xampp\langsettings.php on line 4

Warning: include() [function.include]: Failed opening 'lang/' for inclusion (include_path='.;C:\Programme\xampp\php\pear\') in G:\Web-Server\htdocs\xampp\langsettings.php on line 4

Warning: Cannot modify header information - headers already sent by (output started at G:\Web-Server\htdocs\xampp\langsettings.php:4) in G:\Web-Server\htdocs\xampp\langsettings.php on line 8

Was hat die Müll-Bereinigung da angerichtet ?
Welche Schäden hat XAMPP dadurch bekommen ?
Last edited by knutwilli on 16. June 2006 19:49, edited 2 times in total.
alles gelingt - irgendwann
knutwilli
 
Posts: 21
Joined: 02. June 2006 04:45
Location: Berlin

Postby deepsurfer » 12. June 2006 18:01

Bisher fand ich keine Hinweise, welche weitere Konfiguration nötig ist, um auch bei ausgelagerten Web-Daten die Verschlüsselung anwenden zu können.


die \xampp\apache\conf\extra\ httpd.ssl.conf editieren und dessen DocumentRoot abändern.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Danke - es hat funktioniert

Postby knutwilli » 12. June 2006 18:31

Herzlichen Dank !

ich habe es gerade ausprobiert.
Jetzt klappt alles mit dem https ...

Jetzt muß ich noch herausfinden, welche weiteren Dateien für eine Datensicherung aus xampp herauskopiert werden müssen, damit diese nach einer Neu-Installation von XAMPP den vorher entstandenen aktuellen inhaltlichen Datenbestand wieder herstellen.

hoffe auch da auf gute Tipps

Knut W. Schlanert
alles gelingt - irgendwann
knutwilli
 
Posts: 21
Joined: 02. June 2006 04:45
Location: Berlin

Fehler nach Tune Up Reinigung

Postby knutwilli » 16. June 2006 19:42

Habe mit Tune Up wie gewohnt mal wieder den Computer von Datenmüll befreit. Dazu noch AdAware und Spybot.

nach dieser Reinigungs-Aktion meckerte phpAdmin und meldete die fehlende Datei lang.tmp.
Diese Datei war mit dem Undelete-Programm im Tune Up schnell rückholbar.

Jetzt ist diese erste Fehlermeldung weg und eine neue andere kommt:

Warning: include(lang/) [function.include]: failed to open stream: Permission denied in G:\Web-Server\htdocs\xampp\langsettings.php on line 4

Warning: include() [function.include]: Failed opening 'lang/' for inclusion (include_path='.;C:\Programme\xampp\php\pear\') in G:\Web-Server\htdocs\xampp\langsettings.php on line 4

Warning: Cannot modify header information - headers already sent by (output started at G:\Web-Server\htdocs\xampp\langsettings.php:4) in G:\Web-Server\htdocs\xampp\langsettings.php on line 8

Was hat die Müll-Bereinigung da angerichtet ?
Welche Schäden hat XAMPP bekommen ?
alles gelingt - irgendwann
knutwilli
 
Posts: 21
Joined: 02. June 2006 04:45
Location: Berlin

Postby deepsurfer » 16. June 2006 20:02

@knutwilli
Führe bitte bei dir setup_xampp.bat aus, wie aus den Fehlermeldungen zu sehen stimmen die Pfade alle nicht.

Danach expliziet http://localhost/xampp/lang.php aufrufen, es erscheint die splash.php mit der Sprachauswahl, sprache wählen.

Jetzt sollte wieder alles laufen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

es ist doch gut, wenn man weiß wo die Steine liegen

Postby knutwilli » 16. June 2006 22:16

hat sofort geklappt -das war es tatsächlich

herzlichen Dank

Knut W. Schlanert - knutwilli
alles gelingt - irgendwann
knutwilli
 
Posts: 21
Joined: 02. June 2006 04:45
Location: Berlin

Umzug der Web-Inhalte auf andere HD

Postby knutwilli » 23. June 2006 19:10

Um den Umzug der Webhosting-Daten auf eine andere HD zu regeln
muß an zwei Stellen der Eintrag über die Hosting-Verzeichnisse geändert werden.
1.
\xampp\apache\conf\httpd.conf editieren und dessen DocumentRoot abändern
2.
\xampp\apache\conf\extra\ httpd.ssl.conf editieren und dessen DocumentRoot abändern
alles gelingt - irgendwann
knutwilli
 
Posts: 21
Joined: 02. June 2006 04:45
Location: Berlin

Postby fbn » 27. June 2006 20:10

Hallo!

Ich hatte ein ähnliches Problem. Allerdings war mir nicht klar woran es lag. Benutze zwar auch TuneUp, aber hatte es bevor dieses Problem auftrat nicht verwendet.

Als ich nach einem Neustart http://localhost/xampp/index.php aufrufen wollte, bekam ich folgende Fehlermeldungen:

Warning: file_get_contents(lang.tmp) [function.file-get-contents]: failed to open stream: No such file or directory in C:\xampp\htdocs\xampp\index.php on line 2

Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\xampp\index.php:2) in C:\xampp\htdocs\xampp\index.php on line 9


Habe weder an der index.php was geändert, noch waren irgendwelche Dateien nicht vorhanden. Wie auch immer ...

Jedenfalls habe ich dann die Suchfunktion des Apache Forums in Gang gesetzt und schnell die Lösung meines Problems gefunden:

deepsurfer wrote:@knutwilli
Führe bitte bei dir setup_xampp.bat aus, wie aus den Fehlermeldungen zu sehen stimmen die Pfade alle nicht.

Danach expliziet http://localhost/xampp/lang.php aufrufen, es erscheint die splash.php mit der Sprachauswahl, sprache wählen.

Jetzt sollte wieder alles laufen.


Vielen Dank dafür! :D

Grüße
Fabian
fbn
 
Posts: 1
Joined: 27. June 2006 19:53

Auch bei Putzi kann das Gleiche passieren

Postby knutwilli » 27. June 2006 23:24

Auch bei der Verwendung von Putzi (sucht alle tmp-Dateien) kann das gleiche passieren, wenn man nicht darauf achtet, die lang.tmp zu schonen.

Leider wird die Datei lang.tmp von Putzi in grün angezeigt und ohne Kenntnis der Besonderheit sind eigentlich alle grünen TMP-Dateien überflüssig und löschbar.

Ich bin damit auch mal reingefallen
alles gelingt - irgendwann
knutwilli
 
Posts: 21
Joined: 02. June 2006 04:45
Location: Berlin


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests