File does not exist

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

File does not exist

Postby Anime » 11. June 2006 20:31

Einen guten Abend wünsche ich sehr.....

Ich stehe mal wieder vor einem Rätsel und habe da zwei Probleme die ich nicht zu lösen weis.

1.)
Jedes mal wenn ich unter /phpmyadmin eine neue Tabelle erstellen möchte, erhalte ich folgende Fehlermeldung in der error.log.

error.log = File does not exist: C:/Programme/xampp/htdocs/themes

es ist klar das irgendwas versucht zu finden das aber in dem Verzeichnis /phpmyadmin/themes zu finden ist nur frage ich mich wo ich was ändern muss und warum das fehlerhaft ist. :cry:

2.) Sobald ich den User Pma ein Passwort zuweise, ist es mir nicht mehr möglich in der Status Anzeige von xampp zu sehen das MySql aktiviert ist. Die Anzeige zeigt deaktiviert an obwohl SQL On ist.

Gibt es da ne Möglichkeit das zu beheben ? :roll:

Lieben Gruß
Anime
Anime
 
Posts: 44
Joined: 16. May 2006 18:48

Postby deepsurfer » 12. June 2006 11:44

s ist klar das irgendwas versucht zu finden das aber in dem Verzeichnis /phpmyadmin/themes zu finden ist nur frage ich mich wo ich was ändern muss und warum das fehlerhaft ist. Crying or Very sad

Ab zeile 512 in der config.inc.php im phpmyadmin Pfades
Code: Select all
// theme manager
$cfg['ThemePath']           = './themes';    // using themes manager please set up here the path to 'themes'
                                             // else leave empty
$cfg['ThemeManager']        = TRUE;          // if you want to use selectable themes and if ThemesPath not empty
                                             // set it to true, else set it to false (default is false);
$cfg['ThemeDefault']        = 'xampp';         // set up default theme, if ThemePath not empty
                                             // you can set up here an valid path to themes or 'original' for
                                             // the original pma-theme
$cfg['ThemePerServer']      = FALSE;         // allow diferent theme for each configured server


2.) Sobald ich den User Pma ein Passwort zuweise, ist es mir nicht mehr möglich in der Status Anzeige von xampp zu sehen das MySql aktiviert ist. Die Anzeige zeigt deaktiviert an obwohl SQL On ist.


Tjoa...(wenn man einfach mal die XAMPPpages durchschaut, sehe ich in der status.php einen Verweis auf die mysql.php, und darin wird der user PMA definiert.
Ich schätze einfach mal das du dem user PMA über phpmyadmin eine Passwort vergeben hast, dieses müsstest Du dann nur in die mysql.php eingetragen werden. (diesen Vorgang macht das security script) Dann sollte auch dein Statusreport wieder funktionieren.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Anime » 13. June 2006 11:07

Tjoa smile and happy

Danke das mit der Statusanzeige, das hat soweit geklappt und mit diesem Verständnis habe ich gleich noch andere Dateien modifizieren müssen/ können.

Aber du sag mal, diesen Eintrag in der error.log den konnte ich nicht auskommentieren. Im Gegenteil, inzwischen weiss ich das nicht nur ich davon betroffen bin, sobald eine neue Datenbank erstellt wird.

Ich hab’s mal versucht in der Config.inc.php mit dem direkten Pfad usw. doch hat es nicht den erwünschten Effekt gehabt.

Ich bekam nach wie vor die Fehlermeldung in der Error.Log

Kann es sein das es damit zusammen häng das phpmyadmin als ein alias definiert ist ?

LiebenGruß
Anime
Anime
 
Posts: 44
Joined: 16. May 2006 18:48


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests