kein funktion von localhost...

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

kein funktion von localhost...

Postby rock4k » 08. June 2006 09:39

Hallo,

hatte vor einiger das xampp - paket installiert. alles lief absolut reibungslos.
jedoch kann ich seit zwei tagen nicht mehr meine seiten lokal testen.

d.h. wenn ich im browser localhost oder 127.0.0.1 eingebe kommt nix.
der browser zeigt an "Warten auf localhost".... und es kommt auch keine fehlerseite. auch nach längerem warten nicht.

habe die dienste überprüft und auch die host - datei von windows. alles ist
in ordnung. nach neuinstallation eines neueren xampp laufen zwar alle
dienste einwandfrei, aber alle browser suchen vergeblich den webserver.

habe nur NOD32 als antiviren programm laufen, keine firewall usw., auch
die von windows ist nicht aktiv.
alles wurde übrigens auch ohne virusprogramm getestet.

System: Win XP pro SP2, neuestes xampp - paket

danke für tipps.
mario

p.s.: habe webserver pakete schon mehrfach eingerichtet. kenne mich also gut aus. komme jedoch mit diesem verhalten nicht weiter....
rock4k
 
Posts: 5
Joined: 08. June 2006 08:50

Postby deepsurfer » 08. June 2006 11:50

Hast du ein Windowsupdate die letzten zwei Tage durchführen lassen ?

- checke nochmal Firewall
- benutzt du Skype seit den letzten beiden Tagen ?
- was sagen die Logfile vom XAMPP-Apache ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

nichts dergleichen..

Postby rock4k » 08. June 2006 14:23

Hallo,

danke für die Tipps, nachgeschaut und bei Updates sind glaub ich nicht installiert. Habe zumindest keine Meldung vom Windows bekommen.
(ist bei mir so eingestellt, dass ich über Installationen benachrichtigt werde)

Letzte Einträge im Apache Error - LOG:
[Thu Jun 08 09:33:37 2006] [notice] Child 796: Starting thread to listen on port 443.
[Thu Jun 08 09:33:37 2006] [notice] Child 796: Starting thread to listen on port 80.

d.h. der Apache läuft seit heut morgen... keine erkennbaren Fehler davor.

Skype oder andere Netzwerkprogramme wurden bei mir nie installiert.
Firewall hatte ich auch noch nie eine, da unser lokales Netzwerk über
eine Hardware-Firewall geschützt ist. Die von Windows ist deaktiviert.
Zumindest im Sicherheitsmanager.

Keine Ahnung, was hier nicht geht. Das Internet usw. funktioniert ja auch.
Habe jetzt den Rechner auch schon mit zwei aktuellen Virenscannern
durchsuchen lassen. Inkl. nach Spyware, AdWare und Trojanern.
Alles ist clean.....
:-(
rock4k
 
Posts: 5
Joined: 08. June 2006 08:50

Postby deepsurfer » 08. June 2006 14:30

mal den Browser Cache leeren, vielelicht hängt eine localhost Anweisung ins nirwana.

- Dann auch mal alle XAMPP Services abschalten.
- Rechner neu starten (aber komplett herunterfahren, nicht auf "neustart"
- XAMPP manuell über das XAMPP-Controll starten lassen
- testen ob der XAMPP-Apache jetzt eine Antwort im Bworser gibt.
Wenn ja, dann XAMPP mittels XAMPP-Controll abschalten und dann die
Service einträge mittels der bekannten BATdateien wieder einrichten lassen.

testen und melden.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby rock4k » 09. June 2006 10:19

also, hab einmal bischen gestestet, jedoch ohne Erfolg zu haben.

bin dann auf die Idee gekommen die setup_xampp.bat mit dem xampp_lite
paket zu installieren und siehe da, es kommt beim installieren folgende meldung:

....
Please wait ...
Enable AcceptEx Winsocks v2 support for NT SystemsDas System kann den angegebenen Pfad nicht finden.
Das System kann den angegebenen Pfad nicht finden.
Das System kann den angegebenen Pfad nicht finden.
Das System kann den angegebenen Pfad nicht finden.
Das System kann den angegebenen Pfad nicht finden.
Das System kann den angegebenen Pfad nicht finden.
....
usw.

habe einmal in der setup_xampp.bat nachgeschaut, die pfadangaben stimmen alle.
wie beschrieben, der grundpfad lautet "D:\xampplite"

was kann er da nicht installieren?

vielen dank....

p.s. hatte die gleichen meldungen gesehen mit der installerversion, konnte jedoch nicht sehen, was da schiefgeht, weil alles zu schnell ging.
rock4k
 
Posts: 5
Joined: 08. June 2006 08:50

Postby nanocyte » 09. June 2006 16:43

ich habe ein ähnliches problem. habe mir zuerst die installer-version runtergeladen, hat auch alles soweit geklappt, bis ich dann im browser http://localhost eingetippt hab...

dann kam "Warten auf localhost..." (mit 127.0.0.1 das selbe)
weiter passierte dann nix. also hab ich mal meine easyphp deinstalliert.

danach gings immer noch nicht. bin ich also an unseren anderen rechner gegangen, da funktionierte es auf anhieb.

hab mir auch mal die selbstentpackende exe runtergeladen, allerdings das selbe spielchen.


bin grad bisschen frustriert weil ich den fehler nicht finde!
nanocyte
 
Posts: 6
Joined: 09. June 2006 16:25

Postby rock4k » 09. June 2006 19:59

ja ja... kenne mich eigentlich mit administration, windows und den ganzen kram sehr gut aus, da es ja auch mein beruf ist.

aber habe keine lösung bis jetzt gefunden. alle browser finden den localhost
nicht. nicht einmal ein timeout oder sonstige fehlermeldungen werden
angezeigt. er wartet eben, der browser, und wartet und wartet und wartet...

alle überprüfungen der netzwerk-konfiguration und der routing sachen, bzw.
der winsock haben keine fehler an den tag gebracht.

und das von einem tag auf den anderen.

habe allerdings noch kein anderes apache-paket probiert. hatte vor einiger
zeit mit windows 2000 und xampp die gleichen probleme. die installation
des ib-server paketes hat dagegen reibungslos funktioniert und das dann
über zwei jahre hinweg ohne fehler.

na mal sehen... werd mich am wochenende noch einmal intensiv damit
beschäftigen....
rock4k
 
Posts: 5
Joined: 08. June 2006 08:50

Postby nanocyte » 10. June 2006 00:08

also ich hab mal mein socket-programm (client/server) in delphi ausgegraben. und da hab ich auch ne verbindung gekriegt zum server, allerdings als ich die GET anfrage dann gemacht hab, kam keine antwort zurück...

easyphp hat bei mir auch schon zwei jahre gefunzt ohne probleme, jetzt aber auf einmal die probleme beim xampp...
nanocyte
 
Posts: 6
Joined: 09. June 2006 16:25

Postby rock4k » 10. June 2006 14:11

alle versuche mit xampp schlagen fehl. weiß nicht woran das liegt. der webserver ist einfach nicht über den browser erreichbar. sende ich jedoch einen ping an 127.0.0.1 bekomme ich auch eine antwort.

habe jetzt testhalber das paket IBSERVER installiert. beinhaltet zwar noch
ältere versionen von apache und php.... ABER ...installiert und geht auf
anhieb. man muss dann zwar noch module wie die gdlib in php usw. selbst
aktivieren, aber IBSERVER läuft läuft und läuft.

es bleibt nur noch ein großes fragezeichen.

hatte damals schon beim win2000 dann auf den ibserver zurückgegriffen. weil dieser auch ohne zu mucken funktionierte.

kennt jemand noch andere webserver pakete?
möchte mir nur ersparen den ibserver manuell auf die neuen versionen
anzuheben.
also denn....
rock4k
 
Posts: 5
Joined: 08. June 2006 08:50

Postby Webmania » 18. June 2006 09:33

Habe seit 2 tagen das gleiche problem.
XAMPP hat fine funktioniert und nun finded es keinen VHOSt mehr.

Habe alles un-installed. Chache and registry gesaeubert, XAMPP new heruntergeladen, installiert in ein frishes directory und es arbeited teilweise. Und dan ist es unmoeglich einen vhost zu setzen. HOSTS file is normal
127.0.0.1 localhost
127.0.0.1 dev1
127.0.0.1 dec2

vhost config ist als immer

<VirtualHost *:80>
ServerAdmin webmaster@fox-host.com
DocumentRoot "C:\dev\xampp\htdocs\wwww"
ServerName dev1
DirectoryIndex index.php index.html index.htm
</VirtualHost>
<VirtualHost *:80>
ServerAdmin webmaster@fox-host.com
DocumentRoot "C:\dev\xampp\htdocs\wwww\work2"
ServerName dev2
DirectoryIndex index.php index.html index.htm
</VirtualHost>

Und wenn ich im browser http://localhost oder http://dev1 oder http://dev1
aufrufe komme ich IMMER zum gleichen folder C:\dev\xampp\htdocs\wwww

Habe 127.0.0.1:80 localhost:80 und *:80 versucht und nichts hilft.

XAMPP ist unter Win XP V2 installed und das problem passierte ohne irgenwelche system changes oder new programme installation.

Hoffe das irgend jemand eine loesung weiss als Ich ansonsten ohne xampp arbeiten muesste and das waere schade.

Beste Gruesse
Petr
Webmania
 
Posts: 6
Joined: 01. April 2006 19:23

Got it working

Postby Webmania » 18. June 2006 10:49

Habe gerade das problem geloest!

In http.conf fehlte :
NameVirtualHost localhost:80


and in hosts file habe ich nun

127.0.0.1 localhost dev1 dev2
ALLES in einer line !


und nun funktionierts wie before.

Hoffe es hilft ein bischen anderen auch!

Beste Gruesse
Petr
Webmania
 
Posts: 6
Joined: 01. April 2006 19:23

Postby deepsurfer » 18. June 2006 13:04

rock4k wrote:also, hab einmal bischen gestestet, jedoch ohne Erfolg zu haben.

bin dann auf die Idee gekommen die setup_xampp.bat mit dem xampp_lite
paket zu installieren und siehe da, es kommt beim installieren folgende meldung:

....
Please wait ...
Enable AcceptEx Winsocks v2 support for NT SystemsDas System kann den angegebenen Pfad nicht finden.
Das System kann den angegebenen Pfad nicht finden.
Das System kann den angegebenen Pfad nicht finden.
Das System kann den angegebenen Pfad nicht finden.
Das System kann den angegebenen Pfad nicht finden.
Das System kann den angegebenen Pfad nicht finden.
....
usw.

habe einmal in der setup_xampp.bat nachgeschaut, die pfadangaben stimmen alle.
wie beschrieben, der grundpfad lautet "D:\xampplite"

was kann er da nicht installieren?

vielen dank....

p.s. hatte die gleichen meldungen gesehen mit der installerversion, konnte jedoch nicht sehen, was da schiefgeht, weil alles zu schnell ging.


Kann es sein das du ein SystemTool (TuneUp2006) benutzt, das in seiner Optionsvielfalt dir die möglichkeit bietet ein Commandfenster immer auf c:\ zu öffnen ?

Wenn das der Fall ist, so stört diese Option eines Tuningtool die funktionsweise der setup_xampp.bat
Indem dieses Tool dem setup_xampp.bat einen falschen Ausgangspfad vorlegt und somit alle Einträge in den Xampp-config falsch sind.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby rhos » 01. July 2006 22:21

habe das gleiche Problem, d.h. nach Aufruf von localhost passiert nix. Alle vorgenannten Lösungsvorschläge haben bei mir auch nicht geholfen. Im Fehlerprotokoll steht folgende Meldung:

[error] (OS 10045)Der Vorgang wird von dem Objekttyp nicht unterstützt, auf den Bezug genommen wurde. : Child 424: Encountered too many errors accepting client connections. Possible causes: Unknown. Try using the Win32DisableAcceptEx directive.
rhos
 
Posts: 1
Joined: 01. July 2006 21:01

Postby deepsurfer » 02. July 2006 13:38

rhos wrote:habe das gleiche Problem, d.h. nach Aufruf von localhost passiert nix. Alle vorgenannten Lösungsvorschläge haben bei mir auch nicht geholfen. Im Fehlerprotokoll steht folgende Meldung:

[error] (OS 10045)Der Vorgang wird von dem Objekttyp nicht unterstützt, auf den Bezug genommen wurde. : Child 424: Encountered too many errors accepting client connections. Possible causes: Unknown. Try using the Win32DisableAcceptEx directive.


Editiere die httpd.conf, scrolle an die letzte zeile, setze nun folgenden Wert hinzu:

Win32DisableAcceptEx

abspeicher, XAMPP-Apache neu starten lassen, testen und melden
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby nanocyte » 21. July 2006 18:37

deepsurfer wrote:Editiere die httpd.conf, scrolle an die letzte zeile, setze nun folgenden Wert hinzu:

Win32DisableAcceptEx

abspeicher, XAMPP-Apache neu starten lassen, testen und melden


danke für den tipp, jetzt läuft der apache an, ich krieg endlich eine verbindung, JUHU!!!!

mal guckn ob er jetzt auch stabil so weiterläuft

edit: mysql springt als service zwar an, beendet sich aber gleich wieder. wenn ich ihn so (nicht als service) laufen lassen funzt mysql
nanocyte
 
Posts: 6
Joined: 09. June 2006 16:25

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests