https darf nicht auf den Localhost

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

https darf nicht auf den Localhost

Postby Anime » 02. June 2006 20:48

Wer weiss was , bin gerade am verzweifeln.....
Folgendes Problem habe ich, wenn ich über einen der Virtuellen die Domäne aufrufe so klappt auch alles wie es eben soll, sprich...

http://meinedomäne.dynalias.com und dann öffnet sich das was eben soll.

Selbst wenn ich http://localhost aufrufe trotz der Virtuellen öffnet sich auch diese Seite.
Wenn ich aber https://meinedomäne.dynalias.com aufrufe, öffnet sich mein Localhost.

Ich habe keine Ahnung wie und wo ich was umstellen muss damit dieses nicht mehr passiert.

Hier noch ein Auszug meiner Virtuellen :
Code: Select all
NameVirtualHost *:80

   <VirtualHost *:80>
      ServerName meinedomäne.dynalias.com
      ServerAlias www.meinedomäne.dynalias.com
      ServerAdmin webmaster@localhost
      DocumentRoot x:/home/www/doc/0001/meinedomäne.com/www
   <Directory "x:/home/www/doc/0001/meinedomäne.com/www">
      AllowOverride All
      Options -Indexes IncludesNoExec
      Order allow,deny
      Allow from all
   </Directory>
   </VirtualHost>
<VirtualHost *:80>
   ServerName kontakt.meinedomäne.dynalias.com
   ServerAlias www.kontakt.meinedomäne.dynalias.com
   ServerAdmin webmaster@localhost
   DocumentRoot x:/home/www/doc/0001/meinedomäne.dynalias.com/mail/kontakt
<Directory "x:/home/www/doc/0001/meinedomäne.dynalias.com/mail/kontakt">
   AllowOverride All
   Options -Indexes IncludesNoExec
   Order allow,deny
   Allow from all
</Directory>
</VirtualHost>
   <VirtualHost *:80>
      ServerName reg.meinedomäne.dynalias.com
      ServerAlias www.reg.meinedomäne.dynalias.com
      ServerAdmin webmaster@localhost
      DocumentRoot x:/home/www/doc/0001/meinedomäne.dynalias.com/mail/reg
   <Directory "x:/home/www/doc/0001/meinedomäne.dynalias.com/mail/reg">
      AllowOverride All
      Options -Indexes IncludesNoExec
      Order allow,deny
      Allow from all
   </Directory>
   </VirtualHost>


<VirtualHost *:80>
   ServerName localhost
   ServerAdmin webmaster@localhost
   DocumentRoot D:/Programme/xampp/htdocs
<Directory "D:/Programme/xampp/htdocs">
   AllowOverride All
   Options Indexes IncludesNoExec
   Order allow,deny
Allow from all
</Directory>
</VirtualHost>


Danke für jede Hilfe
Anime
 
Posts: 44
Joined: 16. May 2006 18:48

Postby deepsurfer » 03. June 2006 12:00

In die VHOST auch die "SSLEngine on" eintragen, denn beim XAMPP ist nur das localhost damit definiert.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Anime » 03. June 2006 13:24

Ich danke dir , wusst gar nicht das man das im Vhost definieren kann. Na ja is ja auch nicht verwunderlich wenn man bedenkt, das es das erste mal ist für mich, das ich so etwas aufbauen.

Kannst du mir nicht noch zufällig sagen wie ich das definieren muss ?

Sicherheitshalber habe ich bis dahin den Port 443 und das include conf/extra/httpd-ssl.conf
deaktiviert. Das sollte allerdings nur ne Notlösung sein weil ich eben noch zuwenig weiss darüber.

Ich danke dir und einen
Lieben Gruß
Anime
Anime
 
Posts: 44
Joined: 16. May 2006 18:48

Postby deepsurfer » 03. June 2006 15:11

Sicherheitshalber habe ich bis dahin den Port 443 und das include conf/extra/httpd-ssl.conf
deaktiviert. Das sollte allerdings nur ne Notlösung sein weil ich eben noch zuwenig weiss darüber.

Tjoa....wenn du das deaktivierst ist perse eigentlich gar kein HTTPS möglich, weil dein XAMPP nichts damit anfangen kann, daher springt er schon deswegen auf deinen normalen localhost.

Also, dieses erstmal wieder aktivieren.

Beim überfliegen der Apache Dokumentation ist mir was aufgefallen das das SSL nur IPbasierend funktioniert.

Schau dir mal diesen Thread hier an, scheinbar haben es einige schonmal aufgebaut.
http://community.apachefriends.org/f/viewtopic.php?t=2717
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Anime » 03. June 2006 19:18

Ne klar jetzt nach der Deaktivierung, ich wusst mir nicht mehr anders zu helfen, ist auch kein https mehr möglich.

Wie du an meiner Ausdrucksweise vielleicht auch gemerkt hast, is mir das Thema https bzw SSl noch nicht allzu sehr vertraut.

Ich möchte mich aber bedanken denn dein Hinweis Ip und der Thread bringt mich glaub ich weiter so das ich doch noch SSL nutzen kann.

Dieses Thema Server und Co ist ein Kapitel bei dem man besser keine Frau haben sollte die sich sonst möglicherweise Zeitlich benachteiligt fühlen würde.
Anime
 
Posts: 44
Joined: 16. May 2006 18:48


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests