Ausschalten dieser Indexseite..

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Ausschalten dieser Indexseite..

Postby christimw » 24. May 2006 17:56

auf meinem Localhost zugreifen möchte, dann soll er mir nicht die Verzeichnissstruktur von meinem Document root angeben.. kann man das irgendwo ausschalten!?

MfG
christimw
 
Posts: 2
Joined: 24. May 2006 13:51
Location: Stuttgart

Postby Yalla-Mann » 24. May 2006 19:09

Lego!

Setze einfach eine index.htm ein und schon greift dein Server darauf zu.
Yalla-Mann
 
Posts: 4
Joined: 24. May 2006 17:11

Postby christimw » 24. May 2006 19:29

Danke für die schnelle Antwort! Das Problem ist nur: es läuft ja ein Intranet(Forum) mit dieser index.htm.. Ich möchte aber, das man nicht mehr wenn man z.B. im Browser "http://localhost/files" oder so eingibt, er diese Ordnerstrucktur nicht mehr anzeigt! :)

kann man das irgendwo in der httpd.cfg einstellen!?

MfG
christimw
 
Posts: 2
Joined: 24. May 2006 13:51
Location: Stuttgart

Postby deepsurfer » 25. May 2006 12:43

in der httpd.conf ca. Zeile 216
Options Indexes FollowSymLinks Includes ExecCGI
vor dem Wort "Indexes" ein minus zeichen setzen.

speichern, apache neu starten.
Damit wäre das Indexing global abgeschaltet.

ODER nur für diesen Pfad
in das /files Verzeichnis eine .htaccess mit folgendem Inhalt setzen.
Code: Select all
Options -Indexes
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests