XAMPP Upgrade von 1.4.13 auf 1.5.2: VHosts kaputt

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP Upgrade von 1.4.13 auf 1.5.2: VHosts kaputt

Postby Codehunter » 20. May 2006 15:18

Ich hatte bisher XAMPP 1.4.13 laufen und hab mir jetzt das neue 1.5.2 parallel installiert. Dann habe ich aus der alten httpd.conf den ganzen Abschnitt bzgl. VirtualHosts rauskopiert und in der neuen conf für vhosts abgespeichert.

Die VHost-Names heißen xyz.localhost (auf WinXP) und sind in der hostsDatei eingetragen.

Doch wenn ich die URL http://xyz.localhost im Browser aufrufe bekomme ich mit der alten 1.4.13er Konfiguration nur den Fehler 403. Anscheinend bin ich nicht der einzige mit dem Problem wenn ich das hier im Forum zu überblicke. Ich habe schon alle Tips aus den anderen Threads zu dem Thema ausprobiert es hat nichts bewirkt außer daß ich manchmal anstelle dem Fehler 403 den 500er bekommen hab.

So sieht meinehttpd-vhosts.conf aus:
Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    ServerAdmin admin @localhost
    DocumentRoot "C:/Dokumente und Einstellungen/Me/Eigene Dateien/HTML-Dateien/SelfHTML"
    ServerName selfhtml.localhost
    <Directory "C:/Dokumente und Einstellungen/Me/Eigene Dateien/HTML-Dateien/SelfHTML">
        Options Indexes FollowSymLinks Includes
        DirectoryIndex index.shtml index.htm index.html index.php
        AddType text/html .shtml
        AddHandler server-parsed .shtml
    </Directory>
</VirtualHost>

Ich hab auch schon mal die langen Dateinamen im Pfad auf die kurze Variante (8.3-Format) gekürzt, hat aber auch nix gebracht. Die Verzeichnisse haben im gesamten Baum Vollzugriff. Wie gesagt der parallel installierte Apache aus XAMPP 1.4.13 hat mit den selben Verzeichnissen keinerlei Probleme.

Der einzige Unterschied zwischen meiner alten und der neuen Version den ich bisher feststellen konnte ist, daß der Apache jetzt auch mit Backslashes in Pfadangaben zurechtkommt. Das war früher nicht so. Aber am Problem ändern tut das auch nichts.

Selbst wenn ich die Primitiv-Version mache, also leeres Verzeichnis mit einer einzigen index.html und ohne jede AddHandler-Anweisung im VHost usw. geht es nicht.

Gibt es in der übergeordneten httpd.conf noch irgendwas einzustellen damit der Indianer mit den VHosts tanzt?
Codehunter
 
Posts: 3
Joined: 20. May 2006 15:02

Postby Wiedmann » 20. May 2006 15:30

Der einzige Unterschied zwischen meiner alten und der neuen Version den ich bisher feststellen konnte ist, daß der Apache jetzt auch mit Backslashes in Pfadangaben zurechtkommt.

Nicht wirklich/überall und sollte man daher nicht benutzen. Im Manual steht ja auch ausdrücklich das man Forwardslashs benutzen soll.

So sieht meine httpd-vhosts.conf aus:

Diese Datei wird auch in der "httpd.conf" includiert?

Code: Select all
<Directory "C:/Dokumente und Einstellungen/Me/Eigene Dateien/HTML-Dateien/SelfHTML">
...
</Directory>

Schön das du einen Directory-Block in deinen VHosts hast, nur warum erlaubst du dann dort niemand den Zugriff auf das Verzeichnis?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Codehunter » 20. May 2006 15:46

Also ich bin jetzt schon ein Stück weiter gekommen. Als erstes Problem habe ich den folgenden Block in der httpd.conf ausgemacht:
Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>

Wenn ich den auskommentiere funktionieren einige VHosts. Diejenigen die nicht funktionieren haben anscheinend inkompatible Einstellungen in den jeweiligen .htaccess-Dateien.

Das einzige was jetzt noch nicht funktioniert ist SSI (.shtml). Ich hab das bisher so:
Code: Select all
<VirtualHost *:80>
    ServerAdmin admin@localhost
    DocumentRoot "C:/Dokumente und Einstellungen/Me/Eigene Dateien/HTML-Dateien/Dev/nextstep"
    ServerName nextstep.localhost
    <Directory "C:/Dokumente und Einstellungen/Me/Eigene Dateien/HTML-Dateien/Dev/nextstep">
       Options Indexes FollowSymLinks Includes
        DirectoryIndex index.shtml
        AddType text/shtml .shtml
        AddOutputFilter INCLUDES .shtml
        AddHandler server-parsed .shtml
#       Order allow,deny
#       Allow from all
    </Directory>
</VirtualHost>

Rufe ich den URL auf bietet mir der Browser den Download-Dialog für die index.shtml. Wahrscheinlich läuft der Includes-Parser noch nicht. Wo muss ich den einschalten?

PS: Nur zur Info, es kommt hier nicht auf Sicherheit an, der Testrechner ist vom Internet komplett abgekoppelt.
Codehunter
 
Posts: 3
Joined: 20. May 2006 15:02

Postby deepsurfer » 20. May 2006 15:51

AddType text/shtml .shtml
Das "s" weg und das Parsen sollte gehen.


# Order allow,deny
# Allow from all

Das wäre der Hinweis gewesen der Wiedmann zuvor gegeben hat.
Warum kommentierst du dies ein ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Codehunter » 20. May 2006 16:09

Es scheint so zu sein daß genau diese Anweisungen den 403er verursachen:
Code: Select all
order allow, deny
allow from all

Da scheint noch eine Veränderung zwischen der alten Apache-Version und der neuen zu sein:
Code: Select all
order allow, deny

Das Leerzeichen nach dem Komma. Mein alter Apache hatte damit keine Probleme, der neue mag das Leerzeichen nicht mehr.

AddType text/shtml .shtml
Das "s" weg und das Parsen sollte gehen.

Jau danke das war das Problem zur Lösung ;)

Moah das sind so Kleinigkeiten die einen ewig beschäftigen :-/
Codehunter
 
Posts: 3
Joined: 20. May 2006 15:02


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests