Ordner mit .htaccess-Dat. im directorylisting nicht angezeig

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Ordner mit .htaccess-Dat. im directorylisting nicht angezeig

Postby $Ben » 15. May 2006 21:16

Hallo,
ich habe folgendes Problem.

Ich habe mir XAMPP 1.5.2 runtergeladen und mittels Installer installiert. Subba.
Ich hab mir nun diese Standard-XAMPP-Startseite vom Hals geschafft, so dass ich einfach ein "directorylisting" beim Aufruf von http://localhost/ erhalte. Klappt auch alles soweit so, wie ich es erwarte.

Ich habe nun aber einen Ordner test, der eine .htaccess-Datei enthält. Sollte in meinen Augen nicht so das Problem darstellen.
Aber genau hier ist das Problem. Ordner, in denen eine solche Datei existiert werden im "directorylisting" nicht angezeigt.

Das error-logfile des Apachen sagt mir
C:/apachefriends/xampp/htdocs/DevGuideShop/trunk/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration, referer: http://localhost/


Ich checke den Ordner aus SVN aus, will ihn sehen und tadaa .. ich sehe ihn nicht.
Benenne ich die Datei um, indem ich einfach den Punkt vor "htaccess" wegnehme, so wird alles korrekt angezeigt. Das ist aber ja nicht Sinn der Sache.

Wäre super, wenn mir da jemand weiterhelfen können.
Diese Frage ist ein Crossposting, weil in einem anderen Fachforum (*) leider keine Antwort kam (ok, ich bin etwas ungeduldig, aber es muss ja weitergehen. :D)

Ich danke Euch vielmals.
Grüße, Ben.
$Ben
 
Posts: 25
Joined: 26. March 2005 22:24
Location: Remagen

Postby Wiedmann » 15. May 2006 21:40

Das error-logfile des Apachen sagt mir

Eigentlich steht da doch alles drin was du brauchst?
--> Du benutzt in der ".htaccess" eine Directive für ein Modul das nicht geladen ist.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby $Ben » 16. May 2006 09:17

Viel Wirbel meinerseites um nichts.
Danke. Das mod_rewrite-Modul wurde nicht geladen.

Dachte, dass das in der httpd.conf standardmäßig aktiviert wird.

Danke nochmals. :D
$Ben
 
Posts: 25
Joined: 26. March 2005 22:24
Location: Remagen


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 15 guests