[gelöst] shtml - Dateien werden nicht richtig angezeigt

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

[gelöst] shtml - Dateien werden nicht richtig angezeigt

Postby flyby » 15. May 2006 19:01

Hallo

Ich habe kürzlich XAMPP für Windows installiert und eine kleine Testseite mit SSIs daraufgeladen. Der Status auf "http://winxpsp2/xampp/" zeigt an, dass SSI aktiviert ist.
Wenn ich mir die Site in einem Browser angucke (Opera, FireFox und IE), werde ich nach einem Datei-Download gefragt.
(Die SSI-Includes wurden eingefügt, wenn ich mir die Datei anschaue).
Vergleich: Das Beispiel von selfhtml, wird richtig angezeigt. (http://de.selfhtml.org/servercgi/server ... est1.shtml)
:arrow: mein Apache scheint falsch konfiguriert zu sein. Aber wo ? :(

Folgende Einträge finden sich im httpd.conf:
..
<Directory "C:/Programme/xampp/htdocs">
..
Options Indexes FollowSymLinks Includes ExecCGI
AddType text/shtml .shtml
AddOutputFilter INCLUDES .shtml
..
</Directory>
..
<IfModule mime_module>
..
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
</IfModule>
..

Ich danke schon im Voraus für Eure Hilfe :D
Last edited by flyby on 17. May 2006 20:22, edited 1 time in total.
flyby
 
Posts: 4
Joined: 15. May 2006 18:30

Postby flyby » 17. May 2006 20:17

Hallo

Ich hab's nun also rausgefunden (war ein peinlicher Fehler :oops: )
Das 's' hier ist natürlich überflüssig
Und das braucht's auch nicht
Folgende Einträge finden sich im httpd.conf:
..
<Directory "C:/Programme/xampp/htdocs">
..
Options Indexes FollowSymLinks Includes ExecCGI
AddType text/shtml .shtml
AddOutputFilter INCLUDES .shtml
..
</Directory>
..
<IfModule mime_module>
..
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
</IfModule>

..


LG
flyby
flyby
 
Posts: 4
Joined: 15. May 2006 18:30

Postby Wiedmann » 17. May 2006 20:59

Und das braucht's auch nicht
Code: Select all
<IfModule mime_module>
...
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
</IfModule>

Genau da gehört es hin.

Was Kai dazu getrieben hat, dort nicht einfach die "#" wegzumachen, sondern im Directory-Block für's "htdocs" falsche Einträge zusätzlich zu machen, musst ihn selber fragen... (dabei gab es ja mal eine Beta wo das schon alles stimmte :-/ )
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby flyby » 17. May 2006 21:12

Heisst das nun, dass ich die SSIs nur insgesamt - nicht aber für nur ein bestimmtes Verzeichnis (bsp. Teil meiner Site) aktivieren kann?

(Interessanterweise hat's auf jedenfall genau so funktioniert, nicht bei
<IfModule mime_module>
...
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
</IfModule>

aber in meinem htdoc-Directory ??)
flyby
 
Posts: 4
Joined: 15. May 2006 18:30

Postby Wiedmann » 17. May 2006 21:32

Heisst das nun, dass ich die SSIs nur insgesamt - nicht aber für nur ein bestimmtes Verzeichnis (bsp. Teil meiner Site) aktivieren kann?

Nein. Du selbst kannst natürlich konfigurieren was du willst. (wo man das überall aktivieren kann steht im Manual)

Bei der Standardkonfig vom XAMPP gehört es halt erst einmal insgesamt aktiviert. Und das korrekt innerhalb von "IfModule ...". (Dort steht es ja beim XAMPP schon, halt noch mit einem "#" vornedran, was weg muss).


(Interessanterweise hat's auf jedenfall genau so funktioniert, nicht bei
...
aber in meinem htdoc-Directory ??)

Jein. Selbst wenn du die ´"#" weggemacht hast an der richtigen Stelle, überschriebt der falsche Eintrag im htdocs den richtigen wieder. Du hast also den Eintrag im htdocs korrigiert damit es tut. Ideal, so wie es vorgesehen war, hättest du diesen einfach nur löschen müssen (und beim Anderen die "#" wegmachen).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby flyby » 17. May 2006 21:41

Ich hab's nun ausprobiert (musste eben erst die Test-Kiste nochmals starten..)

Ja, du hast natürlich Recht. So tut's. Wichtig ist's, nicht den Options-Teil auszukommentieren (mir passieren halt die dümmsten Fehler).

Vielen Dank. Für die Hinweise :D
So, jetzt kann ich meinen Dev-Server einrichten. 8)

LG
flyby
flyby
 
Posts: 4
Joined: 15. May 2006 18:30


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 17 guests