Xammp Downloads langsamer als IIS Downloads

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Postby deepsurfer » 09. May 2006 10:57

Das ich noch nicht geantwortet hatte liegt schlicht und ergreifend daran das ich versuche dein Konstrukt nach zu bauen und um damit das Verhalten der unterschiedlichen Downloadratien zu reproduzieren.
Bsher ist mir das nicht gelungen. (ich hab gleiche Ratien)

Das du Logfile nur bis zum 6.5 hast , gehe ich mal von aus das du an diesem Tag den XAMPP installiert hattest, dann nach einem Funktionstest möglicherweise in der xampp-apache-config den <DocumentRoot> geändert hast.
-- Trifft das so zu ? --
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby blakedj » 09. May 2006 11:48

Nein den habe ich nicht geändert. Ich habe ja gestern eine Logfile erstellen lassen. Und hatte die ja reinkopiert was darin stand.

PS: Sorry für miene Ungeduld. Ich danke Dir natürlich das Du Dir so ne Mühe gibst.

greetz: BLaKe
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Postby blakedj » 10. May 2006 22:48

hmm Ist hier nur einer der helfen kann? Entwickler ich rede auch mit Euch oder ist das nur ein Userforum?
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Postby kvo » 11. May 2006 16:17

Hallo alle Zusammen!

Also ich habe es mit meinem 100 Mb/s getestet. Der Apache 2.2.2 (xampplite) stand dafür auf meinem Notebook (1,5 Gh Intel mit 512 MB RAM) zur Vefügung. Allerdings verlief die Anbindung in das ansonsten geschlossene "Cat5-Netz" auf dem Notebook via Wireless (der einzige Wireless-Zugang in diesem Netz).

Test mit xampp-win32-1.5.2.zip als Download (79,1 MB)

1) Erste Versuch auf Client mit MS Internet Explorer 6.0.
=> 79,1 MB in 2,29 Min. (543 kb/sec angezeigt)
2) Das selbe ein zweites Mal mit IExplorer, doch diesmal ging es wesentlich hier schneller:
=>79,1 MB in 1,05 Min. (1,21 kb/sec angezeit)
3) Firefox (anderer und schnellerer Client-Rechner) war bei dem selben ZIP dann noch schneller:
Mindestens 1,700 Kb/sec

Ergebnis:
1) Einmal muss der Apache2 die Datei (den Prozess) geladen haben. Übrigens hat hier hierbei meine Festplatte auf dem Server (Notebook) gut "gerumpelt". Danach (also beim zweiten Zugriff) geht alles wesentlich schneller, da der Prozess bereits geladen ist.
2) Transfergeschwindigkeit ist abhängig von der Browser-Version und der Performance des Clientrechners allgemein.

Fazit: Der Apache 2 kann das Problem nicht alleine sein. Hier muss es noch etwas geben, was ihn in diesem Problemfall bremst.
User avatar
kvo
Apache Friends
 
Posts: 184
Joined: 24. January 2003 14:03
Location: Berlin

Postby blakedj » 12. May 2006 17:14

Hmm ja nur leider hilft mir das jetzt nicht viel weiter. Es ist egal welchen browser du bei meinen geposteten links nimmst. Der unterschied ist zu erkennen.
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Postby blakedj » 12. May 2006 22:06

Also ich habe eben nochmal die Xampp Version 1.4.16 installiert. Hier scheint es fast zu funktionieren. Der Downloadspeed liegt bei 500-550 was natürlich auch noch zu langsam ist. Also Irgendwas müsst Ihr doch geändert haben. Ich verstehe nicht wieso das hier so lange braucht.

Ist das Absicht weil ich nerve? Der Entwickler von Xampp muss wissen wovon ich spreche. Weil immerhin funzt es in der Version 1.4.16 mit 500-550kb.

Das heisst das es nicht an meinem Rootserver liegt. Von daher kann ich es nicht verstehen das ich hier keine Antwort auf mein Problem bekomme.

Ist das evtl. Absicht das es so langsam laufen muss? Ich bin der Meinung es haben schon mehrere etwas dazu gesagt aber es wurde immer drum rum geredet. Hab ich irgendwas verpasst?

Bin am verzweifeln hier echt. Soll ich Geld überweisen damit das gemacht wird?

Mensch Leute bitte.
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Postby deepsurfer » 13. May 2006 12:08

hmmm ein DEV hat ja schon geantwortet, das seine Aussage dir nicht ganz behilflich ist, ist zwar schade, aber im grunde sollte das lesen der Apache Dokumentation behilflich sein.
Stichwort: Apache Perfomance
Da gibt es etliche Einstellungen zu diesem Thema in der Dokumentation.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby kvo » 13. May 2006 12:29

Genau wie "deepsurfer" gesagt hat. Ein DEV hat geantwortet (und das war ich). Also wir ignorieren das Problem nicht.

Das Ganze bringt mich auf eine Idee. Da ich sowieso eine Windows Server 2005 aufsetzen muss, kann ich ein Benchmark machen:

1) Mit dem aktuellen XAMPP (html und php)
2) Dasselbe mit dem IIS (html und php)
3) Einem älteren XAMPP (html und php)

Das Ganze werde ich dann auch graphisch aufbereitet veröffentlichen. In Anschluss werde ich die Apache2 und PHP Performance versuchen zu optimieren. Darunter leidet dann aber die Funktionalität des Apache. Was ich gemacht habe und die Geschwindigkeits-Ergebnisse veröffentliche ich selbstverständlich auch. Ich könnte übrigens auch ein OpenSuse (10) Ergebnis gemacht mit dem selben Rechner gegenüberstellen. Mal sehen, eine Zeitfrage.

Insgesamt sind aber keine Wunder zu erwarten. Denn der Apache2 ist kein Speed-Star. Dafür eben mit sehr vielen Funktionen ausgestattet. Der IIS ist im Allgemeinen tatsächlich schneller. Aber warten wir die Ergebnisse ab. Am Sonntag fange ich an und sollte im Verlauf der nächsten Woche die ersten Ergebnisse vorzeigen können. Bis dahin bitte ich um Geduld.
User avatar
kvo
Apache Friends
 
Posts: 184
Joined: 24. January 2003 14:03
Location: Berlin

Postby blakedj » 15. May 2006 08:35

Danke das ist sehr nett. Ich gedulde mich :D
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Postby kvo » 17. May 2006 12:36

Hallo Members!

Das Benchmark ist fertig. Wie zu erwarten ist der IIS 6 schneller als der Apache unter Windows. Ich hatte schon vor zwei Jahren eine ausgiebige Bench unter Windows XP gemacht. Die damaligen Ergebnisse waren den aktuellen ähnlich. Der Apache win32 ist und bleibt nun einmal ein "Adapting" aus der Unix Welt. Allerdings mit sehr hoher Funktionalität. Noch fehlt übrigens der Vgl. Linux XAMPP vs. IIS 6, aber das hole ich am Ende dieser Woche noch nach.

http://www.onlinetech.de/sites/benchmark-win32-2006.html

Die Tips zur Optimierung habe ich auch nicht vergessen. Diese aber ohne Anspruch auf Vollständigkeit oder messbaren Resultat auf dem Zielsystem. Anregungen hierzu nehme gerne entgegen!

http://www.cvs-for-all.de/onlinetech/sites/benchmark-win32-2006.html#opt

Heute habe ich noch Termine und kann mich wahrscheinlich erst morgen mit dem Thread beschäftigen. Also nicht böse sein!
User avatar
kvo
Apache Friends
 
Posts: 184
Joined: 24. January 2003 14:03
Location: Berlin

Postby blakedj » 17. May 2006 13:32

Super danke für Deinen Beitrag. Nur was ich trotzdem nicht verstehe. Wieso habe ich dann mit dem Xammp 1.4.6 mit meinem DSL 6000 Transferraten von 550 kilobyte pro sekunde von meinem Rootserver. Und nun mit den neuern Xampp Versionen nur 230 kilobyte pro sekunde ?
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Postby kvo » 18. May 2006 12:23

Ja, das ist tasächlich merkwürdig. Deshalb habe ich auch nochmal das offizielle Binary vom Apache 2.2.2 hinzugezogen. Ergebnis: Der Apache der 2.0.x Serie ist in Punkto Download großer Dateien schneller als der neuere Apache 2.2.2 (vgl. Benchmark, IE Download Test).

Warum der Apache 2.2.2 allerdings in deinem Fall noch nicht einmal annähernd die maximalen Werte erreicht (ich hatte ja im 100 MBit/s Netzwerk einen Maximalwert von rund 20 MBit/s) ist anscheindend noch ein anderes Problem. Hier kann ich nur rätseln. Möglicher Weise hält der Apache 2.2.2 Bandbreite vor, d.h. ca. 50% der Bandbreite wird von einem Prozess (hier der Download) maximal beansprucht. Bei dem IIS 6.0 kann man das ja soweit ich mich erinnere auch einstellen. Ich weiss allerdings nicht wie man einen solchen Wert in der httpd.conf manipulieren kann. Wenn das überhaupt der Grund ist.

Schöne Grüße!
User avatar
kvo
Apache Friends
 
Posts: 184
Joined: 24. January 2003 14:03
Location: Berlin

Postby deepsurfer » 19. May 2006 09:50

FlashVideo 8 minuten, zwei WGET Downloads, unten mit Playleiste zeit verkürzen
Video 2.5MB gross

Einige Hänger im Download sind dadurch zu erklären das zum Testzeitpunkt 6 PC alle 2 minuten mails abholen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby sari42 » 20. May 2006 17:47

moin,
was Du brauchst, ist wahrscheinlich ein speed-optimierter Server wie:
http://www.lighttpd.net/
Zitat:
Security, speed, compliance, and flexibility--all of these describe LightTPD which is rapidly redefining efficiency of a webserver; as it is designed and optimized for high performance environments. With a small memory footprint compared to other web-servers, effective management of the cpu-load, and advanced feature set

wird z.B. von phpMyAdimin - Demoserver verwendet.
http://pma.cihar.com/STABLE/
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby blakedj » 20. May 2006 21:17

Danke aber mein Rootserver ist schnell. Oder was meinst Du wieso beim IIS der Speed funzt.

Hmm wie dem auch sei. Ich glaube wir kommen hier nicht weiter. Ich werde den IIS nutzen und mich in einem dafür geeigneten Forum zwecks dem Problem was ich mit dem IIS habe weshalb ich den Apache wollte posten. Weil der Speed ist mir wichtiger als mein Cokkieprob im IIS.

Danke nochmal an alle. Ich werde ab und zu mal vorbei schauen ob sich evtl. noch etwas getan hat.

greetz: BLaKe
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

PreviousNext

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests