Xammp Downloads langsamer als IIS Downloads

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Xammp Downloads langsamer als IIS Downloads

Postby blakedj » 07. May 2006 15:26

Hallo,

Ich habe schond as ganze Forum durchsucht. Aber ich konnte nie etwas passendes finden.

Ich hab eine Windows 2003 Server und nutze den IIS. Ich würde nun gerne umsteigen auf den Apachen.

Nur ist es so das wenn ich denn IIS nutze die Leute auf meiner Seite mit Fullspeed meine Downloads saugen können. Also einer der DSL6000 hat kann auch mit knapp 700kb pro sekunde runterladen.

Nur wenn ich mit Xammp meine gleiche Page mit allen drum und dran starte dann geht der Download immer bis auf 250kb pro Sekunde runter.

Also von meinem Server kann man mit 10MB pro Sekunde downloaden und ich kann auch soviel uploaden. Also es liegt nicht an irgendwelchen Umrechnungen die hier schon beschrieben wurden.

Denn immerhin im IIS wenn ich den anhabe saugen die Leute bzw. jetzt unser Beispiel der DSL6000 User auch mit seiner vollen Geschwindigkeit von meinem Server aber mit Xammp geht der Download immer bei Ihm auf 250kb pro Sekunde runter.

Könnt Ihr mir bitte sagen wo ich da etwas ändern kann. Ich bin der Meinung das früher bei Xammp das immer funktionierte. Denn ich hatte das damals schonmal drauf um es zu testen.

greetz: BLaKe
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Postby blakedj » 07. May 2006 15:29

Axo für die jenigen die jetzt denkend as ist normal ich kann auf Wunsch gerne meine Page einmal auf Port 80 für Xammp und einmal auf Port 81 für den IIS laufen lassen. Um das Ihr sehen könnt wovon ich spreche.
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Postby deepsurfer » 08. May 2006 10:48

Nur ist es so das wenn ich denn IIS nutze die Leute auf meiner Seite mit Fullspeed meine Downloads saugen können. Also einer der DSL6000 hat kann auch mit knapp 700kb pro sekunde runterladen.

Richtig, DU saugst mit knapp 700 was dem Downstream (DSL6000 = 6Mbit oder 600KB plus Buffer) deiner DSLleitung entpricht.

Nur wenn ich mit Xammp meine gleiche Page mit allen drum und dran starte dann geht der Download immer bis auf 250kb pro Sekunde runter.

Nach deiner vorangegangener Erklärung heisst das, das wenn XAMPP läuft DU nur noch mir 250KB saugen kannst und somit fast 500KB geklaut sind.
Wenn das zutrufft dann bedarf es einer Fehlersuche, von der man aber ausgeht das nur XAMPP läuft und sonst kein Tool/Porgramm im hintergrund.

Also von meinem Server kann man mit 10MB pro Sekunde downloaden und ich kann auch soviel uploaden. Also es liegt nicht an irgendwelchen Umrechnungen die hier schon beschrieben wurden.

Wenn du eine 10Mbit Netzwerkkarte eingebaut hast ist diese Aussage richtig, aber nicht in bezug auf das Internet sondern nur innerhalb deines LANs

Denn immerhin im IIS wenn ich den anhabe saugen die Leute bzw. jetzt unser Beispiel der DSL6000 User auch mit seiner vollen Geschwindigkeit von meinem Server aber mit Xammp geht der Download immer bei Ihm auf 250kb pro Sekunde runter.

Was ich nicht glauben kann da dein DSL-Anbieter sicherlich nicht 6000kBit Downstream und 6000kBit Upstream zur verfügung stellt.

Da klingen die 250kBit schon realistisch bezogen auf dein Upstream, dies sollte aber in deinem Vertrag zu sehen sein mit wieviel kB dein Upstream eingestellt ist.

-----------------------------------------
Bitte mach jetzt nicht den gleichen Fehler wie viele andere auch...
DSL6000 bedeutet das dir der Anbieter einen Downstream von mindesten 6000kBit zur verfügung stellt, das entspricht einer 6Mbit Leitung.
ABER
der Upstream ist die Zahl die für dich Interessant ist, denn das ist die vom Anbieter zur Verfügung gestellt Leitung die du von dir NACH draussen vorhanden ist.

Folglich ist erstmal zu schauen was für einen DSL6000 Vertrag du hast.
(Ausser bei ARCOR Kunden die den zusatz haben die hälfte ihres Downstream in Upstream zu nutzen)

Nächter Hinweis: sollte nun ein Kumpel bei dir etwas "saugen" so wird versucht diesem Kumpel den vollen Upstream zu geben, sobald aber ein zweiter Kumpel zeitgleich etwas saugen will, kommt ein sogenannter "Balancing-Effekt zu tragen" sodass der Upstream geteilt durch zwei vergeben wird. Und wenn du dann noch Mailverschickst und viele Webpages abrufst so vermindert sich die Upstreamgrösse für jeden Kumpel.

-------------------------------------
Um eine Umrechnung kommen wir hier nicht drumrum, denn sonst hättest du dieses Zahlenkonstrukt verstanden und wüsstest das kein User bei dir mit der selben Leistung downloaden kann wie du es kannst.

Beispiel: (Quelle der Tabelle
Name: T-DSL 6000
basiert auf Anschluss: T-DSL der Deutschen Telekom
max. Download: 6016 kbit / sec = 600KB Download = 6Mbit
max. Upload: 576 kbit / sec = 57.6 KB Upload = 0,57 Mbit

Basierend auf diesen Zahlen und deren Verständnis baut sich ein DSL Zugang wie folgt auf.

DEIN PC kann AUS dem Internet mit bis zu 600KB Downloaden.
DEIN PC gibt IN das Internet nur 57,6KB Upload

Die Zahlen variieren immer etwas nach oben, da ein Download / Upload nicht nur reine Datensegmente beinhalten sonderm auch sehr viele Kontrollabrufe die in ihrer gesammtheit die Zahlen nach oben hin aussehen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 08. May 2006 11:08

Hm, ich kann mich ja täuschen, aber ich denke dieser Server ist ein (Root-) Server der bei einem ISP im Rechenzentrum steht.

(BTW denke ich eher, dass dieser Server mit 100Mbit am Switch angeschlossen ist und nicht nur mit 10?)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deepsurfer » 08. May 2006 11:24

Sollte das der Fall sein das es sich um ein Rooty bei einem Provider handelt (wurde ja nicht erwähnt) dann tippe ich auf DNS Probleme innerhalb des Rooty in bezug auf den XAMPP.

Um das aber genauer zu erörtern wäre ein realbeispiel von nöten.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 08. May 2006 11:34

Sollte das der Fall sein das es sich um ein Rooty bei einem Provider handelt

Bleibt ja nicht viel anderes übrig, wenn User (die Zuhause DSL6000 haben) von diesem Server mit 700kb downloaden können...

(BTW dürften die wenigsten das Geld ausgeben woll um sich den privat zu kaufen. Als Rooty bekommt man das OS ja dann relativ günstig.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby blakedj » 08. May 2006 12:12

Also ja ich habe ein Rootserver der eine 100Mbit Netzwerkkarte eingebaut hat. Wie gesagt ich sauge von zu Hause aus mit 700Kb von meinem Server zumindest solange der IIS läuft.

Ist der Xammp an sauge ich von meinem Server nur mit 250Kb.

So und nun werde ich mal hier meine Page als Beispiel posten. Ich werde Sie einmal auf Xammp und einmal auf IIS laufen lassen. Und Ihr werdet sehen was ich meine.

Meine Seite im IIS (daher Port 81 weil sonst gehts ja nicht:)):

http://cfc.comgames.de:81/index.php?downloads-show-24

Meine Seite auf Xammp:

http://cfc.comgames.de:80/index.php?downloads-show-24

Ihr kommt direkt mit den Links zu dem Download von meinem Album. Soll keine Werbung sein.

So es ist wie gesagt ein Rootserver der in Berlin steht. Mit einer Anbindung von 100Mbit.

Nochmal zur Info das hat nix mit meinem Provider zu tun wo ich mein DSL habe. Weil ja Root Server.

Danke schonmal für Eure Mühen.

greetz: BLaKe
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Postby deepsurfer » 08. May 2006 12:22

ok... soweit bestätigt, der Download über wget ist zusehenst unterschiedlich

Schau bitte mal in die XAMPP-Logfile ob da einträge sind die sich auf den Request beziehen und die der XAMPP-Apache zuerst ablehnt.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby blakedj » 08. May 2006 12:30

Sorry wo finde ich das? Und wäre es möglich das ich dann einfach den Inhalt hier rein kopiere? Weil ich da jetzt wenig Ahnung habe ob er was blockt.
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Postby blakedj » 08. May 2006 12:42

Du meinst sicherlich das Apache Logfile?

Dort sind die letzten Einträge vom 06.05.2006
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Postby blakedj » 08. May 2006 14:33

Keine Antwort mehr ? Mir ist das wirklich wichtig zu einer schnellen Lösung zu kommen.
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Postby deepsurfer » 08. May 2006 15:43

bin da noch am grübeln...

Da du keine Logs hast, denke ich mir das du mit VHOSTs arbeitest und in diesen keine LOGs definiert hast... oder ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby blakedj » 08. May 2006 16:23

Nein Leider nicht. Da sind noch die dummyhosts definiert.
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Postby blakedj » 08. May 2006 16:29

So ich habe ma eben eine definiert. Dann habe ich die Datei nochmal bei meiner Xampp Webseite runtergeladen. Und nun steht das drin:


84.186.7.79 - - [08/May/2006:17:27:27 +0200] "GET /index.php HTTP/1.1" 200 44963
84.186.7.79 - - [08/May/2006:17:27:29 +0200] "GET /index.php?news HTTP/1.1" 200 44963
84.186.7.79 - - [08/May/2006:17:27:30 +0200] "GET /index.php?downloads HTTP/1.1" 200 37600
84.186.7.79 - - [08/May/2006:17:27:33 +0200] "GET /index.php?downloads-20 HTTP/1.1" 200 35032
84.186.7.79 - - [08/May/2006:17:27:34 +0200] "GET /index.php?downloads-show-24 HTTP/1.1" 200 36935
84.186.7.79 - - [08/May/2006:17:27:35 +0200] "GET /index.php?downloads-down-24 HTTP/1.1" 302 -

Kannst Du damit etwas anfangen?
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Postby blakedj » 09. May 2006 09:01

Hmm immer noch keine Antwort. Weiß denn der Entwickler von Xampp nicht weiter? An irgend etwas simplen muss es ja liegen. Vor allem weil es früher noch ging.

Und nein ich will auf keine ältere Version zurückgreifen müssen.

Wäre nur sehr nett wenn ich das Problem endlich mal gelöst hätte.
blakedj
 
Posts: 32
Joined: 08. April 2005 11:37

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 19 guests