Überwachungstool unter Windows ???

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Überwachungstool unter Windows ???

Postby ub60 » 04. May 2006 02:00

Gibt es ein Tool das mir anzeigt welche IP auf meinen Xampp-Webserver zugreift? Oder das mir alle Aktivitäten anzeigt.
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby Wiedmann » 04. May 2006 10:02

Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ub60 » 04. May 2006 10:38

@Wiedemann

Da bekomme ich die Meldung 404.
Dann müßte ja im htdocs ein solches Verzeichnis vorhanden sein.
Ist bei mir nicht.

Und der Wabalizer zeigt mir auch die Statistiken an.

Was ich meine ist eine Realtimeanzeige.

Muster: http://www.bowlingforum.de/wiw,sid-.html

So halt das für [Gast] eine IP angezeigt wird.
Ich als Admin von diesem Forum bekomme dann die Ip´s angezeigt.
Xampp 1.5.1
Windows 2000 Server
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby Wiedmann » 04. May 2006 10:45

Da bekomme ich die Meldung 404.

Dann scheint das bei deiner XAMPP-Version mal wieder deaktiviert zu sein :-/ Welchen XAMPP hast du denn?

Dann müßte ja im htdocs ein solches Verzeichnis vorhanden sein.
Ist bei mir nicht.

Muss nicht. siehe z.B. phpMyAdmin das auch nicht in htdocs ist (allerdings liegt hier der Fall noch etwas anders).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ub60 » 04. May 2006 10:56

Xampp 1.5.1
Xampp 1.5.1
Windows 2000 Server
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby deepsurfer » 04. May 2006 11:03

ub60 wrote:Xampp 1.5.1

Hast du irgendwas in den configs geändert ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby ub60 » 04. May 2006 11:08

Habe ich nicht.

Ganz normal mit der Installversion installiert.

Die einzige Änderung die ich vorgenommen habe ist
in der apache/conf/extras/http-vhost

dort 4 virtuelle hosts eingerichet.
Xampp 1.5.1
Windows 2000 Server
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby Wiedmann » 04. May 2006 11:12

Den hab ich natürlich grad nicht da *g* Also musst du halt mal folgendes selbst überprüfen:

In der "httpd.conf" muss am Anfang folgendes vorkommen:
Code: Select all
LoadModule info_module modules/mod_info.so
LoadModule status_module modules/mod_status.so


In der "httpd.conf" muss am Ende folgendes vorkommen:
Code: Select all
Include conf/extra/httpd-info.conf


In der "httpd-info.conf" muss jedes Vorkommen von:
Code: Select all
Allow from .example.com

geändert werden in:
Code: Select all
Allow from localhost
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ub60 » 04. May 2006 11:31

Mußte nur in der hhtp-info.conf ändern alles andere wahr ok.
von example.com auf localhost

Wenn ich es dann aufrufe bekomme ich 403 - Zugriff verweigert.

So sieht meine http-info.conf aus:
Code: Select all
#
# Get information about the requests being processed by the server
# and the configuration of the server.
#
# Required modules: mod_status (for the server-status handler),
#                   mod_info (for the server-info handler)

#
# Allow server status reports generated by mod_status,
# with the URL of http://servername/server-status
# Change the ".example.com" to match your domain to enable.

<Location /server-status>
    SetHandler server-status
    Order deny,allow
    Deny from all
    Allow from .localhost
</Location>

#
# ExtendedStatus controls whether Apache will generate "full" status
# information (ExtendedStatus On) or just basic information (ExtendedStatus
# Off) when the "server-status" handler is called. The default is Off.
#
ExtendedStatus On

#
# Allow remote server configuration reports, with the URL of
#  http://servername/server-info (requires that mod_info.c be loaded).
# Change the ".example.com" to match your domain to enable.
#
<Location /server-info>
    SetHandler server-info
    Order deny,allow
    Deny from all
    Allow from .localhost
</Location>
Xampp 1.5.1
Windows 2000 Server
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby deepsurfer » 04. May 2006 12:01

Code: Select all
Allow from .localhost

Der "Punkt" vor dem localhost ist zuviel (hat Wiedmann auch nicht mit angegeben ;) )
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby ub60 » 04. May 2006 12:11

Auch ohne den "." vor localhost keine Änderung.

Immer noch 403

Ich habe mal localhost mit dem Eingetragenem vhost-namen eingetragen.

Da geht es... :D

Das bedeutet dann, bei angelegten Virtualen Hosts, muß der Virtuale Hostname eingetragen werden.
Xampp 1.5.1
Windows 2000 Server
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby deepsurfer » 04. May 2006 12:17

Ich habe mal localhost mit dem Eingetragenem vhost-namen eingetragen.

Da geht es... Very Happy

Das bedeutet dann, bei angelegten Virtualen Hosts, muß der Virtuale Hostname eingetragen werden.

Eigentlich nicht, denn somit kann jeder (also von aussen) auf diesen Status zugreifen. Die Directive "Allow from localhost" sollte dafür sorgen das dieser Status nur von dem PC wo XAMPP drauf ist aufgerufen werden kann.

Kann es sein das du an einem anderen PC sitzt und fernadministration durchführst?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby ub60 » 04. May 2006 12:46

Nein, mache alles an dem Rechner wo auch Xampp drauf läuft.

Kann es etwas mit der host-datei im Windowsverzeichnis zu tun haben ???

meine Eiträge dort:

127.0.0.1 localhost
192.168.0.30 ub60.dyndns.org
Xampp 1.5.1
Windows 2000 Server
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby ub60 » 04. May 2006 13:07

Habe jetzt mal die IP vom Rechner genommen und in die http-info.conf eingetragen.

Dann funktioniert es.

Was mich noch halt wundert ist, das vor der dyndns-adresse ein www vorangesetzt wird. Normalerwise können doch dynamische adressen nicht mit www.xxx.dyndns.org aufgerufen werden. Wenn ich aber meine dyndns-adresse aufrufe: ub60.dyndns.org wird ein www automatisch davorgesetzt. Seltsam ???
Xampp 1.5.1
Windows 2000 Server
ub60
 
Posts: 23
Joined: 02. September 2004 22:42
Location: Hildesheim

Postby deepsurfer » 04. May 2006 14:51

wie hast du denn den VHOST aufgebaut ? mit www.xxx.dyndns.org oder ohne ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests