Update auf neueste XAMPP Version

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Update auf neueste XAMPP Version

Postby M_777 » 28. April 2006 14:48

Hallo Leute,

ich hoffe es wird nicht zu sehr ein gefundenes Fressen für die etwas bissigeren unter Euch, aber ich glaube ich weiß gar nix mehr.

Bisher lief auf meinem Server alles wunderbar aber jetzt macht mich der Apache echt schwach. Also es geht um folgende Grundlagen:

Win 2003 PC ( gehostet ) mit Vollzugriff über remote...

XAMPP lief immer bisher stabil und sicher... habe nun das neueste update eingespielt und kriege meine Domains nicht mehr zum laufen....

Die Struktur der httpd.conf hat sich etwas geändert, und zwar so, dass ich ehrlich gesagt trotz größerer Übersichtlichkeit keine Ahnung hab was ich falsch gemacht habe.

Einfaches Kopieren der Vhosts hat nicht geklappt, und jetzt läuft der Apache zwar, aber ich bekomme die Meldung "Zugriff verweigert" beim Aufruf der Adressen. Obwohl ich die Verzeichnisse vorher als

Order Allow,Deny
Allow from All

gesetzt habe...

vhost sind in /extras/httpd-vhost.conf
verzeichnisfreigaben in httpd.conf
roots der Webseiten ist laufwerk d: und dann als Verzeichnis die Domain also bspw. www.mydomain.tld .

Vorher hat wie gesagt alles funktioniert...



Bitte helft mir.... Ich weiß nicht was ich falsch mache...
M_777
 
Posts: 2
Joined: 28. April 2006 14:25

Postby deepsurfer » 30. April 2006 12:09

Von welcher XAMPP-Version "auf" welche Version hast du -upgedatet- ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

xampp update

Postby Gerhard Limnios » 05. May 2006 03:52

Hi,

Make sure, that when you specify the document root directory in virtuell host, that you have the quotation marks before and after the path, same as in httpd file


<<VirtualHost *:80>
ServerAdmin ......
DocumentRoot "your path"
ServerName ....
</VirtualHost>


hope this helps
Gerhard
Gerhard Limnios
 
Posts: 2
Joined: 05. May 2006 03:23
Location: Sydney

xampp ugrade

Postby Gerhard Limnios » 05. May 2006 04:17

One more thing,

check if the document roots of each virtuell host are a subdirectory of the directory which you have enabled in the main httpd file.

I not, you have do enable them in each virtuell host,

<VirtualHost *:80>
ServerAdmin .....
DocumentRoot "your path"
ServerName ....
ServerAlias ...

<Directory />
Options Indexes FollowSymLinks Includes ExecCGI
AddType text/shtml .shtml
AddOutputFilter INCLUDES .shtml
AllowOverride All
Order allow,deny
Allow from all
</Directory>

</VirtualHost>
Gerhard Limnios
 
Posts: 2
Joined: 05. May 2006 03:23
Location: Sydney


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests