Problem Xampp und IIS

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem Xampp und IIS

Postby wlanboy » 19. April 2006 16:47

Habe auf einem Windows 2003 Server Xampp und IIS parallel laufen. Klappt soweit auch gut, nur brauche ich für eine Applikation den IIS auf Port 80.

Also eine 2te IP Adresse in die Netzwerkkarte eingetragen und den Apache auf 192.168.1.100:80 und das IIS Web auf 192.168.1.101:80 gesetzt.

Nur wenn ich das IIS Web starten will, gibt es die Fehlermeldung aus, dass die Datei schon belegt ist. Stoppt man den Apache, kann ich das IIS Web starten.

Da ich mehrere andere IIS Webs ohne Probleme laufen habe (Port 1200,1201,...) denke ich, dass der Apache sich für alle IPs den Port 80 belegt.
Und das obwohl ich das Listen auf eine einzige IP beschränkt habe.

Wer kann mir weiterhelfen?

Situation vorher:
Apache:
192.168.1.100:80
IIS :
192.168.1.100:1200, 192.168.1.100:1201, ...

Situation nacher:
Apache:
192.168.1.100:80
IIS :
192.168.1.100:1200, 192.168.1.100:1201, ...
und 192.168.1.101:80 (genau dieses Web kann ich nicht starten)
wlanboy
 
Posts: 2
Joined: 19. April 2006 12:50

Postby deepsurfer » 22. April 2006 11:47

schau nochmal genau die Fehlermeldung des XAMPP-Apachen an, ich schätze das er nicht wegen Port 80 nicht startet sondern wegen Port 443 (SSL Port)

Dazu mal in XAMPP die \xampp\apache\conf\extra\ httpd-ssl.conf editieren.

testen und melden ;)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby wlanboy » 22. April 2006 14:51

Danke für den Tipp. Dort habe ich den SSL Port auch auf IP:Port gestellt. Also dürfte er SSL nur auf die eine angegebene IP Adresse und nicht auf alle "horchen".

Trotzdem startet er dann nicht.
wlanboy
 
Posts: 2
Joined: 19. April 2006 12:50

Postby deepsurfer » 22. April 2006 15:08

Öffne mal eine DOSbox und starte apache_start.bat manuell, jetzt solltest du eine Aussagekräftige Fehlermeldung sehen warum XAMPP-Apache nicht startet.

Ich persöhnlich vermute aber das es am Windows liegt, da er bei Virtuellen-IP vergaben bei mir sehr oft Probleme gemacht hatte.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests