Intranet+ MAIL +Netzwerk-MailServer: Was muss ich Beachten?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Intranet+ MAIL +Netzwerk-MailServer: Was muss ich Beachten?

Postby xray » 18. April 2006 18:25

Am Samstag möchte ich in unserer Firma ein Intranet-Portal aufspielen, das ich Zuhause zusammengestellt und angepasst habe.

xampp laüft im Firmennetzwerk bereits wunderbar :)

Das einzige, was ich noch nicht testen konnte, war E-mail (habe ich noch nie gemacht).

Unser Firmennetzwerk hat einen eigenen Mailserver(Typ unbekannt).
Hier ein paar Daten, die ich Outlook entlocken konnte:

Mailserver:
Host: 192.xxx.xxx.6 (xxx => müsst ja nicht alles wissen :wink: )
Port POP3: 110
Port SMTP: 25

Kontoname: vorname.nachname (Mail-adresse => vorname.nachname@firma.de)
kennwort: xxxxxx (warscheinlich keins)

Anmeldung durch gesicherte Kennwortauthentifizierung: nicht angeklickt

Postausgangsserver:
Server erfordert Authentifizierung: nicht angeklickt

>> Alle Netzwerk-Rechner: Windows
>> Server-Rechner: Windows

-------------------------
Jetzt die Fragen:
1. Sind schwierigkeiten zu erwarten?(soll heissen => Mail möglich?)
2. wie muss ich php.ini und httpd.conf konfigurieren, damit php => mail() funktioniert?
-------------------------

Mit PHP Programmierung habe ich einige Erfahrung - ist also kein problem.
Nur mail habe ich halt noch nie ausprobieren können.

Kann mir da jemand helfen?
Vieleicht sogar mit Kofigurationsdaten, die funktionieren >>müssten/sollten<< ?

Wäre schade, wenn ich stunden und tage rumfummel, nur weil ich irgendwas ganz blödes nicht beachtet habe oder es eben einfach nicht geht...

Und -- Ein Portal ohne Mail ist wie ein Auto ohne Benzin.
Das wäre für alle eine grosse Enttaüschung.

PS: Ich mache jetzt feierabend und bin erst morgen abend wieder online.

Danke an alle schon im Vorraus!
MfG
Stefan
xray
 
Posts: 7
Joined: 17. April 2006 14:35

Postby xray » 19. April 2006 17:33

In der PHP ini habe ich jetzt die IP des Netzwerk-Mailservers eingegeben.
Innerhalb des Netzwerks funzt php::mail() :D, aber nach draussen bekomme ich einen Mail-delivery:

---------------------------------------------------------------------------
E-Mail konnte nicht zum Internetanbieter versendet werden.
Fehler beim E-Mail-Versand über smtp.1und1.com. Vom Anbieter mitgeteilte Fehlermeldung: 550 must be authenticated.
---------------------------------------------------------------------------

Wo bzw. wie muss ich die authentifizierung an/eingeben?
xray
 
Posts: 7
Joined: 17. April 2006 14:35

Postby xray » 19. April 2006 17:38

Das ist von delivery-mail vieleicht auch noch ganz interressant:

X-KENRecTime: 1145463649
X-KENId: 000044F5KEN09E9BE86
X-KENRelayed: 000044F5KEN09E9BE86@mailserver
X-AntiVir4Ken: checked by AntiVir for KEN!; host=mailserver
ANTIVIR.VDF 6.34.00.203, AVEWIN32.DLL 6.34.00.56, AVPACK32.DLL 6.33.00.06,
AVDOWNLD.DLL 6.34.00.02, UNRAR.DLL 0.00.00.00, UNACEV2.DLL 2.6.00.00,
SAVAPI.DLL 6.33.00.00, SAVAKEN.DLL 6.33.00.04
X-Mailer: PHP/5.1.1
xray
 
Posts: 7
Joined: 17. April 2006 14:35

Postby deepsurfer » 22. April 2006 12:06

Unser Firmennetzwerk hat einen eigenen Mailserver(Typ unbekannt).

Euer Admin soll auf diesem Mailserver ein Account einrichten, mit diesem Account kommuniziert dann das Mailscript.

z.b. Account = portal@firma.de

Nun verschickt dein Portalscript über den portal@firma.de Account die Mails an die Empfänger.
Denn der Delivery Fehler besagt das die Mail die Versand werden soll keinem Ausgewiesenem Account zugeordnet werden kann, da aber die Accounts vom Mailserver der Firma funktionieren, braucht man halt nur einen Account auf selbigen damit Mails in die weite Welt gehen beziehungsweise innerhalb der Firma verteilt werden können.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Es Funzt! :)

Postby xray » 22. April 2006 18:21

Ich habs!
Habe mir die Header-Daten aus einer Delivery-Mail(return to sender) geholt...
Bin mir aber nicht sicher, ob das so ganz Koscher ist? :?
Code: Select all
<?php
$empfaenger = 'name_to_1@t-online.de,name_to_2@aol.com';
$betreff = 'servertest';
$nachricht = 'it works!';
$header = 'From: name_von@firma.de' . "\r\n" .
    'X-MSMail-Priority: Normal'."\r\n".
   'X-Mailer: Microsoft Outlook IMO, Build 9.0.6604 (9.0.2911.0)'."\r\n".
   'X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1506'."\r\n".
   'Importance: Normal'."\r\n".
   'X-Provags-ID: ksDomain.de accountName@ksDomain.de login:xxxxxx';

mail($empfaenger, $betreff, $nachricht, $header);
?>

@deepsurfer
Danke!
Werde das mit dem Portal-Account mal ansprechen -> soll heissen 'Verlangen' :P
xray
 
Posts: 7
Joined: 17. April 2006 14:35

Postby xray » 22. April 2006 18:30

Unser Server Akzeptiert keine adressen wie:
<benutzer<mailaddresse@irgendwas.de>>

Na, dann änder ich das eben in:
mailaddresse@irgendwas.de

such...such...änder...such..........[arrrrgggg] :roll:
xray
 
Posts: 7
Joined: 17. April 2006 14:35

Postby xray » 22. April 2006 18:40

Oooops - unser Mailserver ist abgekackt!!! - jetzt aber schnell weg!!

....


Nee, war bloss`n Reset *schwitz*
xray
 
Posts: 7
Joined: 17. April 2006 14:35


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests