htaccess

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

htaccess

Postby Alienuser » 15. April 2006 13:43

Hy @ all,

was muss ich hier ändern, damit auch htaccess dateien funktionieren ?

Danke
Alienuser
 
Posts: 10
Joined: 15. April 2006 08:17

Postby deepsurfer » 15. April 2006 14:07

Ab ca. Zeile 178

Code: Select all
#
# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
#
# First, we configure the "default" to be a very restrictive set of
# features.
#
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>


Das AllowOverride None in AllowOverride All umändern.

speichern, xampp-apache neu starten, testen und melden
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Alienuser » 15. April 2006 14:22

also bei mir siht die .htaccess datei so aus:

Code: Select all
AuthName "Das ist ein Testbereich"
AuthType Basic
AuthUserFile inc/.htpasswd
require valid-user


Die .htpasswd sieht so aus:

Code: Select all
Alienuser:$1$ctGZfPOB$wHQvh4n46m8F2XL0zx7An1


aber ich kann immer noch ohne probleme in das verzeichnis kommen !
Warum

die Xampp config (httpd.con) sieht so aus auf der zeile !

Code: Select all
#
# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
#
# First, we configure the "default" to be a very restrictive set of
# features. 
#
<Directory />
    Options FollowSymLinks
    AllowOverride all
    Order deny,allow
    Deny from all
</Directory>
Alienuser
 
Posts: 10
Joined: 15. April 2006 08:17

Postby Wiedmann » 15. April 2006 14:49

deepsurfer wrote:Ab ca. Zeile 178
Das AllowOverride None in AllowOverride All umändern.

Das will man nicht in dieser Zeile machen, diese Zeile will man lassen wie sie ist.

Geändert werden muss das "AllowOverride" in ca. Zeile 228. (der Directory-Block zum htdocs)


Alienuser wrote:AuthUserFile inc/.htpasswd

Geb hier einen vollen Pfad an.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Alienuser » 15. April 2006 14:57

meinst du also 127.0.0.1/Lars/Test/inc/ oder wie ?
Alienuser
 
Posts: 10
Joined: 15. April 2006 08:17

Postby Alienuser » 15. April 2006 14:58

in was soll ich das none ändern ?
Alienuser
 
Posts: 10
Joined: 15. April 2006 08:17


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests