Auf anderen rechnern nur halbe seiten zu sehen!?!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Auf anderen rechnern nur halbe seiten zu sehen!?!

Postby phphp » 15. April 2006 12:29

Hallo!
Ich hab mein meine seiten vom server mal von nem anderen rechner über die lan-ip angesehen.

aber seltsamerweise kommt da bei manchen seiten immer nur die hälfte.
das heißt der untere teil fehlt.

von localhost her angesehen ist alles okay.
phphp
 
Posts: 15
Joined: 06. April 2006 18:12

Postby deepsurfer » 15. April 2006 12:58

Mal in der httpd.conf des XAMPP-Apachen ab ca. Zeile 466
Code: Select all
#EnableMMAP off
#EnableSendfile off


die beiden rauten (" # ") entfernen; speichern; Apache neu starten; testen und melden.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby phphp » 15. April 2006 14:34

danke
was müsste man denn noch ändern um apache "webtauglich" zu machen?
phphp
 
Posts: 15
Joined: 06. April 2006 18:12

Postby deepsurfer » 15. April 2006 16:34

phphp wrote:danke
was müsste man denn noch ändern um apache "webtauglich" zu machen?


Bitte... also scheint es zu klappen

Was verstehst du unter Webtauglich ?
- Sicherheit ?

- Aufruf von aussen ? --> FAQ Hinweise dazu
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby phphp » 15. April 2006 21:23

nee. ich meine was man noch in der httpd.conf ändern damit alles optimal läuft fürs web.
phphp
 
Posts: 15
Joined: 06. April 2006 18:12

Postby phphp » 15. April 2006 21:33

so ein mist.
das kalppt trotzdem nicht!

soll ich vielleicht

EnableMMAP off
EnableSendfile off

auf on setzten???
phphp
 
Posts: 15
Joined: 06. April 2006 18:12

halbe Seiten

Postby cronimo » 16. April 2006 14:46

wenn Du eine halbe phpinfo.php mit merkwürdigen Zeichen meinst dann könnte es die Firewall von SP2 sein.
Wenn Du vom Web aus erreichbar sein möchtest musst Du Passwörter für mySQL phpMyAdmin und Filezilla vergeben.
Zusätzlich würde ich 2 Virtuelle Hosts einrichten. Den ersten local den zweiten fürs Web.

ansonsten käuft das eigentlich alles

Frohe Ostern !
cronimo
 
Posts: 2
Joined: 28. December 2004 15:53

Postby phphp » 16. April 2006 15:15

die mein ich nicht.
wenn eine seite von einem anderem rechner aus aufrufe, dann kommen nur halbe seiten. egal welche seite.(aber eher dei längeren)
phphp
 
Posts: 15
Joined: 06. April 2006 18:12

Postby deepsurfer » 17. April 2006 12:39

Benutzt du irgendwelche Tools im Hintergrund ?
(ich meine damit alles mögliche, kleine aber feine Tools die man so im laufe der Zeit feindet und mal Installiert)

- Mal alle Tools abschalten und dann den XAMPP testen, dazu kannst du auch mal den PC neu booten lassen und wenn das XP Logo erscheint die linke SHIFT-taste festehalten bis der komplette Desktop erscheint.

- Damit verhinderst du das alles Programme die automatisch gestartet werden sollen (eben diese Tools) gestartet werden.

- XAMPP Testen, wenn nicht besser, dann bin ich ratlos

- Bei erneutem Booten ohne Shift-Taste startet dein Windows wie gewohnt.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests