probleme mit port 8245 anstatt port 80

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

probleme mit port 8245 anstatt port 80

Postby kreuzritter » 07. April 2006 19:48

Hi ich habe da mal ne frage und zwar um den Apacheserver ans web anzubinden muss ja der Port 80 benutzt werden ... das ist bei mir nicht möglich da dieser schon anderweitig verwendet wird. Deswegen wollte ich als Alternative den Port 8245 verwenden ... aber nach vielem probieren hat das bisher noch nicht geklappt. Ich habe die Daten in der httpd.conf Datei verändert ... also anstatt port 80 den port 8245 eingetragen. Dasselbe habe ich auch in dem Updateclient von dyndns eingestellt.

Und jetzt kommts es funktioniert trotzdem nicht .... wenn ich den Port 80 im Updateclient und im apache habe funktioniert es anstandslos. Kann mir jemand nen tipp geben was ich machen muss das der Port 8245 klappt.

Besten Dank schonmal ....
kreuzritter
 
Posts: 7
Joined: 07. April 2006 18:49

Postby Wiedmann » 07. April 2006 21:11

Dasselbe habe ich auch in dem Updateclient von dyndns eingestellt.

Das DNS-System kennt keine Ports, weshalb dort auch keine angegeben werden.


Ich habe die Daten in der httpd.conf Datei verändert ... also anstatt port 80 den port 8245 eingetragen.

Also musst du diesen Port im Browser mit angeben:
"http://www.example.com:8245/"

Dein Router / Firewal muss natürlich entspr. konfiguriert sein und manchen Scripten muss man das auch mitteilen (siehe dessen Doku).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

danke für deine antwort

Postby kreuzritter » 07. April 2006 21:29

.... aber das mit dem www.example.com:8245 wusste ich auch und habs auch so beim testen angegeben .... ist trotzdem nicht lauffähig
kreuzritter
 
Posts: 7
Joined: 07. April 2006 18:49

Postby kreuzritter » 07. April 2006 21:31

und Router und Firewall habe ich auch auf den Ports 8245 eingestellt .... das ist alles geschehen
kreuzritter
 
Posts: 7
Joined: 07. April 2006 18:49

Postby Wiedmann » 07. April 2006 21:55

Dann kann ich dir auch nicht helfen. Im Apache muss man jedenfalls nur die Directive "Listen" entsprechend abändern.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby kreuzritter » 08. April 2006 10:25

trotzdem besten dank ..... wenn ich den fehler finde poste ich den mal muss ja nicht sein das andere sich noch mal so stressen .....

bin trotzdem für weitere tipps dankbar
kreuzritter
 
Posts: 7
Joined: 07. April 2006 18:49

Postby deepsurfer » 10. April 2006 12:12

@kreuzritter:
Du beschreibst zwar Änderungen in der httpd.conf aber nicht welche du da gemacht hast.

Hast du den <wink> von Wiedmann gelesen und in der httpd.conf die LISTEN 80 directive geändert ?

Auch daran gedacht den Apache jedesmal neu zu starten wenn Änderungen in der httpd.conf getan wurden ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby kreuzritter » 10. April 2006 13:35

ich habs nochmal nachgeprüft .....bei Listen to habe ich 8245 eingetragen und neu gestartet hab ich den Apache auch .....

wenn ich alles über port 80 laufen lasse funktioniert es ja auch nur bei Port 8245 nicht
kreuzritter
 
Posts: 7
Joined: 07. April 2006 18:49

Postby deepsurfer » 10. April 2006 13:41

Sorry, wenn es kleinkarriert anhört (soll nicht so sein)

Ich finde die Directive "Listen to" nicht, sondern nur "Listen 80" ausgehend von XAMPP 1.5.1 in ca. Zeile 53.

Bneutzt du auch VHOSTs oder ist alles noch in XAMPP Standardinstallation vorhanden und bisher noch nichts weiter von Dir geändert ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby kreuzritter » 10. April 2006 14:35

sorry meinte schon LISTEN 80
kreuzritter
 
Posts: 7
Joined: 07. April 2006 18:49

Postby deepsurfer » 10. April 2006 14:39

Ruf mal einen Kumpel an der dein dyndnsnamen mit dem port aufruft.

Sicher !?!? das der XAMPP-Apache läuft ?
testen mit http://localhost:8245
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby kreuzritter » 10. April 2006 15:03

hab ich schon im Rechenzentrum gemacht ...funzt nicht
kreuzritter
 
Posts: 7
Joined: 07. April 2006 18:49

Postby deepsurfer » 10. April 2006 17:31

kreuzritter wrote:hab ich schon im Rechenzentrum gemacht ...funzt nicht


Also wenn ich diese Aussage richtig deute, heisst es das du am PC mit dem XAMPP selbst über http://localhost:8245 nicht drauf kommst.

Das bedeutet für mich, folgende Situation:

a) Firewall auf diesem PC blockiert 8245

b) der Apache ist nicht richtig eingestellt (httpd.conf Zeile 53)

c) der Apache läuft garnicht. (DOSbox öffnen und XAMPP über apache_start.bat starten lassen, wenn ein Fehler vorliegt wird dieser beschrieben.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby deepsurfer » 13. April 2006 10:57

Wie sieht es aus ??
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests