Anfängerfragen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Anfängerfragen

Postby MrMister » 31. March 2006 13:06

Haudi Jungs, hätte ein paar kleine Fragen, auf die ich weder in der FAQ noch in der Forensuche eine wirkliche Antwort gefunden habe... Falls ich was übersehen habe bitte linken, war dann keine Absicht :wink:

Zuerstmal hätte ich eine generelle Frage: Ich habe XAMPP jetzt installiert und man kann von außen über ne Dyndns auf meine htdocs zugreifen - So weit so gut. Ich hatte vor, den Server so einzurichten, dass ich bei der normalen Adresse nur auf den htdocs-Ordner komme (so wie jetzt) und mit einer Passwortabfrage auf einen anderen Ordner, in dem private Dateien liegen... Dafür habe ich dann versucht FileZilla FTP zu konfigurieren. Soweit korrekt?

Problem 1: FileZilla lässt sich nicht starten/konfigurieren. Beim Start kommt die Abfrage nach der IP, dort gebe ich 127.0.0.1 ein, aber danach passiert nichts mehr, er bleibt bei "Connected, waiting for authentication" einfach stehen, so dass ich keine Möglichkeit habe Einstellungen vorzunehmen. Readme und Filezilla-Homepage waren nicht sehr hilfreich :(

Problem 2: Wenn jemand von außerhalb meine Internetip in den Browser eingibt, dann kommt er in die XAMPP-Einstellungen. Den Sicherheitscheck konnte ich mit Passwort und Username sichern, der Rest ist weiterhin einsehbar. Wie kann ich dem abhelfen?


Ich kann mir denken, dass diese Fragen bestimmt schon irgendwo beantwortet wurden, aber leider habe ich dazu nichts gefunden... :oops:

Grüße,
MrMister
MrMister
 
Posts: 13
Joined: 30. March 2006 22:57

Postby deepsurfer » 31. March 2006 14:24

Zu 1 FilleZilla:
Hast du sichergestellt das die Server einheit auch gestartet wurde ?
(mach mal das häkchen "SVC" im XAMPP-Controll rein, dann sollte gefragt werden ob der Server als Service installiert werden soll.
Wenn das gesehen dann kannst du mittels dem FileZilla-Interface auf den Server zugreifen und Administrieren.

Zu 2 Internet-Ip und Willkommenscreen:
Mal deinen Browser-Cache leeren.

testen und melden ;)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby MrMister » 31. March 2006 16:36

Hast du sichergestellt das die Server einheit auch gestartet wurde ?
(mach mal das häkchen "SVC" im XAMPP-Controll rein, dann sollte gefragt werden ob der Server als Service installiert werden soll.
Wenn das gesehen dann kannst du mittels dem FileZilla-Interface auf den Server zugreifen und Administrieren.


Jap, Server läuft, nur die Verbindung über das Interface-Programm funktioniert nicht. IP 127.0.0.1 auf Port 80 ist korrekt, oder?

Zu 2 Internet-Ip und Willkommenscreen:
Mal deinen Browser-Cache leeren.


Die Seite konnte von einem Freund in mehreren Kilometer Entfernung gesehen werden - Auch nach der Cacheleerung. Ist halt Sicherheitstechnisch ein wenig unpraktisch, wenn jeder nur meine Dyndns-Domain eintippseln muss und in den XAMPP-Optionen rumfuhrwerken kann :wink:

Trotz allem schonmal vielen Dank für deine schnelle Hilfe!

Grüße,
MrMister
MrMister
 
Posts: 13
Joined: 30. March 2006 22:57

Postby Wiedmann » 31. March 2006 16:52

IP 127.0.0.1 auf Port 80 ist korrekt, oder?

Nein. IMHO ist bei dem Programm aber beim ersten Start der richtige Port eingestellt gewesen. (in der "server.xml" steht der Port aber drin zum nachlesen)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deepsurfer » 31. March 2006 17:52

Port 14147
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby MrMister » 01. April 2006 17:26

Da soll mal einer drauf kommen :oops:
Naja, jetzt funzt es, vielen dank euch :D

Grüße,
MrMister
MrMister
 
Posts: 13
Joined: 30. March 2006 22:57

Postby deepsurfer » 02. April 2006 14:23

MrMister wrote:Da soll mal einer drauf kommen :oops:
Naja, jetzt funzt es, vielen dank euch :D

Grüße,
MrMister

Naja....der Port ist beim ersten Aufruf des Interfaces eingetragen ;)

HAPPY XAMPP
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby itchy777 » 02. April 2006 16:10

Hi Ho!
erstmal noch zu der sache mit dem kleinen Problem mit der Abfrage deiner Einstellungen von ganz weit weg ööhhm ich glaub (<-- hab Xampp auch erst 2 Tage :) ) das liegt daran das bei dir im Xampp verzeichnis noch im Ordner HTDOCS gaaanz viel zeug is und zwar ist das das root verzeichnis für den Apache sprich dem Webserver... jetzt kommen wir dann mal gleich zu meinem Problem: wie kann man genau dieses Rootverzeichnis umlegen?! ich hab ne eigene Partition für meinen Webserver und für meinen FTP-server nur der Web... mag da nich drauf... :cry: kann man da was machen?!
42
itchy777
 
Posts: 1
Joined: 02. April 2006 15:56
Location: Schwerin


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests