bei zugriff auf phpmyadmin - absturz

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

bei zugriff auf phpmyadmin - absturz

Postby Blackskyliner » 26. March 2006 20:00

Hallo, ich habe ein Probelm... Wenn ich auf phpMyAdmin zugreife oder gar ein Flsh mit php erstellen will, kackt der Apache ab. da kommt immer dass ein fehler in apache exe verursacht wurde... Ich habe W2K SP4 mit allen Updates und die neuste XAMPP version. Dieser fehler trat nach dem neuinstall meines systems auf, obwohl sich die pfade nicht geändert haben und ichs jetzt auch shconmal versuchte es neu zu installen. Aber wie gesagt der schmiert leider immer ab... ich hab echt k.A. warum :O, jm. ne idee?


[edit]
Hier noch der ApacheLOG

Code: Select all
[Sun Mar 26 20:05:52 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sun Mar 26 20:05:52 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sun Mar 26 20:05:53 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sun Mar 26 20:05:53 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sun Mar 26 20:06:01 2006] [notice] Apache/2.2.0 (Win32) DAV/2 mod_ssl/2.2.0 OpenSSL/0.9.8a mod_autoindex_color PHP/5.1.1 configured -- resuming normal operations
[Sun Mar 26 20:06:01 2006] [notice] Server built: Dec  1 2005 18:36:53
[Sun Mar 26 20:06:01 2006] [notice] Parent: Created child process 1948
[Sun Mar 26 20:06:02 2006] [notice] Child 1948: Child process is running
[Sun Mar 26 20:06:02 2006] [notice] Child 1948: Acquired the start mutex.
[Sun Mar 26 20:06:02 2006] [notice] Child 1948: Starting 250 worker threads.
[Sun Mar 26 20:06:02 2006] [notice] Child 1948: Starting thread to listen on port 443.
[Sun Mar 26 20:06:02 2006] [notice] Child 1948: Starting thread to listen on port 80.
[Sun Mar 26 20:06:46 2006] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Sun Mar 26 20:06:46 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sun Mar 26 20:06:46 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sun Mar 26 20:06:47 2006] [notice] Apache/2.2.0 (Win32) DAV/2 mod_ssl/2.2.0 OpenSSL/0.9.8a mod_autoindex_color PHP/5.1.1 configured -- resuming normal operations
[Sun Mar 26 20:06:47 2006] [notice] Server built: Dec  1 2005 18:36:53
[Sun Mar 26 20:06:47 2006] [notice] Parent: Created child process 2856
[Sun Mar 26 20:06:48 2006] [notice] Child 2856: Child process is running
[Sun Mar 26 20:06:49 2006] [notice] Child 2856: Acquired the start mutex.
[Sun Mar 26 20:06:49 2006] [notice] Child 2856: Starting 250 worker threads.
[Sun Mar 26 20:06:49 2006] [notice] Child 2856: Starting thread to listen on port 443.
[Sun Mar 26 20:06:49 2006] [notice] Child 2856: Starting thread to listen on port 80.
[Sun Mar 26 20:08:04 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sun Mar 26 20:08:04 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sun Mar 26 20:08:05 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sun Mar 26 20:08:05 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sun Mar 26 20:08:06 2006] [notice] Apache/2.2.0 (Win32) DAV/2 mod_ssl/2.2.0 OpenSSL/0.9.8a mod_autoindex_color PHP/5.1.1 configured -- resuming normal operations
[Sun Mar 26 20:08:06 2006] [notice] Server built: Dec  1 2005 18:36:53
[Sun Mar 26 20:08:06 2006] [notice] Parent: Created child process 3020
[Sun Mar 26 20:08:08 2006] [notice] Child 3020: Child process is running
[Sun Mar 26 20:08:08 2006] [notice] Child 3020: Acquired the start mutex.
[Sun Mar 26 20:08:08 2006] [notice] Child 3020: Starting 250 worker threads.
[Sun Mar 26 20:08:08 2006] [notice] Child 3020: Starting thread to listen on port 443.
[Sun Mar 26 20:08:08 2006] [notice] Child 3020: Starting thread to listen on port 80.
[Sun Mar 26 20:08:30 2006] [notice] Parent: child process exited with status 1073807364 -- Restarting.
[Sun Mar 26 20:08:30 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sun Mar 26 20:08:30 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sun Mar 26 20:08:31 2006] [notice] Apache/2.2.0 (Win32) DAV/2 mod_ssl/2.2.0 OpenSSL/0.9.8a mod_autoindex_color PHP/5.1.1 configured -- resuming normal operations
[Sun Mar 26 20:08:31 2006] [notice] Server built: Dec  1 2005 18:36:53
[Sun Mar 26 20:08:31 2006] [notice] Parent: Created child process 2444
[Sun Mar 26 20:08:33 2006] [notice] Child 2444: Child process is running
[Sun Mar 26 20:08:33 2006] [notice] Child 2444: Acquired the start mutex.
[Sun Mar 26 20:08:33 2006] [notice] Child 2444: Starting 250 worker threads.
[Sun Mar 26 20:08:33 2006] [notice] Child 2444: Starting thread to listen on port 443.
[Sun Mar 26 20:08:33 2006] [notice] Child 2444: Starting thread to listen on port 80.
[Sun Mar 26 20:08:40 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sun Mar 26 20:08:40 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sun Mar 26 20:08:40 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Sun Mar 26 20:08:40 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Sun Mar 26 20:08:41 2006] [notice] Apache/2.2.0 (Win32) DAV/2 mod_ssl/2.2.0 OpenSSL/0.9.8a mod_autoindex_color PHP/5.1.1 configured -- resuming normal operations
[Sun Mar 26 20:08:41 2006] [notice] Server built: Dec  1 2005 18:36:53
[Sun Mar 26 20:08:41 2006] [notice] Parent: Created child process 2816
[Sun Mar 26 20:08:43 2006] [notice] Child 2816: Child process is running
[Sun Mar 26 20:08:43 2006] [notice] Child 2816: Acquired the start mutex.
[Sun Mar 26 20:08:43 2006] [notice] Child 2816: Starting 250 worker threads.
[Sun Mar 26 20:08:43 2006] [notice] Child 2816: Starting thread to listen on port 443.
[Sun Mar 26 20:08:43 2006] [notice] Child 2816: Starting thread to listen on port 80.
[Sun Mar 26 20:09:39 2006] [notice] Apache/2.2.0 (Win32) DAV/2 mod_ssl/2.2.0 OpenSSL/0.9.8a mod_autoindex_color PHP/5.1.1 configured -- resuming normal operations
[Sun Mar 26 20:09:39 2006] [notice] Server built: Dec  1 2005 18:36:53
[Sun Mar 26 20:09:39 2006] [notice] Parent: Created child process 3204
[Sun Mar 26 20:09:40 2006] [notice] Child 3204: Child process is running
[Sun Mar 26 20:09:40 2006] [notice] Child 3204: Acquired the start mutex.
[Sun Mar 26 20:09:40 2006] [notice] Child 3204: Starting 250 worker threads.
[Sun Mar 26 20:09:40 2006] [notice] Child 3204: Starting thread to listen on port 443.
[Sun Mar 26 20:09:40 2006] [notice] Child 3204: Starting thread to listen on port 80.
[Sun Mar 26 20:09:54 2006] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Sun Mar 26 20:09:54 2006] [notice] Apache/2.2.0 (Win32) DAV/2 mod_ssl/2.2.0 OpenSSL/0.9.8a mod_autoindex_color PHP/5.1.1 configured -- resuming normal operations
[Sun Mar 26 20:09:54 2006] [notice] Server built: Dec  1 2005 18:36:53
[Sun Mar 26 20:09:54 2006] [notice] Parent: Created child process 2808
[Sun Mar 26 20:09:56 2006] [notice] Child 2808: Child process is running
[Sun Mar 26 20:09:56 2006] [notice] Child 2808: Acquired the start mutex.
[Sun Mar 26 20:09:56 2006] [notice] Child 2808: Starting 250 worker threads.
[Sun Mar 26 20:09:56 2006] [notice] Child 2808: Starting thread to listen on port 443.
[Sun Mar 26 20:09:56 2006] [notice] Child 2808: Starting thread to listen on port 80.

[/edit]
Blackskyliner
 
Posts: 4
Joined: 26. March 2006 19:30

Postby Blackskyliner » 27. March 2006 14:04

Ein neustart hat geholfen nu gehts aufeinmal :) :D :D :D Thx,

MFG
Blackskyliner
Blackskyliner
 
Posts: 4
Joined: 26. March 2006 19:30

Postby Blackskyliner » 27. March 2006 14:14

Zu früh gefreut :(( Der zeigt mir in PHPMyAdmin nur mist an..., bricht z.B. in der hälfte ab mit parsen oder son schwachsinn.. :(( was ist das denn? Da will man nur den XAMPP nutzen und nix geht >:(
Blackskyliner
 
Posts: 4
Joined: 26. March 2006 19:30

Absturz Apache

Postby mascheck » 03. April 2006 21:00

Hallo Black,

hast Du schon was gefunden? Bei mir schmiert der Apache auch in unregelmäßigen Abständen 3 bis 6 mal am tag ab - die Win Meldung muss abgedrückt werden, dann gehts weiter - mein Log sieht ähnlich deinem aus.

MfG
Andreas
mascheck
 
Posts: 3
Joined: 03. April 2006 20:51

Energieoptionen?

Postby mascheck » 04. April 2006 19:03

hier nochmal zu meinem Fehler, Apatche hat in unregelmäßiger Folge Wiki Seiten nicht gefunden oder wegen falscher Zeichen bemängelt und ist abgestürzt.

Der Apache läuft auf einem Laptop, dem hatte ich mitgegeben, daß nach 45 Min die Festplatte abgeschaltet wird. Nachdem ich das verhindert habe, lief der Laptop als Server heute ohne Beanstandungen. Ich kann mir allerdings den Zusammenhang nicht erklären. Die Abstürze erfolgten nämlich auch innerhalb der 45 Min Frist.

Ich werde, fall isch was anderes finde hier wieder posten.
mascheck
 
Posts: 3
Joined: 03. April 2006 20:51

Postby Sider » 05. April 2006 08:31

Das sieht ja fast nach meinem Problem aus:

http://community.apachefriends.org/f/viewtopi ... 8061#68061

Kommt bei dir auch diese Fehlermeldung?
Sider
 
Posts: 57
Joined: 13. February 2006 15:12

fast genauso

Postby mascheck » 07. April 2006 05:06

Hallo Sider,

Ich habe gestern und vorgestern viel mit mediawiki gearbeitet und einige meiner Kollegen gelegentlich - kein Absturz mehr!

Noch etwas habe ich zufällig gefunden, die Suchfunktion war irgendwie gestört - heute sollte ich auf php4 umschalten, angeblich ist mwiki in php4 geschrieben der neue xampp kommt aber mit php5. vielleicht liegt das auch daran??
mascheck
 
Posts: 3
Joined: 03. April 2006 20:51

Postby Sider » 07. April 2006 14:06

Also erstmal kommt der Fehler nur sporadisch, je nach Betriebssystem mehr oder weniger häufig, manchen Tag gar nicht, anderen Tag 10mal. Zu der Frage nach Php 4, dort kommt der Fehler ebenfalls, offenbar, weil es ja die gleiche Apache-Version ist.

Bekommst du denn nun diese Fehlermeldung oder nicht?
Sider
 
Posts: 57
Joined: 13. February 2006 15:12

Postby Sider » 18. April 2006 14:57

Habe meinen Fehler offenbar besiegt, siehe unter

http://community.apachefriends.org/f/viewtopic.php?t=16097
Sider
 
Posts: 57
Joined: 13. February 2006 15:12


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests