CPU Auslastung ist "Dank" dem Apache bei fast 99%

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

CPU Auslastung ist "Dank" dem Apache bei fast 99%

Postby BiTeMeNoW » 21. March 2006 18:15

Meine CPU Auslastung ist "Dank" dem Apache bei fast 99%
Bitte in der Datei \xampp\apache\conf\httpd.conf die Zeile => # Win32DisableAcceptEx entkommentieren. Also richtig:

Win32DisableAcceptEx

Standardgemäß ist im Apache seit jüngster Zeit eine verbesserte Winsock 2 - AcceptEx() Unterstützung etabliert, die aber nicht auf den Homevarianten (98/ME usw.) funktioniert. Leider sind ab und zu auch NT Systeme (2000 und Xp Professional) davon betroffen. Die Anweisung "Win32DisableAcceptEx" deaktiviert (disable) nun den eigentlich verbesserten Socket Zugriff bei Problemen.


Hallo Zusammen,

seit ich das neuste Xampp installiert habe (1.5.1) läuft eine Webapplikation von mir bedeutend langsamer. Jedes Mal als die Site abgerufen wird, verursacht apache.exe über 90% Auslastung. Ich hatte nur den Server (Windows 2003) neu installiert und sonst nix drauf installiert. Ich habe probiert mit dem eintrag wie oben in der FAQ beschrieben, aber ohne Erfolg (abgesehen davon, dass der Eintrag nicht mehr in der httpd.conf ist sondern in der oldhttp... was ich aber nicht weiss ob diese überhaupt gebraucht wird).

edit: Ich habe im Verzeichnis extra ein conf File gefunden mit dem Eintrag und das # entfernt. Hat nichts gebracht
Ich habe die Threads von 250 auf 64 runtergeschraubt und immer noch keine Besserung.
Firewall sind keine installiert da kein Inet anschluss. Ist ein Intranet-Server.

Kann mir jemand helfen?

Danke und Gruss
BiTeMeNoW
 
Posts: 5
Joined: 21. March 2006 18:07

Postby BiTeMeNoW » 23. March 2006 11:42

Ich sehe es schon ein. ich muss alles wieder neu installieren und zwar wieder auf 1.4.x.

Wirklich schade, dass keiner damit helfen kann. Das generieren eines .pdf dauert jetzt ca. 65 Sekunden. Musste somit sogar die timeout Grenze höher setzen ... Mit dem alten Xampp-Package benötigte der Server im Vergleich nur 13 Sekunden !!
BiTeMeNoW
 
Posts: 5
Joined: 21. March 2006 18:07


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests