Svc MySQL funktioniert nicht (bei Apache und FileZ. schon)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Svc MySQL funktioniert nicht (bei Apache und FileZ. schon)

Postby starwarsfan2001 » 12. March 2006 00:12

Hallo,

ich habe da ein Problem mit dem MySQL Autostart - Service - generell bei allen XAMPP-Versionen und etlichen Neuinstallationen + bei einem Freund ebenso. Alles hab ich mit dem XAMPP Control Panel gesteuert.

Undzwar ist es so, dass die Service (Svc) - Module bei Apache und FileZilla funktionieren und auch beim Start laufen.
Wenn ich bei MySQL nun Svc auswähle und dann MySQL starte, kommt unten nur "MySQL service started", was natürlich nicht stimmt. Es steht weder Running in grün da, noch ist es sonst angeschaltet.
Wenn ich Svc wieder ausschalte und dann MySQL starte, funktioniert es einwandfrei. Warum geht es aber nicht, dass ich es als Service starten will ?

Sehr praktisch wäre es nämlich schon, wenn es gleich bei Windowsstart mit Apache und Filezilla mitstartet, denn dann kann ich gleich von wo anders aus drauf zugreifen... ;)

Wäre also super, wenn jemand das Problem kennt und Rat weiß.

Mit freundlichen Grüßen,
starwarsfan2001

Image
User avatar
starwarsfan2001
 
Posts: 6
Joined: 06. August 2005 22:18
Location: localhost/home

Postby MPL » 12. March 2006 00:23

geh mal systemsteuerung > verwaltung > dienste such dort in der liste mal mysql aus und öffne es mit rechtsklick > eigenschaften und schau mal ob dort automatisch steht bei starttyp wenn nein stellt das auf automatisch und teste es dann
MPL
 
Posts: 59
Joined: 12. February 2006 22:54

Postby starwarsfan2001 » 12. March 2006 00:30

Hallo,

ist auf automatisch bereits gestellt, funktioniert immer noch nicht. :-(

MfG,
swf2001
User avatar
starwarsfan2001
 
Posts: 6
Joined: 06. August 2005 22:18
Location: localhost/home

Postby MPL » 12. March 2006 00:57

hmmm dann instalier mal xampp neu
MPL
 
Posts: 59
Joined: 12. February 2006 22:54

Re: Svc MySQL funktioniert nicht (bei Apache und FileZ. scho

Postby starwarsfan2001 » 12. March 2006 12:27

starwarsfan2001 wrote:Hallo,
ich habe da ein Problem mit dem MySQL Autostart - Service - generell bei allen XAMPP-Versionen und etlichen Neuinstallationen + bei einem Freund ebenso. Alles hab ich mit dem XAMPP Control Panel gesteuert.


Das hatte ich doch schon mehrmals... :roll:
User avatar
starwarsfan2001
 
Posts: 6
Joined: 06. August 2005 22:18
Location: localhost/home

Postby Wiedmann » 12. March 2006 12:42

Wenn ich bei MySQL nun Svc auswähle

Das war bereits der Fehler...

Vorbereitung:
(- für alle Schritte brauchst du Adminrechte)
- mach im CC erst einmal den SVC-Haken raus bei MySQL.
- beende das CC
- im Verzeichnis "\xampp" rufe zur Sicherheit die Batch "mysql_stop.bat" auf (kann ein Fehler angezeigt werden) und kontrolliere im Taskmanger ob der Prozess MySQL beendet ist (ansonsten dort killen).
- Führe in der Eingabeaufforderung folgendes Kommando aus (kann ein Fehler angezeigt werden):
Code: Select all
sc delete mysql


Test:
- starte MySQL über die "mysql_start.bat" in "\xampp".
- stoppe MySQL über die "mysql_stop.bat" in "\xampp".
beides muss ohne Fehler funktionieren. Wenn hier was anderen passiert genaue Ausgabe posten und nicht weitermachen.

Dienst einrichten:
- rufe im Verzeichnis "\xampp\mysql" die Batch "mysql_installservice.bat" auf.
- Jetzt wird der Dienst installiert und gleich gestartet (es darf kein Fehler angezeigt werden. Wenn ja dann diesen posten und nicht weitermachen)
- CC starten. MySQL wird dir jetzt als schon gestartet angezeigt und du kannst den Dienst dort jetzt starten und stoppen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests

cron