Wie date ich den Apache auf php 5.1.12 up???

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Wie date ich den Apache auf php 5.1.12 up???

Postby z80 » 01. March 2006 18:22

Habe den neuesten xampp v 1.5.1 installiert. Diese macht Zicken bei Mozilla mit Umlauten und portugiesischen Sonderzeichen.
Würde gerne wieder meinen alten Apache nehmen, der doeses Problem nicht hatte, jedoch ist das php dort veraltet v. 5.0.3!
Wie kann ich einen Apache auf die neuste php Version updaten?
z80
 
Posts: 1
Joined: 16. February 2006 12:26

Postby deepsurfer » 01. March 2006 18:54

Eine alte XAMPP version mit einem aktuellen PHP zu versehen wüsste ich jetzt nicht wie das geht, da die PHPversionen spezifisch zum XAMPP Compiliert wurden.

Was du aber mal testen kannst ist folgendes:

\xampp\apache\conf\extra\ httpd-language.conf editieren.

Es wurden einige Teile herausgenommen, kannst aber folgendes mal Hinzufügen unter die Zeile 76:
Code: Select all
LanguagePriority en ca cs da de el eo es et fr he hr it ja ko ltz nl nn no pl pt pt-BR ru sv zh-CN zh-TW
AddDefaultCharset ISO-8859-1 #<<<--- hinzufügen


Eventuell das ISO-8859-1 gegen UTF-8 austauschen.

Kannst das auch mal mit einer META angabe in deiner Page probieren
Code: Select all
<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">

Quelle:
http://de.selfhtml.org/html/kopfdaten/m ... nkodierung



Bedenke das nach jeden Ändern und Speicher der configfiles der Apache neu gestartet werden muss.

-- Mach dir aber bitte vorher eine Kopie der Datei, wenns nicht klappt hast du auf jedenfall erstmal wieder den Grundzustand wiederhergestellt. --
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Soulmerge » 02. March 2006 14:47

Ich habe heute soeben mein eigenes PHP auf Version 5.1.2 aktualisiert, da 5.1.1 einen Fehler enthält, der mir in die Quere gekommen ist. Im Prinzip ist es ganz einfach:
1. Zu allererst mal das alte php-Verzeichnis umbenennen (...\xampp\php -> ...\xampp\php.original)
2. Auf www.php.net die neueste zip-Datei für Windows herunterladen und in das ehemalige php-Verzeichnis kopieren (in ...\xampp\php)
3. Einige Erweiterungen müssen jetzt deaktiviert werden, dazu die Datei ...\xampp\apache\bin\php.ini editieren und folgende Zeilen mit einem Semikolon an erster Stelle auskommentieren:
extension=php_pdf.dll
extension=php_xsl.dll
4. Jetzt muss statt dem Apache-Modul das php aus dem Verzeichnis geladen werden. Dazu die Datei ...\xampp\apache\conf\extra\httpd-xampp.conf editieren. Dort sollte nun etwas in folgender Form zu sehen sein:
Code: Select all
#ScriptAlias /php/ "C:/Programme/xampp/php/"
#Action application/x-httpd-php "/php/php-cgi.exe"
LoadModule php5_module "C:/Programme/xampp/apache/bin/php5apache2.dll"

Hier werden die ersten zwei auskommentierten Zeilen entkommentiert (Somit wird php als cgi-skript aufgerufen, was ein wenig langsamer ist, als das Apache Modul) und die letzte Zeile auskommentiert. Anschließend muss noch eingefügt werden, dass Apache auf das php Verzeichnis zugreifen darf. Am Ende sollte das folgendrmaßen ausschauen:
Code: Select all
ScriptAlias /php/ "C:/Programme/xampp/php/"
Action application/x-httpd-php "/php/php-cgi.exe"
#LoadModule php5_module "C:/Programme/xampp/apache/bin/php5apache2.dll"
<Directory "C:/Programme/xampp/php">
    Order allow,deny
    Allow from all
</Directory>

@Admins: Könnte man diese Information irgendwie in die FAQ aufnehmen? Hätte mir jetzt sicher meinen Vormittag erspart :)
Soulmerge
 
Posts: 1
Joined: 02. March 2006 14:28

Re: Wie date ich den Apache auf php 5.1.12 up???

Postby KingCrunch » 02. March 2006 14:58

z80 wrote:Habe den neuesten xampp v 1.5.1 installiert. Diese macht Zicken bei Mozilla mit Umlauten und portugiesischen Sonderzeichen.
Würde gerne wieder meinen alten Apache nehmen, der doeses Problem nicht hatte, jedoch ist das php dort veraltet v. 5.0.3!
Wie kann ich einen Apache auf die neuste php Version updaten?

Dies tritt vorallen auf, wenn der Apache kein bevorzugten Zeichensatz mitsendet. Das sollte aber nicht der Apache regeln, sondern der Programmierer ;)
zB
Code: Select all
<meta http-equiv="Content-Type" content="text/html; charset=utf-8;"/>

In der alten Xampp-Version war (soweit ich das richtig mitbekommen habe) ein Default noch angegeben, was aber im Standard-Apache nich mehr so vorgesehen war, weswegen der Xampp jetzt auch darauf verzichtet.
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

php5.1.2

Postby spinne73 » 03. March 2006 10:59

servus,
ich würd mich eher darüber freuen wenn es so blad wie mögleich ein update von xampp geben würde auf php5.1.2, weil ich nämlich mit der 5.1.1er version auch massive probleme habe.
wann könnte man denn in etwa mit einem update rechnen? eine beta für linux gibt es ja bereits schon, wann würde denn eine für windoof erscheinen?
spinne73
 
Posts: 2
Joined: 03. March 2006 10:54

Postby deepsurfer » 03. March 2006 13:09

wann könnte man denn in etwa mit einem update rechnen? eine beta für linux gibt es ja bereits schon, wann würde denn eine für windoof erscheinen?


Windoof ? , dieses OS kenn ich nicht..

Inoffizielles Statement:
Es gab zur XAMPP für Linux 1.5.2beta auch eine XAMPP für Windows 1.5.2beta(s), aber da grössere Probleme auftauchten wurde die Beta für Windows gestoppt.
Die DEVs arbeiten soweit es ihre Zeit zulässt (Job / Privatleben) an einer
lauffähigen Version.
Eine Zeitrahmen wurde und wird nicht ausgesprochen durch besagte Zeiten.

Aber aus sicherer Quelle weiss ich das die DEVs nicht in der Sonne liegen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

re

Postby spinne73 » 03. March 2006 13:58

hmmm hab ich ja auch nicht behauptet das diese das tun ;) ich weiss das selber das devs nicht faul in der sonne liegen und nix tun...
aber anbei... vielleicht hast du ja auch eine lösung dazu:
http://www.openphpnuke.info/system/article/index.php?opnparams=VnZRaQYzXDwAPw
weil das ist eigentlich mein hauptproblem dass ich keine test-installation machen kann.
Mit wäre schon geholfen, wenn mir jemand einen tipp geben könnte wie ich das event. lokal umstellen kann. das obige hat mir nicht wirklich geholfen, da es wohl nen anderes problem ist. ;)

und ich glaub ob ich windows oder windoof schreibe ... das bleibt sich doch relativ gelich, das wirst du schon verstehen

thx greez
spinne73
 
Posts: 2
Joined: 03. March 2006 10:54

Postby valval » 13. March 2006 13:07

Can somebody translate the solution for upgrading to php 5.1.2 in english please?
valval
 
Posts: 3
Joined: 13. March 2006 12:55

Postby melchior » 14. March 2006 01:02

Die Lösung von Soulmerge funktioniert wunderbar. Danke.
Evt. noch, wenn man viel in der PHP.INI im Verzeichnis /xampp/apache/bin geändert hat, die php.ini nach /xampp/php kopieren.
melchior
 
Posts: 1
Joined: 14. March 2006 00:36
Location: Kiel


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests