ModRewrite und xampp 1.5.1

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

ModRewrite und xampp 1.5.1

Postby LANtastic » 19. February 2006 18:50

Ich bin mir nicht sicher, ob es nun ein Bug ist, oder aber auf meine Unfähigkeit zurückzuführen ist :)
Ach ja, ich weiss auch nicht, ob ich hier überhaupt im richtigen Board gelandet bin, falls nicht ... sorry und bitte verschiebt mich :D

Nun aber zu meinem Problemchen :

Bei einer älteren Xampp Version (vermutlich der Vorgänger der 1.5.1, aber ich weiss die genau Nummer nicht mehr), hatte ich keine Probleme mod_Rewrite zu aktivieren und zu benutzen.

Bei der aktuellen Version hab ich jedoch so meine Problemchen.
In der httpd.conf hab ich die Zeile, um das Modul zu laden entkommentiert und laut phpinfo() wird das Rewrite Modul auch geladen.

Soviel dazu.
Jedoch wird selbst die simpelste Umschreibung nicht vollführt.
Beispiel :
Code: Select all
RewriteRule ^(.*).htm$ $1.php

Sollte eigentlich jede Datei mit der Endung .htm intern auf die Endung .php umschreiben.
Das passiert jedoch nicht und ich lande jedesmal auf einer Fehlerseite, dass die Datei xxx.htm nicht gefunden werden konnte.

Nachdem ich mir die Logs angesehen habe finde ich dort den Eintrag :
Code: Select all
(2) init rewrite engine with requested uri /xxxx.htm
(1) pass through /xxx.htm


Das Problem ist also, dass trotz eines korrekten Eintrages in der .htaccess die Datei nicht erkannt wird und die Anforderung einfach an den Server durchgeleitet wird.
Alles ausprobiert und alles getestet, aber es will nicht klappen.
Hat jemand einen kleinen Wink mit dem Zaunpfahl?
Mit der älteren Verwendeten Xampp Version lief alles noch wunderbar.
LANtastic
 
Posts: 19
Joined: 19. February 2006 18:36

Postby KingCrunch » 19. February 2006 19:16

Code: Select all
RewriteRule ^(.*)\.htm$ $1.php

Wenn ich nich ganz falsch liege, fehlt da nen Backslash. In der httpd.conf "AllowOverride None" in "All" geändert?
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Selbsterkenntnis :)

Postby LANtastic » 19. February 2006 19:17

Einige graue Haare später :

Es klappt nun, nachdem ich in der httpd.conf folgendes geändert habe :

War :

<Directory "D:/xampp/htdocs">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride None
Order allow,deny
Allow from all
</Directory>


Ist nun:

<Directory "D:/xampp/htdocs">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride FileInfo
Order allow,deny
Allow from all
</Directory>
LANtastic
 
Posts: 19
Joined: 19. February 2006 18:36

Postby LANtastic » 19. February 2006 19:19

Hui .... da war ich 1 Minute zu langsam :)

Das mit der httpd.conf ist es gewesen.
Offenbar wurde diese Einstellung seit meiner älteren Version standardmässig geändert, auf jeden Fall klappt es nun.

Wobei sich mit da noch eine Frage stellt:

Was exakt ist der Unterschied zwischen "All" und den anderen Optionen.
Klar, statt alle anderen Optionen aufzulisten reicht es "All" zu verwenden, aber gibt es sonst noch einen Grund, warum man "All" statt z.B. "FileInfo" zu verwenden ?
LANtastic
 
Posts: 19
Joined: 19. February 2006 18:36

Postby KingCrunch » 19. February 2006 19:23

"All" is gewissemaßen eine Abkürzung für die Auflistung aller denkbaren Optionen. Wenn du nur "FileInfo" angibst, erlaubst du nicht das überschreiben der anderen Optionen "Options", "AuthConfig" und "Limit". Es kommt dann darauf an, obs in deinem Sinne ist ;)
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 15 guests