xampplite InnoDB anlegen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

xampplite InnoDB anlegen

Postby deetee » 14. February 2006 19:54

Ich habe in der my.ini diese Einstellungen gemacht


Code: Select all
#skip-innodb
# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir = D:/xampplite/mysql/data/
innodb_data_file_path = ibdata1:2000M:autoextend
# müssen das selbe Verzeichnis sein!
innodb_log_group_home_dir = D:/xampplite/mysql/data/
innodb_log_arch_dir = D:/xampplite/mysql/data/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
set-variable = innodb_buffer_pool_size=280M
set-variable = innodb_additional_mem_pool_size=30M
# Set .._log_file_size to 25 % of buffer pool size
set-variable = innodb_log_file_size=10M
set-variable = innodb_log_buffer_size=8M
innodb_flush_log_at_trx_commit=1
set-variable = innodb_lock_wait_timeout=50



Nach mehreren Neustarts von MySQL klappt das Anlegen von InnoDB Tabellen immernoch nicht.

In phpmyadmin kann ich auch den Tabellentyp aus dem Dropdown Feld gar nicht auswählen. Wenn ichs per SQL Ausdruck versuche, wird statt einer InnoDB der Standardtyp MyISAM angelegt.

Über ein Desktop Tool habe ich es auch versucht, da ist das selbe Problem.

Weiß jemand Rat?

edit:
Mein System:
WindowsXP
xampplite mit MySQL 5.015
deetee
 
Posts: 6
Joined: 14. February 2006 19:05

Postby Wiedmann » 14. February 2006 20:43

Ich habe in der my.ini diese Einstellungen gemacht

Normal nennt sich diese Datei "my.cnf" und ist im Verzeichnis "D:\xampplite\mysql\bin".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deetee » 14. February 2006 21:01

Hallo,

danke, ich habs gleich mal ausprobiert, aber auch dann hab ich das selbe Ergebnis. Es lassen sich keine InnoDB Tabellen anlegen.

Kann es daran liegen, dass MySQL evtl. in xampplite nicht mit InnoDB kompiliert wurde?

Ist nur eine Vermutung, was anderes fällt mir nämlich nicht mehr ein.
deetee
 
Posts: 6
Joined: 14. February 2006 19:05

Postby deetee » 18. February 2006 02:27

Kann mir evtl. jemand sagen, wie ich rausfinden kann, ob MySQL mit InnoDB Unterstützung kompiliert wurde?

Oder zumindest, ob es in xampplite der Fall ist.
deetee
 
Posts: 6
Joined: 14. February 2006 19:05

Postby Wiedmann » 18. February 2006 11:31

Oder zumindest, ob es in xampplite der Fall ist.

Ist es.

Kann mir evtl. jemand sagen, wie ich rausfinden kann, ob MySQL mit InnoDB Unterstützung kompiliert wurde?

Ob es aktiviert ist oder nicht siehst du mit:
Code: Select all
SHOW VARIABLES LIKE 'have_innodb';

(Im phpMyAmdin würde es da auch einen Link dafür geben)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deetee » 19. February 2006 00:56

Danke für die antwort.

Also hava_innodb ist auf Disabled gesetzt.

Gut, was muss ich denn noch ändern, außer die bisher genannten Änderungen?
deetee
 
Posts: 6
Joined: 14. February 2006 19:05

Postby Wiedmann » 19. February 2006 01:16

Wenn:
Also hava_innodb ist auf Disabled gesetzt.


Dann ist in der Konfig-Datei die MySQL benutzt:
Code: Select all
skip-innodb

eingetragen (also ohne "#").

Oder MySQL benutzt keine Konfigdatei.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deetee » 19. February 2006 01:21

Also ich habe Werte in der my.cnf geändert und dann über ein DB Tool die Werte angeschaut, die Werte wurden jedesmal übernommen. Also MySQL benutzt dann wohl die my.cnf Datei. Aber skip-innodb ist auskommentiert. Ich habs sogar schon ganz rausgenommen, hat auch nichts geändert.
deetee
 
Posts: 6
Joined: 14. February 2006 19:05

Postby Wiedmann » 19. February 2006 17:44

xampplite mit MySQL 5.015

Das dürfte dann der XAMPP Lite version 1.5.0 sein. Den hab ich mir jetzt mal
- runtergeladen
- entpackt
- in "\xampplite\mysql\bin\my.cnf" Zeile 63 ein "#" davor hingemacht --> "#skip-innodb"
- MySQL über "\xampplite\mysql_start.bat" gestartet

E:\xampplite\mysql\bin>mysql -u root
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 1 to server version: 5.0.15

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> show variables like 'have_innodb';
+---------------+-------+
| Variable_name | Value |
+---------------+-------+
| have_innodb | YES |
+---------------+-------+
1 row in set (0.24 sec)

mysql> quit
Bye

E:\xampplite\mysql\bin>
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deetee » 20. February 2006 03:08

Also unabhängig von diesem Problem habe ich mir die neuste xampplilte Version 1.5.1 installiert und da hat es auf Anhieb funktioniert.

Sorry für die Umstände. Erklären kann ich mir das nicht.
deetee
 
Posts: 6
Joined: 14. February 2006 19:05

Postby feroce » 22. February 2006 01:20

Hallo,

ich hatte bis eben das gleiche Problem. Beim Einrichten von MySQL wird im Windows-Ordner eine my.ini abgelegt. (Kriegt man auch in der Eingabeaufforderung angezeigt, beim Einrichten als Dienst) Diese Datei wird auch beim Aufruf von WinMySQLadmin benutzt. Allerdings verwendet sie MySql nicht. MySQL greift auf die my.cnf im Ordner "mysql\bin" zu... Darauf soll man dann erstmal kommen!! Und ich dachte ich bin zu blöd die Einstellungen zu editieren... komische Windows-Welt...

Ich hoffe damit konnte ich einigen verwirrten Leuten helfen.
feroce
 
Posts: 1
Joined: 22. February 2006 01:05

Postby TBaDDadE » 04. April 2006 18:46

Hej,

ich verwende XAMPP 1.4.9 und wollte nachfragen ob ich auch in diesem Xampp die innodb aktivieren kann. Wenn ja, wie sollte ich vorgehen.

Vielen Danke für Eure Hilfe

Thomas
TBaDDadE
 
Posts: 11
Joined: 09. December 2004 18:33

Postby Wiedmann » 04. April 2006 20:42

siehe oben...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests