mod_rewrite bzw. .htaccess

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

mod_rewrite bzw. .htaccess

Postby Hans_Dampf » 14. February 2006 00:24

hallo. ich wollte mal etwas mit mod_rewrite spielen. bekomme es aber im xampp 2.1 auf windows xp nicht hin, dass der meine .htaccess liest.

meine \xampplite\apache\conf\http.conf sieht folgendermassen aus (in auszügen):
Code: Select all
LoadModule rewrite_module modules/mod_rewrite.so
...
<Directory />
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>


apache habe ich schon (mehrfach) durchgestartet. trotzdem sagt mir das testscript von http://modrewrite.info/index.php?mod_rewrite_faq2 immer, mod_rewrite sei nicht aktiviert. wer weiss rat?
Hans_Dampf
 
Posts: 2
Joined: 14. February 2006 00:18

Postby Wiedmann » 14. February 2006 00:44

bekomme es aber im xampp 2.1 auf windows xp nicht hin,

Sorry, aber es gibt keinen XAMPP 2.1. Die neuste Version ist 1.5.1.

Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

Dies entspricht aber nicht mehr dem Standard an dieser Stelle. Solltest aus Sicherheitsgründen wieder zurückändern.

Code: Select all
LoadModule rewrite_module modules/mod_rewrite.so

Soweit ok,...

dass der meine .htaccess liest.

Im XAMPP 1.5.1 ist hier tatsächlch ein Fehler (siehe Forumssuche...), dass für das Directory "\xampp\htdocs" AllowOverride auf "none" und nich auf "all" gesetzt ist (gesetz dem Fall du hast deine ".htaccess" auch da drin).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Hans_Dampf » 14. February 2006 17:16

Ich hielt die Nummer bei diesem Control-Tool für die XAMPP Version. Habe 1.5.1. Sicherheitsaspekte sind mir jetzt erstmal egal, ich brauche Unterstützung für .htaccess. Deshalb habe ich ja auch schon bei den angegebenen Einstellungen herumexperimentiert. Aber egal ob so wie oben angegeben oder so:
Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride All
    Order deny,allow
    Deny from all
</Directory>

es funktioniert einfach nicht. Wie du siehst habe ich AllowOverride auf All stehen, bringt mir nur leider überhaupt nichts.
Hans_Dampf
 
Posts: 2
Joined: 14. February 2006 00:18

Postby Wiedmann » 14. February 2006 17:20

Wie du siehst habe ich AllowOverride auf All stehen, bringt mir nur leider überhaupt nichts.

Möglich das du das dort jetzt auf "All" hast. Allerdings hab ich dir bereits gesagt, /wo genau/ du das auf "All" stellen musst.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests