Forum einbinden?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Forum einbinden?

Postby DannyXX » 10. February 2006 20:35

Hallo,

ich habe den XAMPP installiert und läuft auch alles.

Weiterhin habe ich ein Forum phpBB downgeloadet und Dateien entpackt. Nun weiß ich nicht weiter. Wie binde ich das Forum ein bzw. wie läuft das Forum auf meinem Browser.
Zur Info noch: Der Server und das Forum sollen auf meinem PC laufen.

Ich habe null Plan davon und wäre dankbar für eine simple Erklärung.

Vielen Dank vorab und viele Grüße
Danny
DannyXX
 
Posts: 21
Joined: 10. February 2006 20:27

Postby KingCrunch » 10. February 2006 20:40

Dann wäre son Basic-Tutorial eventuell angebrachter. Du entpackst die Dateien ins htdocs. Danach folgst du den Anweisung des Forums ;)
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby DannyXX » 11. February 2006 07:40

Hallo und vielen Dank.

Datein habe ich entpackt. In der Readme steht:

Welcome to PBLang bulletin board!

Installing Powerboards is VERY easy if you follow the instructions TO THE LETTER. Please read the step-by-step instructions below:
NOTE: If you want to add another language, please read the language-readme-file

Upload the entire PBLang/ folder to your PHP capable (!!!) server. If you update, read the section about updating in the file PBLang-doc.txt very carefully! Have a look at PBLang-update.txt as well!
CHMOD ALL DIRECTORIES TO 777. This includes the image directory templates/pb/images/ranks and the files in this directory. The other files which need to be set writeable should be set by the installation script, so you do not need to worry about them
Open your browser to http://www.yourdomain.com/PBLang/install.php. Obviously replacing "yourdomain.com" with YOUR DOMAIN.
The install program will check the setup and report in plain English the problems it encountered. First fill in the fields, if they aren't already filled in automatically by the install program. Just follow the instructions in the installation procedure
If you didn't receive any error message, you are done, otherwise, do what is recommended in the error message, and run install.php again. In case of any problems, contact me through the PBLang support forum!
Go into your PBLang-board and register as the first user. This first user will have admin status.
Visit the project page for many addons, additional graphics, avatars and language sets!
All done. Enjoy your new board.


Das trifft für mich doch gar nicht zu oder? Ich will das Forum ja an keine Homepage legen.

Wie bekomme ich dann das Forum gestartet?

Wenn ich auf index klicke, startet der Index des Forums im Browser und es wird " Nice try bozo" angezeigt. Weiß nicht, ob das relevant ist.

Könnte mir noch mal jemand helfen?

Viele Grüße
Danny
[/b]
DannyXX
 
Posts: 21
Joined: 10. February 2006 20:27

Postby JollyFine » 11. February 2006 11:40

hi,
wenn du das forum auf deinem rechner laufen lassen willst, musst du erst mal sehen das du dir ein tool besorgst, dass deine ip ständig aktuell hält, denn du willst ja, dass die leute dein forum finden. da sich deine ip in der regel täglich ändert, kannst du das über einen dienst wie zb. dyndns.org machen. besorg dir dort einen account und ein entsprechendes updatetool für die ip.

allein die dateien des phpbb nur in dein htdocs zu legen bringt nichts, du musst das forum schon installieren. das kannst du local machen, macht aber mehr sinn, wenn du das über die adresse machst die du dir bei dyndns geholt hast.

funktioniert in der regel dann etwa so:
browser aufmachen
http://deinedomainadresse/phpbb/admin/install.php (das ist nur ein beispiel, den genauen installpfad entnimmst du deiner phpbbdoku) eingeben und anschliessend den anweisungen der install folgen.
ist das alles korrekt abgelaufen, kannst du dein forum über zb.
http://deinedomain/phpbb/index.php aufrufen.
vor derr installation solltest du natürlich den xampp, also apache und mysql gestartet haben - sonst wird das nix.

greez
Jolly
JollyFine
 
Posts: 22
Joined: 29. January 2006 11:10

Postby DannyXX » 11. February 2006 12:25

Hallo,

wie kann ich das Forum local installieren? Sorry, ich vergaß: Das Forum soll nur vom Heim-PC genutzt werden und nicht von anderen Surfern.

Muß ich so ein Zertifikat laden?

Vielen Dank

Viele Grüße
Danny
DannyXX
 
Posts: 21
Joined: 10. February 2006 20:27

Postby DannyXX » 11. February 2006 13:32

Hallo,

wenn ich - ob es richtig ich, weiß ich nicht - in den Browser:
http//localhost/pblang/install.php eingebe, erscheint folgender
Fehler: Error 404
localhost
02/11/06 13:27:35
Apache/2.2.0 (Win32) DAV/2 mod_ssl/2.2.0 OpenSSL/0.9.8a mod_autoindex_color PHP/5.1.1

Liegt das an dem nicht aktivierten Zertifikat, weil dort auch open SSL steht?

Kann mir jemand helfen?

Gruß Danny
DannyXX
 
Posts: 21
Joined: 10. February 2006 20:27

Postby KingCrunch » 11. February 2006 13:58

Nein, 404 heißt "Seite nicht gefunden"
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby deepsurfer » 11. February 2006 14:03

Back to the Root...

1) Welche XAMPP Version ? (auch angabe ob Installer/ZIP/EXEzip)
2) Welches Windows

Ausgehend von einer Absoluten Grundinstallation des XAMPP, also ohne jegliche Änderung an irgendwelchen Configs und ohne Änderung irgendwelcher Pfade die bei der Installation/Entpacken des XAMPP vorgegeben sind.
(Zum gegentest habe ich hier die aktuelle 1.5.1 ZIP und die 1.5.2 beta1 EXEzip Version benutzt)

1)
XAMPP starten, und mittels http://localhost die Sprache auswählen und im Willkommenscreen des XAMPP prüfen ob die darin befindlichen Demos und Informationsseiten einwandfrei laufen.

Trifft das bei dir zu ?
Ohne diesen Test brauchst du gar nicht erst weiter lesen !


2)
phpBB in das Verzeichnis \xampp\htdocs entpacken.
Folglich sieht es dann so aus \xampp\htdocs\phpbb2
Für dieses Tut habe ich die phpBB2-2.0.19-deutsch.zip geholt (aktuelle Version auf phpbb.de)

3)
http://localhost/phpmyadmin , darin im Eingabefeld (DB erstellen) phpbb eingeben und abschicken.
Jetzt wird eine DB in MySQL erstellt die das phpBBforum benötigt

4)
http://localhost/phpbb2 -->hier sollte direkt die Installationpage des phpBB kommen.
In dieser Page werden Fragen gestellt.

Kategorie Grundeinstellung:
Datenbanktyp ändern auf MySQL 4.x/5.x

Kategorie Datenbankkonfiguration:
Datenbank: Host / DSN: localhost
Name der Datenbank: phpbb
Datenbank Benutzername: root
Datenbank Passwort:
<<--- leer lassen, sofern das XAMPP Securityscript nicht ausgeführt wurde, ansonsten das MySQL Passwort hier eintragen.
Prefix für die Tabellen in der Datenbank: phpbb_

Kategorie Administratorkonfiguration:
E-Mail Adresse des Administrators: kannst du deine eintragen
Domainname: 127.0.0.1
Server Port: 80
Scriptpfad: phpbb2
Administrator Benutzername: entweder admin oder irgendwas (merken !)
Administrator Passwort: denk dir was aus (logisch oder)
Administrator Passwort [ Bestätigung ]: brauch ich nix zu sagen


Jetzt nur noch zweimal Klicken und das Forum ist betriebsbereit.

Hinweis !!!!!!!!!!!!!!!!
Wenn du das Forum über die Administration einstellt, so stelle bitte die Mailfunktion ab, das heisst,
- bei Anmeldung KEINE Mail
- Private Nachrichten per Mail abschalten
- Mailversand von User zu User abschalten

Warum ??, weil zwar ein Mailserver beim XAMPP dabei ist, aber laut deiner Aussage du es nur local nutzen willst und ich hier und jetzt keine Mercury-Mail-Server Anleitung schreiben werde.

Dazu bitte ich dich weiter hier im Forum umher zu lesen, denn da existieren jede menge Fragen mit Lösungen dazu.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby DannyXX » 11. February 2006 14:36

Hallo,

vielen Dank, das geht alles. Bin mir nun unsicher. Du schreibst:

3)
http://localhost/phpmyadmin , darin im Eingabefeld (DB erstellen) phpbb eingeben und abschicken.
Jetzt wird eine DB in MySQL erstellt die das phpBBforum benötigt

4)
http://localhost/phpbb2 -->hier sollte direkt die Installationpage des phpBB kommen.
In dieser Page werden Fragen gestellt.


Also von einem phpBBforum bzw. phpbb2. Ich habe ein Forum runtergeladen und entpackt in xampp von PBLang.

Muß ich trotzdem obige Eingaben schreiben?

Gruß Danny
DannyXX
 
Posts: 21
Joined: 10. February 2006 20:27

Postby deepsurfer » 11. February 2006 15:48

Also von einem phpBBforum bzw. phpbb2. Ich habe ein Forum runtergeladen und entpackt in xampp von PBLang.

Verstehe das nicht, "entpackt in xampp von PBlang

Erkläre deine schritte bitte nochmal, sorry, aber bevor es nachher ein irrtümer entstehen aufgrund von miss verständnissen, dann ist das geschrei noch grösser.

Muß ich trotzdem obige Eingaben schreiben?

Ja, denn wie ich beschrieben habe wird hierdurch erst eine Datenbank in MySQL erstellt worin die Forumsoftware die daten ablegt.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby DannyXX » 11. February 2006 16:47

Hallo,

ich habe ein Forum von PBLang heruntergeladen (nicht phpBB2)

Die Dateien habe ich extrahiert in die Datei des Xampp namens htdocs

Xampp, Version Win32 1.5.1 läuft alles, und die Dateien des PBLang-Forums starten auch mit dem Server in der Eingabeaufforderung (?) Es erfolgt jedoch ein Abbruch, weil die Web-Adresse fehlt anscheinend.

Du schriebst, ich solle PhpBB bzw. phpBB2 eingeben. Muß ich das denn auch bei einem Forum von PBLang? Ist da nicht die Eingabe Pbl z.B.?

Auch so und Betriebssystem ist Win XP

Gruß Danny
DannyXX
 
Posts: 21
Joined: 10. February 2006 20:27

Postby KingCrunch » 11. February 2006 17:17

Wo ist eigentlich das Problem?
Du hast doch oben die Installationsanleitung selbst gepostet :?:
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby deepsurfer » 11. February 2006 18:25

So....jetzt kommen wa der Sache schon näher....

Also ich hab das PBLang gefunden.
Es ist KEIN SQL basiertes BulletinBoard, also ist die sache mit dem phpmyadmin schonmal abgehakt.

Ich hab das ding auch mal heruntergeladen, entpackt in htdocs und
http://localhost/pblang/install.php aufgerufen (so wie es in der Anleitung steht)

Nungut es kommt die erste Installermaske
- der erste Pfad eintrag ist automatisch ausgelesen und stimmt.
- die URL Angabe lautet normalerweise dann http://localhost/pblang
- mailadresse iss klar.
- sprachauswahl auch

Beim Abschicken dieser Daten macht der Installer aber eine Fehlermeldung bezugnehmend auf eine Template für die Sprache

Code: Select all
Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in C:\xampp\htdocs\pblang\templates\pb\language\lang_fr.php on line 711


Hierbei geh ich nun von aus das dieses Produckt aus Oktober 2004 nicht richtig funktioniert.
Auch ein Umswitchen auf PHP4 brachte diese Meldung.

Ich muss aber jetzt gestehen das ich zu faul bin im Support Forum von PBLang zu schauen.
Vielleciht mach ich das morgen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby DannyXX » 11. February 2006 19:15

Hallo und danke für die Mühe,

so weit wie Du komme ich erst gar nicht, da ich keine Domain habe. Ich kann also nicht der Installationseinleitung folgen und in den Browser eingeben "www.mydomain.com/PBLang/install.php.

Auf localhost/PBLang/install.php nimmt er es nicht.

Wie bekomme ich dann die Installationsseite?

Gruß Danny P.S: Hast du in der Anleitung was von http://localhost/PBLang/install.php stehen? Wenn ja, wo, denn das habe ich nicht in meiner gesehen.
DannyXX
 
Posts: 21
Joined: 10. February 2006 20:27

Postby KingCrunch » 11. February 2006 19:26

"www.mydomain.de" ist in diesem Fall gleichbedeuten mit "localhost"
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests