PHP läuft nicht?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

PHP läuft nicht?

Postby Marcel_1 » 03. February 2006 13:58

Hallo,

ich habe XAMPP 2.1 installiert.
Im ControlPanel steht hinter Apache, MySQL und FileZilla "Running".
Aber PHP Code wird nicht ausgeführt.

Ich habe Virtuelle Hosts angelegt.

Wenn ich jetzt die einzelnen lokalen Domains aufrufe, dann wird der html Teil angezeigt aber sobald php vorkommt wird dies nicht ausgeführt.

Beispiel:
********************
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html>
<head>
<title>Testseite</title>
</head>

<body>
Das ist ein PHP-Test
<br>
<?php
echo "Die aktuelle PHP-Konfiguration:<br>";
phpinfo();
?>

</body>
</html>
********************

"Testseite" und "Das ist ein PHP-Test" wird dargestellt aber "Die aktuelle PHP-Konfiguration" sowie phpinfo() werden nicht dargestellt bzw. ausgeführt.

Was habe ich da falsch gemacht?
Hat jemand eine Idee?

Vielen Dank + Gruß

Marcel
Marcel_1
 
Posts: 15
Joined: 26. January 2006 12:41

Postby Hanspeter Thöni » 03. February 2006 15:59

Darf man fragen, wo die Datei liegt, und wie du diese im Browser aufrufst?
Gruss Hanspeter
User avatar
Hanspeter Thöni
 
Posts: 233
Joined: 17. August 2004 10:29
Location: Schweiz

Postby KingCrunch » 03. February 2006 16:12

Desweiteren: phpinfo erzeugt eine komplette html. Das du dies noch zusätzlich in html einbettest, führt zu einer fehlerhaften html-syntax. Möglicherweise ignoriert das der Browser. Möglicherweise auch nicht ;)
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Marcel_1 » 03. February 2006 16:22

Hallo,

das hat sich erledigt.
Es lag an einem falschen Eintrag inder Datei httpd-vhosts bezüglich localhost.

Jetzt habe ich aber ein neues Problem:

Mache Dateien mit php-Code muss ich mit der Endung .html abspeichern. Damit diese geparsed werden habe ich in der .htaccess Datei den folgenden Entrag eingefügt:
AddType x-mapp-php4 .php .html .htm

Bei PHP4 hat das problemlos funktioniert nun aber mit XAMPP und PHP5 funktioniert es nicht mehr.

Auch Versuche das mit
AddType x-mapp-php .php .html .htm
oder
AddType x-mapp-php5 .php .html .htm

hinzubekommen schlugen fehl.

Wie kann ich das nun wieder hinbekommen?

Vielen Dank

Gruß Marcel
Marcel_1
 
Posts: 15
Joined: 26. January 2006 12:41

Postby KingCrunch » 03. February 2006 16:35

Eventuell wird dies durch ein AddType mit html überschrieben oder so. Ich kenne allerdings auch keinen Grund php als html zu speichern...
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests