.htaccess wird überhaupt nicht berücksichtigt

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

.htaccess wird überhaupt nicht berücksichtigt

Postby MatzeMuc » 02. February 2006 18:32

Hallo,

ich habe XAMMPP installiert, das DocumentRoot von C auf D verlegt. Jetzt möchte ich das gesamte Dcument Root per .htaccess sichern. In meiner http.conf des Apache habe ich "AccessFileName .htaccess " nicht finden können, also habe ich es manuell bei ausgeschaltenem Apache gemacht. Leider interessiert ihn weder davor noch danach meien .htaccess Datei. In der Datei steht folgendes:
AuthName "Server"
AuthType Basic
AuthUserFile "C:\[...]\xampp.users"
require valid-user

Woran liegt es, dass ihn die Abfrage nicht interessiert?
Mein Ziel ist es mittels .htacess gewisse IPs ohne abfrage durchzulassen und alle anderen (kommen übers internet) müssen das Passwort eingeben. Allerdings sollte davor mal das im Grundmodus funktionieren.
Vielen Dank
MatzeMuc
 
Posts: 3
Joined: 02. February 2006 18:15

Postby Wiedmann » 02. February 2006 18:43

In meiner http.conf des Apache habe ich "AccessFileName .htaccess" nicht finden können,

Das ist der Default, weshalb man es nicht unbedingt nachmals reinschrieben muss.

Leider interessiert ihn weder davor noch danach meien .htaccess Datei.

Dafür gibt es in dieser Datei ein "AllowOverride None" für's htdocs, worin dein Problem begründet ist.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby KingCrunch » 02. February 2006 18:55

Jep, in der httpd.conf ist neuerdings ein AllowOverride None eingetragen. Dafür hat sich das Xampp-Team auch schon entschuldigt ;) (oder so ähnlich)
Einfach ändern in
Code: Select all
AllowOverride All
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby MatzeMuc » 06. February 2006 17:46

Ich habe nun foilgendes drinnenstehen, was aber an meinem Problem nichts ändert!

AccessFileName .htaccess

#
# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
#
# First, we configure the "default" to be a very restrictive set of
# features.
#
<Directory />
Options FollowSymLinks
AllowOverride All
Order deny,allow
Deny from all
</Directory>
MatzeMuc
 
Posts: 3
Joined: 02. February 2006 18:15

Postby KingCrunch » 06. February 2006 18:07

Is das jetz deine htacces oder deine httpd? :?: Ansonsten müssteste eventuell noch das "Deny from All" überschreiben
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Wiedmann » 06. February 2006 18:08

Ich habe nun foilgendes drinnenstehen, was aber an meinem Problem nichts ändert!

Yup. dürfte daran liegen, dass du vorhergehende Posts nicht genau genug liest...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby MatzeMuc » 06. February 2006 18:25

Laos ich habe nun das Deny from All auskommentiert.
Die Ángaben bezogen sich auf die httpd.conf
Leider klappt es immer noch nicht.
Firefox?
Danke
MatzeMuc
 
Posts: 3
Joined: 02. February 2006 18:15

Postby lugau45 » 14. February 2006 19:03

gibt es schon eine lösung? wenn ich in der httpd.conf in der zeile 233
Code: Select all
#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "C:/Programme/xampp/htdocs">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important.  Please see
    # http://httpd.apache.org/docs/2.2/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks Includes ExecCGI

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    #
    AllowOverride None

    #
    # Controls who can get stuff from this server.
    #
    Order allow,deny
    Allow from all

</Directory>

aus non all mache geht es aber ich kann mich nicht einloggen wie es in der .htpwd steht
irgendwas ist ja immer...
Skype me...
User avatar
lugau45
 
Posts: 106
Joined: 25. July 2004 10:31

Postby Wiedmann » 14. February 2006 19:17

wenn ich in der httpd.conf in der zeile 233 aus non all mache geht es aber ich kann mich nicht einloggen wie es in der .htpwd steht

Dann wird in deiner ".htpwd" etwas falsches drinstehen oder diese Datei nicht gefunden werden.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby lugau45 » 14. February 2006 19:30

wie ist das bei windows mit dem passort kann ich da benutzer:passwort oder wie?
irgendwas ist ja immer...
Skype me...
User avatar
lugau45
 
Posts: 106
Joined: 25. July 2004 10:31

Postby Wiedmann » 14. February 2006 19:34

wie ist das bei windows mit dem passort kann ich da benutzer:passwort oder wie?

yup. Der Apache wird unter jedem OS im Prinzip gleich konfiguriert.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby lugau45 » 14. February 2006 19:42

hmm komisch geht nicht test:test steht drin geht nicht.
htacces:
AuthType Basic
AuthName "Administrationsbereich"
AuthUserFile "C:/Programme/xampp/htdocs/.../admin/.htpasswd"
require valid-user
irgendwas ist ja immer...
Skype me...
User avatar
lugau45
 
Posts: 106
Joined: 25. July 2004 10:31

Postby lugau45 » 14. February 2006 20:03

geht jetzt lag an der htpasswd
irgendwas ist ja immer...
Skype me...
User avatar
lugau45
 
Posts: 106
Joined: 25. July 2004 10:31


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests