[mod_rewrite]Server findet Dateien nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

[mod_rewrite]Server findet Dateien nicht

Postby Dr KillerJoe » 27. January 2006 23:29

Hallo.

1.)Ich verwende ein Cms, welches die Url's zB article_id=12&clang=0 umwandelt in .../12_0_name.html umwandelt

allerdings funktionieren die Links nur, wenn die Links wie folgt aussehen: /?/12_0_name.html

entfernt man das ?/ funktionieren die Links nicht mehr. Einer aus dem Entwicklerteam sagte mir, daß es daran liegen muß, daß das Modul mod_rewrite nicht auf dem Server ist <- Es ist inkl und auch aktiv laut phpinfo()...

inhalt der .htaccess
Code: Select all
RewriteEngine On
# RewriteBase /htdocs/demo/
RewriteRule ^([0-9]*)-([0-9]*)- index.php?article_id=$1&clang=$2&%{QUERY_STRING}


Verwendet wird xampp 1.5 (apache2.2, mysql5, php5)

2.) Das zweite was mich stört in dem zusammenhang ist, daß alle Links auf Localhost verweisen und somit von extern nicht zu brtrachten sind!!!!! Wie kann ich das ändern?
Dr KillerJoe
 
Posts: 35
Joined: 19. January 2006 22:38

Postby Dr KillerJoe » 28. January 2006 22:32

Weiß keiner Rat??

Server OS ist WinXP Home
Dr KillerJoe
 
Posts: 35
Joined: 19. January 2006 22:38

Postby Wiedmann » 28. January 2006 23:44

zu 1)
evtl.: http://community.apachefriends.org/f/viewtopi ... ride#66344

zu 2)
Doku und/oder Support vom CMS.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Dr KillerJoe » 29. January 2006 00:29

Danke!!!

Problem nr 1.) hat sich somit erledigt!!!

Problem nr 2.) besteht noch immer... eine weitere Installation des CMS (andere DB) funktioniert wunderbar, benutzt aber auch nicht den mod_rewrite!!! Wenn da jemand noch nen kleinen Tip hätte wärs super!!!
Dr KillerJoe
 
Posts: 35
Joined: 19. January 2006 22:38

Postby KingCrunch » 29. January 2006 10:38

Versuch ma in der httpd.conf den Server zu ändern
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Dr KillerJoe » 29. January 2006 11:06

KingCrunch wrote:Versuch ma in der httpd.conf den Server zu ändern


Den Servernamen?? oder was??
Dr KillerJoe
 
Posts: 35
Joined: 19. January 2006 22:38

Postby KingCrunch » 29. January 2006 11:44

joa
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Dr KillerJoe » 29. January 2006 12:00

Was sollte der Servername damit zu tun haben? eine weitere Instanz des CMS funktioniert!!! Diese ist allerdings ohne aktivem mod_rewrite.
Dr KillerJoe
 
Posts: 35
Joined: 19. January 2006 22:38


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests