Probelme bei Mailsversand mit PHP und Mercuy

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Probelme bei Mailsversand mit PHP und Mercuy

Postby dam » 17. January 2006 10:43

Hallo,

ich habe ca. 2.000 Mails per PHP und Mercury versenden wollen auf xampp - mit dem Befehl mail().

Das erste Problem war eine Zeitüberschreitung von PHP, dieses Problem ist behoben.

Hier meine weiteren, noch nicht gelösten Probleme - vielleicht weiß jemand eine dieser Probleme:
1.
Mercury versendet nur ca. 17 Mails auf einmal - bei den darüberliegenden trifft ein Fehler (glaube 554 auf). Jetzt weiß ich nicht ob er die anderen versenet oder nicht. Ich habe das Problem so probiert zu lösen, dass ich PHP gesagt habe, dass er jede 40 Sec. 17 Mails weitergibt (sleep() - Funktion). Ist eine etwas schwache Lösung. Ich würde gerne so schnell wie möglich alle Mails an den Mercury senden.

2.
Wenn ich über den Internetexplorer auf meinem Server die php-Datei starte, die Mails versendet erscheint nach 10 oder 20 Min. die Seite im Internetexplorer: "Seite kann nicht angezeigt werden...". Also die normale Meldung von Explorer. (Timeout in php.ini steht auf 86400 Sec. also 24 Stunden). Bei diesem Internetexplorer-Fehler "Seite kann nicht angezeigt werden..." wird automatisch das php-Script abgebrochen und somit werden nicht alle Mails versendet. Wie kann ich dieses Problem beheben?

Hoffe jemand kann mir helfen.

Danke
dam
 
Posts: 5
Joined: 30. December 2005 13:38

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests