Kein mod_rewrite

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Kein mod_rewrite

Postby narc » 16. January 2006 00:27

Hallo, habe mir Heute die aktuellste Version von xamp runter geladen. Installiert, und scheint alles zu funktionieren. Habe noch die Pfade angepasst, so das es nach meinem Schema funktioniert.

Doch leider funktioniert mod_rewite nicht.
Das Modul wurde unter apache aktiviert, sowie
Code: Select all
AccessFileName .htaccess

Code: Select all
AllowOverride All


Meine Anwendung ist unter c:\WWW\Anwendung (localhost/anwendung) installiert. In meiner .htaccess steht folgendes.

Code: Select all
RewriteEngine on
RewriteBase /Anwendung/

RewriteRule ^index\.html$ /index.php [L]


Leider wird die .htaccess nicht beachtet. Habe ich jetzt einen Denkfehler, oder muss noch etwas aktiviert werden?
narc
 
Posts: 12
Joined: 16. January 2006 00:04

Postby deepsurfer » 16. January 2006 14:40

Testweise auch das probiert ??
Code: Select all
RewriteBase /WWW/Anwendung/
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby narc » 16. January 2006 14:53

Ja habe ich, leider funktioniert es so nicht.

Im ErrorLog von Apache steht folgendes
Code: Select all
127.0.0.1 - - [16/Jan/2006:14:49:38 +0100] "GET / HTTP/1.1" 200 4404
127.0.0.1 - - [16/Jan/2006:14:49:44 +0100] "GET /Anwendung/ HTTP/1.1" 301 373
127.0.0.1 - - [16/Jan/2006:14:50:01 +0100] "GET /Anwendung/ HTTP/1.1" 301 373
127.0.0.1 - - [16/Jan/2006:14:50:15 +0100] "GET /Anwendung/ HTTP/1.1" 200 9499
127.0.0.1 - - [16/Jan/2006:14:50:16 +0100] "GET /Anwendung/template/name/format.css HTTP/1.1" 304 -
127.0.0.1 - - [16/Jan/2006:14:50:16 +0100] "GET /Anwendung/template/name/img/point.gif HTTP/1.1" 404 1443
127.0.0.1 - - [16/Jan/2006:14:50:19 +0100] "GET /Anwendung/directory-788.html HTTP/1.1" 404 1385
narc
 
Posts: 12
Joined: 16. January 2006 00:04

Postby deepsurfer » 16. January 2006 15:18

Also das Rewrite klappt schonmal, nur werden die benötigten Unterpfade nicht mehr angesprochen daher erhältst du ein 403 Fehler auf point.gif und der directory-788.html

Sicherlich meldet sich gleich noch ein rewrite Spezie, der da helfen kann.

Ansonsten auch mal diese Bereich gelesen ?
http://modrewrite.de
http://modrewrite.info
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby narc » 16. January 2006 15:27

wie gesagt dieses projekt ist bereits länger online, mit den selben rewrite_rules, und es funktioniert alles tadelos.
narc
 
Posts: 12
Joined: 16. January 2006 00:04

Postby narc » 17. January 2006 19:16

kann mir den niemand helfen, ich brauche mod_rewrite unterstüzung unter xammp. das ist wirklich dringend.
narc
 
Posts: 12
Joined: 16. January 2006 00:04

Postby dpk » 17. January 2006 21:35

Hallo,
das Modul rewrite ist in Apache auskommentiert. Du musst das # in der xampp\apache\conf\httpd.conf bei "LoadModule rewrite_module modules/mod_rewrite.so" entfernen.
Na dann, viel Spass :)
dpk
 
Posts: 2
Joined: 17. January 2006 21:32

Postby narc » 17. January 2006 21:42

das ist mir bekannt, wie ich weiter oben geschrieben habe, ist dies bereits oben beschrieben. die mod_rewrite rule ist in der konfig datei auskommentiert, und die rechte auf all gestellt. online funktioniert es wunderbar, jedoch nicht bei mir lokal.
narc
 
Posts: 12
Joined: 16. January 2006 00:04

Postby narc » 18. February 2006 04:22

von unten holl,
leider funktioniert es immer noch nicht. können sich vielleicht die macher mal melden?
narc
 
Posts: 12
Joined: 16. January 2006 00:04

Postby Wiedmann » 18. February 2006 11:34

Such mal im Forum nach ".htaccess".

(Nebenbei könntest du uns auch verraten welchen XAMPP du hast.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby dekker » 18. February 2006 15:20

Hast du dir mal ein RewriteLog ausgeben lassen?
dekker
 
Posts: 6
Joined: 17. February 2006 19:06

Postby narc » 18. February 2006 15:29

@Wiedmann
ich habe das forum bereits abgegrast, aber leider keine lösung gefunden, die bei mir funktioniert. die xampversion ist die aktuellste 1.5.1 ohne perl

@dekker
ja, siehe weiter oben. leider immer ein 404 error. die htaccess habe ich schon in alle richtungen anzupassen, funzt aber leider auch nicht.

ich habe das gefüll, das mod_rewrite nicht läuft, da da noch irgenwo ein haken ist.
narc
 
Posts: 12
Joined: 16. January 2006 00:04

Postby narc » 20. February 2006 12:36

Mencsch, kann den niemand in diesem offiziele supportforum helfen? Es ist wirklich dringeng, und ich warte schon fast 1 monat :(
narc
 
Posts: 12
Joined: 16. January 2006 00:04

Postby narc » 27. February 2006 03:05

ich hoffe mir kann hier jemand helfen, ich bin langsam am verzweifeln.

kann mir bitte jemand sagen wo und was ich auskommentieren, einfügen, ändern muss, damit mod_rewrite funktioniert?

das forum habe ich hier bereits durchgerasst, was ich finden konnte ausprobiert, aber es läuft und läuft nicht :(
narc
 
Posts: 12
Joined: 16. January 2006 00:04

das könnte helfen

Postby fricare » 14. March 2006 01:18

in httpd.conf

suche in zeile 223
AllowOverride None
verändern in
AllowOverride all


suche in zeile 330
<Directory "C:/pfad/xampp/cgi-bin">
AllowOverride none
Options None
Order allow,deny
Allow from all
</Directory>


veränder in
<Directory "C:/pfad/xampp/cgi-bin">
AllowOverride FileInfo
Options None
Order allow,deny
Allow from all
</Directory>


dann müsste es gehen, natürlich muss mod_rewrite aktiviert sein sichheits halber phpinfo checken
fricare
 
Posts: 3
Joined: 28. October 2004 18:17

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests