Probleme mit MySql-Datenbank

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit MySql-Datenbank

Postby mxstyler » 14. January 2006 12:09

Hi Zusammen,

ich habe mir auf rechner Xampp Installiert. Es läuft alles auser mal wieder MySql. Der Dienst startet zwar aber kann wenn ich unter phpMyAdmin Datenbanken anlegen will oder sontiges machen will geht es nich kommt nur der Fehler:



Willkommen bei phpMyAdmin 2.6.3-pl1

phpMyAdmin hat versucht eine Verbindung zum MySQL-Server aufzubauen, jedoch hat dieser die Verbindung zurückgewiesen. Sie sollten Ihre Einstellungen für Host, Benutzername und Kennwort in Ihrer config.inc.php überprüfen und sich vergewissern, dass diese den Informationen, welche sie vom Administrator erhalten haben, entsprechen.

Fehler
MySQL meldet:

#2013 - Lost connection to MySQL server during query


kann mir da einer weiter Helfen. Was muss ich da jetzt machen bin ein ziemlicher neuling

danke schon ma im vorraus

mfg
Steffen Dech

mxstyler

http://www.mxstyler.com
http://www.mxstyler.de
Rechtschreibfehler sind gewollt
User avatar
mxstyler
 
Posts: 9
Joined: 14. January 2006 11:54

Postby deepsurfer » 15. January 2006 15:11

Willkommen bei phpMyAdmin 2.6.3-pl1

phpMyAdmin hat versucht eine Verbindung zum MySQL-Server aufzubauen, jedoch hat dieser die Verbindung zurückgewiesen. Sie sollten Ihre Einstellungen für Host, Benutzername und Kennwort in Ihrer config.inc.php überprüfen und sich vergewissern, dass diese den Informationen, welche sie vom Administrator erhalten haben, entsprechen.


Hast du das SecurityScript von XAMPP ausgeführt ??????

Wenn ja, dann müsstest du die config.inc.php im phpmyadmin editieren und dort die Passwörter hinzufügen die du im SecurityScript gewählt hast.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Ja hab ich

Postby mxstyler » 17. January 2006 15:15

Danke für deine Antwort. Wo find ich den die config datei?

Dann hab ich da noch eine frage wenn ich localhost eingeb dann komm ich immer auf die Xampp seit wo kann man den das noch änden?

Danke im vorraus

Steffen Dech
Rechtschreibfehler sind gewollt
User avatar
mxstyler
 
Posts: 9
Joined: 14. January 2006 11:54

Postby deepsurfer » 17. January 2006 15:21

Danke für deine Antwort. Wo find ich den die config datei?

\xampp\phpmyadmin --> config.inc.php

Dann hab ich da noch eine frage wenn ich localhost eingeb dann komm ich immer auf die Xampp seit wo kann man den das noch änden?

die index.html in \xampp\htdocs editieren, diese index.html beinhaltet einen 0 Sekunden META-weiterleitung auf das Verzeichniss \xampp\htdcos\xampp
Eine reine HTML-page ist das.

Wenn du diese index.html geändert hast vorsorglich noch den Browser-Cache leeren, damit auch die geänderte index.html angenommen wird.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 17. January 2006 16:34

\xampp\phpmyadmin --> config.inc.php

Mal abgesehen davon das Windows eine gute Suchfunktion hat, wenn man ja schon den Namen kennt, ist es nicht! nötig diese Datei von Hand zu ändern wenn man das Securityscript ausgeführt hat.

Es scheint ja eher ein Problem mit der Verbindung zum Server an sich zu geben (läuft er überhaupt?, OS?).

die index.html in \xampp\htdocs editieren, diese index.html beinhaltet einen 0 Sekunden META-weiterleitung auf das Verzeichniss \xampp\htdcos\xampp

Die Weiterleitung geschieht in der Datei "index.php" (und natürlich nicht über einen META-Refresh)...

Willkommen bei phpMyAdmin 2.6.3-pl1

... oder war das bei diesem alten XAMPP noch so? Dann stellt sich natürlich die Frage, warum bei einer neuen INstallation so ein alter genommen wird.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deepsurfer » 17. January 2006 16:43

Wiedmann wrote:Die Weiterleitung geschieht in der Datei "index.php" (und natürlich nicht über einen META-Refresh)...

Ahhhh.... ok...bei der 1.4.xx Version war es noch eine index.html mit META

Werde es aber behrzigen bei kommenden Versionen auch darauf zu schauen ;)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Danke

Postby mxstyler » 18. January 2006 13:46

Das mit der Umleitung habe ich jetzt geändert. Das geht

aber mit dem phpMyAdmin 2.6.3-pl1 da brauch ich jetzt noch hilfe was muss ich da ändern?

mfg Steffen

PS: Mit dem config.inc.php da hätte ich auch selbst drauf kommen können genau so wie mit dem php aber trotzdem danke bin ja noch ein anfänger
Rechtschreibfehler sind gewollt
User avatar
mxstyler
 
Posts: 9
Joined: 14. January 2006 11:54

Hallo?

Postby mxstyler » 29. January 2006 13:06

hatt keiner ne antwort dafür wäre wierklich wichtig
Rechtschreibfehler sind gewollt
User avatar
mxstyler
 
Posts: 9
Joined: 14. January 2006 11:54


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests