Port-Adresse 80 ändern?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Port-Adresse 80 ändern?

Postby aha! » 13. January 2006 17:59

Standardmäßig ist es doch so, dass
ich die Startseite von Apache erreiche,
wenn ich http://localhost:80 eingebe.

Wie kann ich die 80 abändern,
meinetwegen auf 8443?

Ist das ohne Weiteres machbar?

Besten Dank im Voraus


(hier steht zwar etwas, ich weiß aber nicht wo ich die änderungen vornehmen soll! http://httpd.apache.org/docs/2.0/bind.html )
aha!
 
Posts: 1
Joined: 13. January 2006 17:50
Location: Doha, Qatar

Postby deepsurfer » 13. January 2006 18:08

Ist das ohne Weiteres machbar?

ja

Ausgehend von XAMPP 1.5.1

Editiere die httpd.conf und auf Zeile 53 steht "Listen 80"
dort einfach die 80 gegen den Wert den du haben möchtest austauschen und Apache neu starten.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby binolino » 17. January 2006 11:10

Auf meinem System (XP SP2) läuft neben dem Apache (neuestes Xampp) noch ein IIS, den ich für ASP.Net-Programmierung benötige. Im Moment beende ich immer den IIS um Apache zu starten.

Den Listen-Port habe ich schon von 80 auf 85 getauscht; jetzt startet der Apache nicht mehr :(

was muss ich noch ändern, damit beide Webserver paralell laufen?

binolino
binolino
 
Posts: 4
Joined: 17. January 2006 11:02
XAMPP version: 7.0.8
Operating System: OS X El Capitain

Postby deepsurfer » 17. January 2006 14:06

Den Listen-Port habe ich schon von 80 auf 85 getauscht; jetzt startet der Apache nicht mehr Sad

was muss ich noch ändern, damit beide Webserver paralell laufen?

Dazu müsstest du noch die ssl.conf von XAMPP editieren, denn dort ist der SSLport 443 eingetragen der auch der IIS benutzt.

Ändere diesen mal in 445 (ich glaube zweimal vorhanden), dann sollte es gehen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 17. January 2006 14:10

Ändere diesen mal in 445 (ich glaube zweimal vorhanden), dann sollte es gehen.

445 ist kein guter Port da schon benutzt.

Abgesehen davon sollte man, wenn man Dienste auf abweichenden Ports betreibt, mind. Ports >1024 nehmen (am besten eigentlich über >49152).

Am einfachsten dürfte hier aber sein, SSL einfach zu deaktivieren.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests