iSafer Firewall & Apache geht nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

iSafer Firewall & Apache geht nicht

Postby gerrit » 08. January 2006 15:42

Hallo,

habe soeben festgestellt, dass es unmöglich ist Apache zum Laufen zu bekommen solange der iSafer Firewall Dienst läuft. Sogar wenn man die Firewall abschaltet, so dass eigentlich nichts geblockt wird geht es nicht. Zwar startet Apache sowieso, aber das Child crasht immer wieder mit der Fehlermeldung:
[Sun Jan 08 15:18:35 2006] [notice] Parent: child process exited with status 3221225477 -- Restarting.

Das einzige das hilft ist, den als Service installierten iSafer Dienst zu beenden. Dann geht alles wie geschmiert.

Ich muss sagen, das ist aber Sch*****! Die Firewall brauche ich eigentlich schon, so habe ich einige Anwendungen bei denen ich partout nicht gestatten kann, dass sie nach Hause telefonieren, sie tun es aber ob ich will oder nicht solange ich diesen Anwendungen den Zugriff aufs Netz gestatte.

Andererseits möchte ich aber auch auf Port 80 erreichbar sein, zumindest im lokalen Netz jedenfalls, leider schliesst sich das wohl gegenseitig aus.

Hier habe ich NT4 Server, ich habe schon verschiedene Firewall Software ausprobiert, die einzige die funktioniert hat war die Sygate Personal Firewall, alle anderen freien Firewalls haben entweder ihren Dienst aufgrund des Server Systems verweigert, haben zu Bluescreens beim Boot des Systems geführt, ich bin mit den Programmen irgendwie nicht zurechtgekommen bzw. sie haben nicht richtig funktioniert (z.B. ZoneAlarm). ASuch Sygate hat sich für meinen Geschmack zu tief in die System Innereien reingehängt und ich musste es entfernen als ich eine VPN Software installieren wollte.
Dann habe ich iSafer entdeckt, eine Firewall die auf Winsock Basis arbeitet, somit keine Problem bzgl. System und VPN, geht auch wunderbar auf meinem NT4 Server, ausser, dass es jetzt mit Apache nicht funzt. Inwieweit auch MySQL oder PostgreSQL in einer Xampp Installation Probleme haben mit iSafer konnte ich erstmal nicht weiter testen, Apache geht ja schon gar nicht. Wenigstens mal die MySQL Dienste laufen ohne Probleme. Auch andere Netzwerk-Serverdienste laufen hier ohne Probleme (Mikrosoft DNS, Xmailserver, Firebird, NetTime), d.h. diese haben kein Problem einen bestimmten Port an sich zu binden, Apache scheint das auf irgendeine seltsame Art und Weise anders zu machen.

Hat vielleicht jemand einen Tipp wie ich dennoch Apache und Firewall zusammen zum Laufen bekommen kann?


MfG,
Gerrit
gerrit
 
Posts: 31
Joined: 09. November 2005 02:43

Postby Wiedmann » 08. January 2006 15:48

Hat vielleicht jemand einen Tipp wie ich dennoch Apache und Firewall zusammen zum Laufen bekommen kann?

Was deine spezielle angeht nicht.

Was funktioniert ist die alte Kerio Firewall (nicht die Neue die es auch in einer Serverversion gibt). Musst halt schauen ob die noch wo findest. Die war damals noch Freeware und lief auch unter einem Server OS.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby gerrit » 08. January 2006 18:18

Wen es interessiert, die 4er Kerio geht nicht auf NT4, die "gute" alte Kerio Personal Firewall 2.15 kann man aber immer noch runterladen bei Kerio im Archiv, gibt bei mir auf NT4 aber einen BlueScreenOfDeath... kurz BSOD: http://download.kerio.com/dwn/kpf/kerio ... en-win.exe
Da gibt es auch die englische Doku dazu: http://download.kerio.com/archive/

Ich habe jetzt wieder die Sygate Personal Firewall, die klappt auch auf NT4 (auch Server), gibt es weiterhin auf http://www.sygate.de/ (bis auf Widerruf auf dieser Seite).

MfG
gerrit
 
Posts: 31
Joined: 09. November 2005 02:43


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests

cron