ich kann per GCI/Perl ein Modul nicht lokatieren

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

ich kann per GCI/Perl ein Modul nicht lokatieren

Postby Lucky-Joe » 07. January 2006 16:00

Hallo an all,

ich bin ein Neuling beiWebbased-Apllications aber habe eigentlich alles gut hinbekommen bis auf eine Geschichte: CGI/Perl-Zugriff auf Bugzilla.

ich habe folgende Fehlermeldung beim Aufruf von :

http://www.mydomain.de/bugzilla/index.cgi

Code: Select all
[Sat Jan 07 15:48:37 2006] [error] [client 127.0.0.1] Premature end of script headers: index.cgi
[Sat Jan 07 15:48:37 2006] [error] [client 127.0.0.1] Can't locate Bugzilla/Constants.pm in @INC (@INC contains: . C:/Programme/xampp/xampp/Perl/lib C:/Programme/xampp/xampp/Perl/site/lib) at F:/Data/Downloads/Bugzilla/bugzilla-2.20/index.cgi line 40.\r
[Sat Jan 07 15:48:37 2006] [error] [client 127.0.0.1] BEGIN failed--compilation aborted at F:/Data/Downloads/Bugzilla/bugzilla-2.20/index.cgi line 40.\r


ich habe alle Einstellungen geprüft und kann mir noch vielen Tagen Suche keinen Reim drauf machen, kann mir jemand weiterhelfen ?

t.i.a
Joe
Lucky-Joe
 
Posts: 4
Joined: 07. January 2006 15:50

Postby deepsurfer » 07. January 2006 16:14

[Sat Jan 07 15:48:37 2006] [error] [client 127.0.0.1] Can't locate Bugzilla/Constants.pm in @INC (@INC contains: . C:/Programme/xampp/xampp/Perl/lib


Schau mal beim BugZilla rein ob die dieses Constants.pm mitgeliefert haben und diese in den Pfad kopieren der dort beschrieben.

Ich mein mich aber zu erinnern das hier noch jemand diesen BugZilla benutzt, schau mal in den Threads der letzten paar Tage, ich mein es war um Sylvester rum.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Lucky-Joe » 07. January 2006 16:20

dieses Modul Bugzilla/Constants ist bei mir vorhanden, das ist es ja was ich nicht verstehe :(

ich könnte mir vorstellen, daß es ein rechteproblem ist, denn auch das index.cgi wird nicht automatisch aufgerufen, von Hand jedoch klappt es.
Ich habe auch eine eigens index.cgi erstellt mit ner einfachen print-Meldung, diese hat funktioniert

thanks

Joe
Lucky-Joe
 
Posts: 4
Joined: 07. January 2006 15:50

Postby deepsurfer » 07. January 2006 16:26

dieses Modul Bugzilla/Constants ist bei mir vorhanden, das ist es ja was ich nicht verstehe

Hast du auch dieses Constants.pm in das C:/Programme/xampp/xampp/Perl/lib Verzeichnis kopiert ?
(mit sicherheit nicht, sonst sähe dein Antwort anders aus ;) )

Dazu auch am besten das PERL-Addon von XAMPP herunterladen und einbinden, so wie es scheint verlangt der Bugzilla nachher noch mehr.

Das das CGI nicht gestartet wird klingt für mich danach das du möglicherweise den DocumentRoot geändert hast und oder einen VHOST oder ALIAS benutzt ohne CGI Anweisung.
Hast du so etwas in der Art eingebaut ????
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Lucky-Joe » 07. January 2006 16:34

ich werde das Perl-Add-On gleich mal runterladen und installieren!

Für mein Bugzilla habe ich folgende Zeilen im HTTP-Conf hinzugefuegt:

Code: Select all
ScriptAlias /bugzilla   "f:/Data/Downloads/Bugzilla/bugzilla-2.20"

<Directory "/bugzilla">
  AddHandler cgi-script .cgi .exe .pl .pm
  Options +Indexes +ExecCGI +FollowSymLinks
  DirectoryIndex index.cgi
  AllowOverride Limit
</Directory>
Lucky-Joe
 
Posts: 4
Joined: 07. January 2006 15:50

Postby schotti » 02. February 2006 01:41

könnte es an den rechten liegen ?
schauh mal ob in der datei /etc/apache2/uid.conf weiterkommst

du führst das teil wahrscheinlich mit den falschen rechten aus


...die schepang könnte auch falsch sein !

und versuche mal vielleicht die anführungszeichen bei "bugzilla"zu löschen !
schotti
 
Posts: 4
Joined: 02. February 2006 01:25

Postby deepsurfer » 05. February 2006 13:09

könnte es an den rechten liegen ?
schauh mal ob in der datei /etc/apache2/uid.conf weiterkommst

Er hat ein Windows System ;)

...die schepang könnte auch falsch sein !

Stimmt, das wäre noch drinn..

@Lucky-Joe
Wie siehts aus ?
Läuft ... läuft nicht ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests