Kann über IP nicht auf Apache2 zugreifen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Kann über IP nicht auf Apache2 zugreifen

Postby Brain » 07. January 2006 15:41

Hallo!!
Ich habe das oben beschriebene Problem.
OK, so ein Thema kam schon vor kurzem aber es hat mir nicht geholfen.

Ich kann zwar über localhost auf den Server und ich kann mich auch anpingen.
Aber über meine IP, die vom Provider angegeben wurde, kann ich nicht auf den Apache2-Server zugreifen.

Ich benutze XAMPP für Windows v. 1.5.0-pl1

Der FTP-Server und alles andere funktioniert, eben außer http apache.
Die Ports 80 und 81 sind frei.

Ich habe alles auf "Sicher" gemacht, außer "PHP im Safe Mode".
Die Services laufen alle.

Danke schon im Voraus.
Brain
 
Posts: 4
Joined: 07. January 2006 15:33

Postby deepsurfer » 07. January 2006 15:48

OK, so ein Thema kam schon vor kurzem aber es hat mir nicht geholfen.

welche hilfe meinst du da ?

Der FTP-Server und alles andere funktioniert, eben außer http apache.
Die Ports 80 und 81 sind frei.

das heisst, das jemand von aussen auf dein server per ftp kommen kann, dann ist also auch Port 21 bei dir frei

- Hast du acuh geschaut ob dein Router ein eigene Firewall hat ?
- Hast du geschaut ob auf dem PC wo XAMPP läuft ein mögliche Firewall entsprechend konfiguriert ist ?
- Welche Fehlermeldung erhältst du denn beim aufruf ?
- mit welchen eingaben versucht du im Browser zu testen ?



Danke schon im Voraus.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Brain » 07. January 2006 16:01

1. http://community.apachefriends.org/f/viewtopic.php?t=15291

2. Ja Ports 20, 21, 80 und 81 sind frei. Ich habe sogar alle Ports auf meinen PC freigeschaltet, da gab es also keinen einzigen gesperrten Port mehr. Hat aber auch nicht funktioniert.

3. http://localhost
http://localthost:80 od. :81
http://meine ip

4. Ja, der Router hat eine eigene Firewall. Die habe ich deaktiviert. Funktioniert auch nicht.
Brain
 
Posts: 4
Joined: 07. January 2006 15:33

Postby Brain » 07. January 2006 22:59

Weiß jemand die Lösung???

Muss ich da noch was in der "httpd.conf"- oder in der "hosts"-Datei von Windows was ändern?

Localhost funktioniert ja. Ich kann nur nicht über's Internet auf den Server zugreifen.
Brain
 
Posts: 4
Joined: 07. January 2006 15:33

Postby DaKu » 08. January 2006 00:20

unter:

ServerName (in der Original http so in Zeile 300)

in der http.conf die IP Adresse eintragen, auf die er hören soll, also die von deinem Provider, oder den DNS Namen
wer BÖHSEs sät, wird ONKELZ ernten
DaKu
 
Posts: 11
Joined: 07. January 2006 19:06

Postby Brain » 08. January 2006 00:37

Also ich habe das Problem entdeckt, kenne aber weder die Ursache noch den Ursprung:
Ich habe einen Port-Scan durchgeführt, es sind 21 und 80 offen. So soll es sein.

Ein Freund von mir hat den Port-Scan mit dem selben Programm von außen auf meine IP durchgeführt, und das Programm hat angezeigt, dass nur Port 21 offen ist.

Obwohl im Router 21 und 80 aktiviert wurden.
Wie ist das zu erklären?
Brain
 
Posts: 4
Joined: 07. January 2006 15:33

Postby KingCrunch » 08. January 2006 01:09

Tja, kein passender Forward oder Firewall im Router. Das sind die Punkte, die mir spontan einfallen.
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests