Kann meinen Server nicht von außen erreichen.

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Kann meinen Server nicht von außen erreichen.

Postby ACID » 03. January 2006 06:58

Hi, habe da ein großes Problem.
Ich habe Xampp installiert, alles wunderbar. In meinem Router die Port-Weiterleitung zu meinem Rechner gemacht und die benötigten Ports freigegeben.
Dann habe ich bei DYNDNS mir eine Adresse besorgt (http://frankthetank.dyndns.org). Der DYNDNS-Updater funktioniert auch wunderbar. Aber jedesmal wenn ich meinen Rechner über die Adresse oder meine IP (die online-ip) erreichen will kommt die Fehlermeldung "Das Dokument enthält keine Daten.". Im lokalen Netz kann ich über die IP des Rechners zugreifen ist schon komisch.
Habe meine Ports mal testen lassen "https://www.grc.com/x/ne.dll?bh0bkyd2" und die ports 80,443,3306,21 sind offen.
Kann mir bitte Jemand helfen.
ACID
 
Posts: 7
Joined: 14. December 2005 21:41

Postby Tiberiu » 03. January 2006 09:27

also bei mir funktionierts, wenn ich die DYNDNS Adresse eingebe komme ich zum Login Fenster zu Xampp aber ich kenn ja das PW nicht.
Du erreichst deine Dateien so http://frankthetank.dyndns.org/ordner/
Weil er leitet dich automatisch auf den ordner xampp um.. das kann man auch ändern.
Tiberiu
 
Posts: 18
Joined: 18. December 2005 09:13

Postby KingCrunch » 03. January 2006 10:36

DynDNS ist solange du es nicht innerhalb des Netzwerks auflöst, innerhalb des Netzwerks nicht erreichbar. Gab hier diesbezüglich schon Themen. Das heißt nur, dass du nicht aus deinem Netzwerk rausgehen kannst und von daher (per DnyDNS) wieder zurück in dein Netzwerk.

---

Ich glaub, [ur=http://community.apachefriends.org/f/viewtopic.php?t=14973]der hier[/url] wars.
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby ACID » 03. January 2006 17:44

Danke erst mal für die schnelle hilfe.
Über diese Adresse komm ich jetzt auch rein.
Da ich einen Speedport W 500v Router+Modem habe, denke ich mal das da ein kleines problem bestand.
Mich würde mal Interressieren wie ich die meine weiterleitung nun richtig einrichte. Sprich die Logs Richtig einstelle.
Ich habe es zur Zeit so stehen.
Code: Select all
<VirtualHost *>
    ServerAdmin XXX@WEB.DE
    DocumentRoot "F:/binaries/xampp/htdocs/www"
    ServerName frankthetank.dyndns.org
    #ErrorLog "F:/binaries/xampp/apache/logs/http.ag-intranet.error"
    #CustomLog "F:/binaries/xampp/apache/logs/access_log.ag-intranet common"
</VirtualHost>


Doch wenn ich die Logs auskommentiere startet Apache nicht mehr.
ACID
 
Posts: 7
Joined: 14. December 2005 21:41

Postby deepsurfer » 03. January 2006 17:46

Code: Select all
#ErrorLog "F:/binaries/xampp/apache/logs/http.ag-intranet.error"
#CustomLog "F:/binaries/xampp/apache/logs/access_log.ag-intranet common"


Die zwei rauten (#) davor löschen und darauf achten das das Verzeichnis
logs unterhalb von F:/binaries/xampp/apache/ existiert.

Dann laufen die LOGs automatisch.

PS: Nach Änderungen in der httpd.conf den Apachen neu starten lassen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests