xampp und Zend Studio Server 5 - installationsprobleme

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

xampp und Zend Studio Server 5 - installationsprobleme

Postby netspeedy » 12. December 2005 19:39

Ich versuche den Zend Studio Server zu installieren und habe die aktuelle Version von XAMPP installiert.

Welche Angaben muss ich bei der installation machen?
d.h. soll ich "Apache Server 2.x" auswählen, oder "Other Web server"
was ist das root verzichnis des servers? "xampp\apache\"?

und für die php.ini "xampp\apache\bin" oder "xampp\php"

kann mir jemand ne art kurzanleitung schreiben, wie ich den zend studio server auf xampp installiere?
ich komm da nicht mehr weiter.. :(
es wird im browser immer "Zend Optimizer not installed" angezeigt..
netspeedy
 
Posts: 3
Joined: 12. December 2005 18:45

Postby deepsurfer » 12. December 2005 22:48

Soweit ich weiss ist in diesem teuren Zend-Studio-Server ein komplettes Rundumpaket enthalten, so auch einen Apachen und PHP den man sich Installieren kann.

Schau dazu mal in der Anleitung nach, daraus kannst du die Pfad anweisungen auf XAMPP umsetzen.


es wird im browser immer "Zend Optimizer not installed" angezeigt..

das hat was mit den Pfaden zu den exstansion zutun, die liegen innerhalb des XAMPP.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby netspeedy » 12. December 2005 23:11

also bei zend studio ist nur apache 1.x dabei um es mit zu installieren.. bei 2.x wird der apache nur angepasst - http.conf wird verändert und die php.ini - so wie ich das bisher mitbekommen habe.. von den daten werden jedenfalls backups gemacht..
netspeedy
 
Posts: 3
Joined: 12. December 2005 18:45

xampp und zend server 5.0

Postby punknroll » 04. January 2006 08:31

ich habs geschafft, beides zu installieren. also zuerst mal xampp. wenn da alles passt, dann den zend server installieren. server version 5.1 hat bei mir nicht funktioniert. die 5.0 installation hat geklappt. dann musste ich noch händisch den zend optimizer installieren und in der php.ini den parameter

zend_optimizer.enable_loader = 1

setzen. jetzt funktioniert xampp und der zend studio server!

greetz
andi
punknroll
 
Posts: 6
Joined: 04. January 2006 07:59

..noch was vergessen

Postby punknroll » 04. January 2006 08:32

achja, bei der zend.server installation hab ich apache 2.x ausgewählt und use existing php version. ist laut zend auch besser so!
punknroll
 
Posts: 6
Joined: 04. January 2006 07:59

Postby netspeedy » 04. January 2006 13:49

zend_optimizer.enable_loader = 1

thx genau das war's :D
jetzt klappt alles :-)
netspeedy
 
Posts: 3
Joined: 12. December 2005 18:45

5.1?

Postby punknroll » 04. January 2006 17:52

du hast aber auch den zend studio server 5.0 laufen oder funzt bei dir 5.1?
punknroll
 
Posts: 6
Joined: 04. January 2006 07:59

Gleiches Problem

Postby Che » 05. January 2006 09:32

Ich habe das gleiche Problem - wo kriege ich denn die Studio Server Version 5.0 her?
Che
 
Posts: 6
Joined: 04. November 2004 21:36

Re: Gleiches Problem

Postby deepsurfer » 05. January 2006 14:27

Che wrote:Ich habe das gleiche Problem - wo kriege ich denn die Studio Server Version 5.0 her?

Kaufen.... bei www.zend.com
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Che » 05. January 2006 17:41

deepsurfer wrote:Kaufen.... bei www.zend.com


Ist leider ein Wink in die falsche Richtung :( - denn bei zend ist die Folgeversion, eben die nicht lauffähige Version 5.1 zu kaufen oder zum Test herunterzuladen - was nutzt mir dieser Hinweis auf zend? Es sei denn "deepsurfer" hat den Fehler in der Installationsroutine des servers 5.1 gefunden. Dann bitte posten - sonst bleibt nur der support bei zend ... :idea: aber die haben mir bisher auch nicht weiterhelfen können :(

Ich bleibe aber dran ... bis dahin eben weiter phpedit ...
Che
 
Posts: 6
Joined: 04. November 2004 21:36

Postby KingCrunch » 05. January 2006 17:44

Was spricht gegen Eclipse mit PHPEclipse?
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby deepsurfer » 05. January 2006 18:21

Che wrote:
deepsurfer wrote:Kaufen.... bei www.zend.com


Ist leider ein Wink in die falsche Richtung :( - denn bei zend ist die Folgeversion, eben die nicht lauffähige Version 5.1 zu kaufen oder zum Test herunterzuladen - was nutzt mir dieser Hinweis auf zend? Es sei denn "deepsurfer" hat den Fehler in der Installationsroutine des servers 5.1 gefunden. Dann bitte posten - sonst bleibt nur der support bei zend ... :idea: aber die haben mir bisher auch nicht weiterhelfen können :(

Ich bleibe aber dran ... bis dahin eben weiter phpedit ...


Den Fehler in der 5,1 hab ich nicht gefunden, da ich kein Geld für sowas hab.

Der Hnweis "Kaufen.... www.zend.com" war eine Direkte Antwort deine Frage, denn mit Sicherheit ist bei Zend selber, auf Anfrage, die 5.0 noch zu haben.

Da du aber schon mit dem Support in Verbindung stehst, wäre die Frage nach dem Erwerb der 5.0 ja nicht abwegig.

Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Che » 06. January 2006 11:50

Für alle, die Zend Studio 5.1 testen wollen:

Zend Support Center wrote:* 06.Jan.2006 01:03:22 Jacob Shucart Deferred

Hello Che,

There have been a couple of other reports of the same problem. We have a temporary workaround. Here are some manual installation instructions:

Here are manual installation instructions:
Make sure you have a running web server with PHP on it.
Download the package
http://downloads.zend.com/support-files ... indows.zip
and extract it under the Program Files directory on your machine.
Next, download the package
http://downloads.zend.com/support-files ... .0-GUI.zip
and extract it under your web server's document root.

Next, add the following section to the bottom of your php.ini file:

[Zend]
zend_extension_manager.optimizer_ts="C:\Program
Files\Zend\ZendStudioServer-5.1.0\lib\Optimizer-2.6.1"
zend_extension_ts="C:\Program
Files\Zend\ZendStudioServer-5.1.0\lib\ZendExtensionManager.dll"
zend_extension_manager.debug_server_ts="C:\Program
Files\Zend\ZendStudioServer-5.1.0\lib\Debugger-5.1.0"
studio.install_dir="C:\Program Files\Zend\ZendStudioServer-5.1.0"
zend_debugger.expose_remotely=allowed_hosts
zend_gui.ini_modifier="C:\Program
Files\Zend\ZendStudioServer-5.1.0\sbin\ini_modifier.exe"
zend_debugger.deny_hosts=
zend_gui_password=81dc9bdb52d04dc20036dbd8313ed055
zend_debugger.allow_hosts=127.0.0.1/32, <ADD YOUR MACHINE'S IP HERE>
zend_debugger.allow_tunnel=127.0.0.1/32
zend_ini_file="C:\Program Files\Zend\ZendStudioServer-5.1.0\etc\zend.ini"
;----------end of Zend section -----------

Please also create a file called dummy.php in your document root. This is used by the debugger.

Make sure that all paths are valid and replace the <ADD YOUR MACHINE'S IP HERE> with your client machine's IP (the one that ZDE is installed
on) in the directive: zend_debugger.allow_hosts.
Note that the password for the Zend Studio Server GUI (accessible form http://<your server name>/ZendStudioServer/studio/index.php) is '1234'.

Let me know if you encounter any problems with this manual installation


Please don't hesitate to contact us with any additional questions.

-----------------------------------------------------------
Thank you for contacting Zend Support Center.


Damit wird manuell die StudioServer Version 5.0 installiert. Die InstallerVersion des Servers 5.0 wäre evtl. einfache zu installieren aber immerhin, es funktioniert ...
Che
 
Posts: 6
Joined: 04. November 2004 21:36


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests