Fehleer 404 bei eigenen Dateien

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Fehleer 404 bei eigenen Dateien

Postby xcrash » 26. November 2005 22:36

Hallo

Ich habe Xampp installiert. Funktioniert auch komplett. Es startet die Xampp Seite. Wenn ich jedoch unter c:\xampp\htdocs\eine Datei rein kopiere Bsp. : test.php und ich diese aufrufen möchte, kommt immer die Fehlermeldung, dass die Datei nicht existiert. Also Fehler 404 !

Auch wenn ich ein Unterverzeichnis dort einrichte und dort Dateien rein kopiere, es ist immer das gleiche :-(

Was muss ich machen ?
xcrash
 
Posts: 3
Joined: 26. November 2005 22:30

Postby xcrash » 26. November 2005 22:56

Mir ist gerade was aufgefallen.
Wenn ich unter localohost/xampp/datei.php aufrufe (datei.php kann eine x-beliebige Datei von Xampp sein) dann ruft er sie auf. Kopiere ich dort eine eigene php datei rein und möchte diese starten, geht es wieder nicht.

Also irgendwas stimmt da nicht !!

Kann mir mal jemand helfen ?
xcrash
 
Posts: 3
Joined: 26. November 2005 22:30

Postby deepsurfer » 27. November 2005 08:53

http://faq.kwm-web.info/doku.php?id=xam ... r_aufrufen

Einen absatz tiefer wird erklärt wie man eigene Pages in XAMPP einbindet.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby xcrash » 27. November 2005 09:27

na was hab ich denn getan?

steht doch eigentlich oben, dass ich es genauso gemacht habe und es funktioniert nicht !!

MAn sollte nicht nur einfach kurz nen link reinschreiben und denken, der ist so doof und weis nicht mal wo man seine eigenen Dateien reinkopieren muss !!
xcrash
 
Posts: 3
Joined: 26. November 2005 22:30

Postby deepsurfer » 27. November 2005 10:23

MAn sollte nicht nur einfach kurz nen link reinschreiben und denken, der ist so doof und weis nicht mal wo man seine eigenen Dateien reinkopieren muss !!

Komm mal wieder runter ! Es hatte schon seinen Sinn gehbat und ich halte dich nicht für "doof".
Es gab und es wird leider immer wieder User geben die es falsch machen, und bevor ich ein Fragekatalog ablasse und zum schluss rauskommt das der User einfach nur einen Aufruf bzw. Plazierungsfehler gemacht hat, so ist das in diesem Fall nun bei dir jetzt ausgeschlossen.
oder schreibst du im browser http://localhost/xampp/test.php
oder http://localhost/xampp/unterverzeichnis/test.php auf obwohl die datei im xampp\htdocs Verzeichnis liegt und der aufruf somit http://localhost/test.php heist.

Denn das hast du nicht geschrieben !

Der 404 Fehler besagt eindeutig das der Webserver die Datei nicht dort fndet wo sie im browser angefordert wird.

Desweiteren, leere mal den BrowserCache.
Es hat sich gezeigt das oftmal Fehlaufrufe auch von daher kommen.


EDIT:
Wenn man auch nur an den Teufel denkt ist er meist nicht fern ;)
http://community.apachefriends.org/f/viewtopic.php?t=14709
Bestes beispiel dafür was ich meine mit Userfehler.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 3 guests