kopierte Seite vom Hoster läuft nicht unter Xampp

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

kopierte Seite vom Hoster läuft nicht unter Xampp

Postby erika Spunkt » 21. November 2005 20:54

Hallo Freunde der Nacht,

ich bitte ein weiteres mal um eure Hilfe:

ich habe meine Webseite von 1und1 komplett heruntergeladen
und unter xampp abgespeichert.

Nu zum problem:
die statischen seiten werden angezeigt.
Nicht jedoch die dyn. erzeugten und mit mode rewrite veränderten
Seiten.
mode rewrite ist in der httpd.conf eingeschaltet.

Wie gesagt, die Seite ist komplett d.h. incl. der .htaccess herunter
kopiert worden.
Auf dem Server läuft alles, jedoch nicht unter Xampp.

selbst mit
Code: Select all
RewriteEngine On

ErrorDocument 404 /fehlerseite.html


wird die Fehlerseite nicht angezeigt.
D.h. das die .htaccess ignoriert wir.d
Woran kann das liegen ?

mfg
Erika S.
erika Spunkt
 
Posts: 4
Joined: 20. November 2005 12:22

Postby deepsurfer » 22. November 2005 16:11

Code: Select all
RewriteEngine On

ErrorDocument 404 /fehlerseite.html

Welches XAMPP benutzt du ?

Hast du das RewriteEngine On nur für die Fehlerseite ?, wenn ja so ist das unnötig, denn die ErrorDocument Definition braucht kein rewrite dazu.

Wo liegt diese htaccess ? im DocumentRoot Pfad oder in einem Unterverzeichnis davon ?
Ich frage deswegen weil diese schreibweise davon ausgeht das die fehlerseite.html in \xamp\htdocs\ Pfad liegt.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby erika Spunkt » 22. November 2005 16:53

besten Dank für die Hilfe, ich habe das problem eben selber lösen können.

es hat in der httpd.conf der Eintrag
AllowOverride All
gefehlt.

D.h. gefehlt hat er nicht.
Xampp hatte gestern damit rumgemuckt.
Daher habe ich ihn ausgeklammert.

Da es sich nur um einen auszug der .httaccess handelt steht dort noch
das
RewriteEngine On
drin.
Es folgen anschließend die Bedingungen.

es klappt jetzt jedenfalls und ich kann endlich wieder arbeiten.

nochmals besten Dank.

tschau
Erika S.
erika Spunkt
 
Posts: 4
Joined: 20. November 2005 12:22


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests